Jump to content
Sam1993

Erreur 500 aprè tentative de mise à jour des modules

Recommended Posts

Bonjour,

Je viens de reprendre un vieux site sur prestashop 1.6 qu'une amie m'a demandé de mettre à jour pour elle.
Le problème est que vous voulez mettre à jour les modules, tout a planté en ayant une page avec erreur 500, donc après quelques recherches sur le web j'ai modifié le fichier config / define.inc.php à la ligne 28 comme indiqué j 'ai remplacé 

 

par 

 

donc en actualisant la page https: //www.licence-kids.com/shop/admin .......  j'ai désormais le message d'erreur suivant :

Erreur d'analyse: erreur de syntaxe, '[' inattendu dans /home/licencek/www/shop/modules/paypal/api/sdk/braintree/lib/Braintree.php sur la ligne 17

Pourquoi? Quel est le rapport avec le module Paypal, je n'arrive plus du tout à accéder au Cpanel, merci de m'aider à résoudre ce soucis.

PS: sur le ftp j'ai passé tout le contenu du site en CHMOD 755

Edited by Sam1993
Suppression d'un lien confidentiel de mon accès admin (see edit history)

Share this post


Link to post
Share on other sites

On dirait une version incompatible de PHP. Quelle version de PHP utilisez-vous ?

Share this post


Link to post
Share on other sites
24 minutes ago, Sam1993 said:

 

Parse error: syntax error, unexpected '[' in /home/licencek/www/shop/modules/paypal/api/sdk/braintree/lib/Braintree.php on line 17

 

Bonjour,

Il faut  enlever le lien  vers votre  page admin  on  a  pas besoin de le voir  pour vous aider .

Il ne faut  jamais  poster  le lien admin  en publique.

 

 

Edited by ndiaga (see edit history)

Share this post


Link to post
Share on other sites

lol @ndiaga en le citant tu affiches le lien une fois de plus :)

    $requiredExtensions = ['xmlwriter', 'openssl', 'dom', 'hash', 'curl'];

a remplacer par 

    $requiredExtensions = array('xmlwriter', 'openssl', 'dom', 'hash', 'curl');

Mais il serait bon de connaitre votre version PHP

Share this post


Link to post
Share on other sites
10 minutes ago, joseantgv said:

On dirait une version incompatible de PHP. Quelle version de PHP utilisez-vous ?

@Eolia @joseantgv Aucune idée, j'ai cherché sur le compte OVH je n'ai pas trouvé et comment puis-je le savoir autrement je n'arrive plus à acceder au Cpanel de Prestashop ? Et la ligne à modifier que vous m'indiqué c'est sur quel fichier ?

Edited by Sam1993
Oublié de mentionner quelqu'un (see edit history)

Share this post


Link to post
Share on other sites
7 minutes ago, Eolia said:

lol @ndiaga en le citant tu affiches le lien une fois de plus :)

 

 

 

Je  voulez  attirez  son  attention  avant d’éditer  .   lol

Share this post


Link to post
Share on other sites

Compte OVH -> WEB -> hébergement -> Votre nom de domaine

La ligne modifiée est celle indiquée par votre log d'erreur:

il y a 44 minutes, ndiaga a dit :

/home/licencek/www/shop/modules/paypal/api/sdk/braintree/lib/Braintree.php on line 17

 

Share this post


Link to post
Share on other sites

@EoliaJ'ai réussi à régler le soucis en basculant en PHP 7.0 mais un seul module ne veut pas se mettre à jour, bizarrement mais pour les reste c'est bon Et suis-je obligé de payer un module pour sécuriser le site et le passer en https ou bien je peux créer un htaccess que j'upload sur le ftp ?

Edited by Sam1993 (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More