Jump to content
tyler06_34

Snippet "brand" et "url"manquant sur Product.tpl (Prestashop 1.6)

Recommended Posts

Bonjour,

 

Suite aux avertissements remontés dans la Google Webmasters Tools, j'ai réussi :

- à retirer toutes les références Rich-Snippet de la page catégorie (un sujet du forum traite du sujet). Ces éléments n'ont à priori rien à faire dans les pages de collection de produit. Il suffit pour cela de retirer toutes les occurrences des itemprop, itemscope,  itemtype etc... dans le fichier product-list.tpl

- à corriger le problème sur Format de prix non valide dans la propriété "price", celui ci faisait apparaître la currency. Du coup j'ai forcé le content de la propriété price pour ne plus faire apparaître la currency dans product.tpl => itemprop="price" content="{$productPrice}"

- à corriger le problème Champ "priceValidUntil" manquant en forçant dans product.tpl :

<meta itemprop="priceValidUntil" content="{($smarty.now + (60*60*24*15))|date_format:"%Y-%m-%d"}" />

 

Il me reste 3 problèmes à corriger. Et j'ai beau cherché sur le forum, je n'ai pas trouvé de solution clairement expliquée pour corriger sur product.tpl :

Champ "brand" manquant (forcer le nom du fabricant si connu, sinon forcer le nom du shop)

Champ "url" manquant (forcer l'url du produit)

Aucun identifiant global (code GTIN, référence fabricant ou ISBN) n'a été fourni (à défaut de ne pas avoir de ISBN, peut être forcer l'id du produit).

 

Beaucoup des réponses que j'ai trouvées concernait la version 1.7 de prestashop et non la version 1.6

Avez vous le code à insérer pour résoudre ses 3 avertissements (et l'endroit où cela doit être fait).

 

Merci infiniment pour votre aide ou pour vos sources sur le sujet. Je pense que cela pourrait aider pas mal de monde, il semble que de nombreux thèmes en 1.6 (dont celui par défaut) soit mal codés à ce sujet.

 

Sébastien.

 

 

 

Share this post


Link to post
Share on other sites
24 minutes ago, tyler06_34 said:

Il me reste 3 problèmes à corriger. Et j'ai beau cherché sur le forum, je n'ai pas trouvé de solution clairement expliquée pour corriger sur product.tpl :

Champ "brand" manquant (forcer le nom du fabricant si connu, sinon forcer le nom du shop)

Champ "url" manquant (forcer l'url du produit)

 

 

Bonjour,

Ces deux  champs  ne sont  pas sur la page détails produit pour la version 1.6   que je sache, ils  concernent  la version 1.7 .

Share this post


Link to post
Share on other sites

Ils ne le sont pas effectivement en l'état.

Cependant ma console Google Webmaster Tools m'avertit que ces 2 champs le devrait pour l'ensemble de mes pages produits. Du coup je cherche une solution pour lui fournir.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More