Jump to content
Sgarbo

Pagination.php ContextErrorException

Recommended Posts

Ciao a tutti!
Scrivo per un problema che sto riscontrando dopo aver aggiornato dalla versione 1.7.4 alla 1.7.6.2 solo su alcune pagine (pagina categorie e produttori) e non sulla singola pagina del prodotto.

Sto ottenendo l'errore che risulta nello screen allegato e non so come risolverlo... sapreste aiutarmi per favore?

Grazie

 

Versione attuale PS 1.7.6.2

Versione PHP 7.1

Schermata 2020-01-13 alle 15.50.44.png

Share this post


Link to post
Share on other sites

Ciao,

dopo aver fatto un backup completo aggiorna il tema, passando dalla versione 1.7.4 alla 1.7.6 alcune funzioni interne sono cambiate

Share this post


Link to post
Share on other sites

Oggi provo! Grazie mille!!!

2 minutes ago, mma87 said:

Ciao,

dopo aver fatto un backup completo aggiorna il tema, passando dalla versione 1.7.4 alla 1.7.6 alcune funzioni interne sono cambiate

 

Share this post


Link to post
Share on other sites

di nulla! poi fammi sapere se il problema si risolve

Share this post


Link to post
Share on other sites
On 1/14/2020 at 10:13 AM, mma87 said:

di nulla! poi fammi sapere se il problema si risolve

Ciao! Ho provato ad aggiornare il tema (manualmente perché il tema che ho acquistato prevede solo questo procedimento) sostituendo i vari file del vecchio template con quelli "aggiornati". Nella descrizione c'è scritto 'compatibile con Prestashop 1.7.6' ma continuo a ricevere lo stesso errore...

Ho provato a contattarli. Vediamo se propongono altre soluzioni

Grazie 😊 

Share this post


Link to post
Share on other sites
On 1/14/2020 at 10:13 AM, mma87 said:

di nulla! poi fammi sapere se il problema si risolve

Giusto per aggiornarti e se può essere utile a chi si trova/troverà (speriamo di no) nello stesso problema:

Il programmatore del tema dice che il tema è ok. È un problema di Prestashop, ha letto in giro altri casi. Al momento non ci sarebbe soluzione oltre ad un rollback alla versione 1.7.4.3 oppure 1.7.5

Alla fine ho fatto proprio questo. Fortunatamente ho backup giornalieri di file e database.

Però nel fare il rollback si sono creati due problemi:

Primo problema:  Internal Server Error 500 se tentavo di accedere al backend

Soluzione: Il problema era causato dal Modulo ps_linklist che va eliminato manualmente sia dalla cartella Modules principale che da quella che si trova nei template che usi;

 

Secondo problema: la pagina Prestazioni e quella Preferenze Generali risultavano irraggiungibili (sempre errore 500) a meno che non attivassi la modalità debug. Se attivavo la debug tutto funziona correttamente, altrimenti appena la disattivavo, niente, errore 500 in quelle due pagine.

Soluzione: eliminare manualmente le cartelle .../var/cache/dev e .../var/cache/prod

 

Ora sono tornato alla normalità.... Grazie comunque!

Share this post


Link to post
Share on other sites

Ciao,

ottimo per la soluzione che hai proposto e per aver risolto il tuo problema

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More