Jump to content
Andrea_17

Ordinamento prodotti in categoria

Recommended Posts

Salve ragazzi,

mi ritrovo con un problema abbastanza strano nell'ordinamento dei prodotti all'interno delle categorie. In pratica in parametri negozio > prodotti, ho selezionato "ordine di default=posizione nella categoria" e "metodo default ordine=crescente". Fin qui tutto ok, però poi quando vado a scegliere nelle categorie la posizione dei prodotti (con il metodo riordina), dopo un pò ritornano alle posizioni originali. Non riesco a capirne il perchè. L'unica cosa strana che ho notato è che alcuni prodotti occupano la stessa posizione (screen in allegato). A cosa potrebbe essere dovuto questo errore? A qualcuno è mai capitato? Vi ringrazio per l'attenzione e per eventuali suggerimenti o aiuti.715926970_Schermata2020-01-07alle08_25_52.png.9157e91f458634fe58c475ad475b9dee.png

Share this post


Link to post
Share on other sites

Ciao Andrea,

dopo aver riodinato premi il tasto riordina?

Share this post


Link to post
Share on other sites
13 minutes ago, mma87 said:

Ciao Andrea,

dopo aver riodinato premi il tasto riordina?

Ciao mma87, intanto grazie mille per la risposta. Si ho premuto sul tasto riordina. Inizialmente le posizioni rimangono invariate, ma se poi vado a cambiare nuovamente la posizione di un prodotto, le posizioni di tutte le categorie ritornano nelle posizioni antecedenti al primo ordinamento con le posizioni chiaramente duplicate. Non riesco a capire per quale motivo succede questa situazione. La versione di Prestashop che utilizzo è la 1.7.5.1.

Share this post


Link to post
Share on other sites

Scusami, volevo dire "Salva e ricarica" dopo aver riordinato.

inoltre assicurati di non avere filtri attivi.

Infine valuta anche di fare l'upgrade all'ultima versione di prestashop, potrebbe essere anche questo il problema

Share this post


Link to post
Share on other sites

Considera che ho appena fatto delle prove con un mio sito che ha la versione 1.7.6.2 e non ho questo problema

Share this post


Link to post
Share on other sites
Just now, mma87 said:

Considera che ho appena fatto delle prove con un mio sito che ha la versione 1.7.6.2 e non ho questo problema

Il fatto è che ho la stessa e medesima versione su un ambiente di test e li funziona tutto maledettamente bene, non ho posizioni duplicate e ho effettuato un sacco di test di spostamento, ma rimane tutto come deve essere (naturalmente ho analizzato nel dettaglio le probabili differenze anche nel db ed è tutto uguale). Non so veramente più dove andare a parare.

Share this post


Link to post
Share on other sites

prova a fare l'upgrade all'ultima versione, è la soluzione più facile.

ovviamente fa un backup prima.

se poi non va dovresti andare a fare il debug. nel caso ti spiego come farlo

Share this post


Link to post
Share on other sites

Il debug e l'analisi dell'errore l'ho già fatta e non mi viene segnalato nessun tipo di errore o avviso. Ho attivato sia la modalità di debug su Prestashop (sia da front che da back nessun errore) ed ho analizzato tutto anche con l'inspector e la console non segnala nessun errore. Potrebbe riguardare il gestionale? Ho controllato anche quello, ma li di posizioni e ordinamenti non ce ne sono. Valuterò il passaggio all'ultima versione, anche se ripeto, la stessa versione, lo stesso db, gli stessi prodotti sull'ambiente di test funziona alla perfezione.

Share this post


Link to post
Share on other sites

magari prova a vedere sul database se si modificano le posizioni oppure no.

la tabella è ps_category_product

(cambia ps_ con il tuo prefisso)

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, mma87 said:

magari prova a vedere sul database se si modificano le posizioni oppure no.

la tabella è ps_category_product

(cambia ps_ con il tuo prefisso)

provato anche questo, sulla versione ufficiale, le posizioni anche sul db ritornano come in precedenza, mentre sul test, la tabella ps_category_product rimane invariata con le posizioni correttamente settate. E' veramente qualcosa di inspiegabile. Ho provato anche a cambiare le posizioni direttamente dal db, ma nulla da fare.

Edited by Andrea_17 (see edit history)

Share this post


Link to post
Share on other sites

davvero strano. c'è qualcosa che resetta tutto però non so dirti cosa, mi dispiace

Share this post


Link to post
Share on other sites
3 minutes ago, mma87 said:

davvero strano. c'è qualcosa che resetta tutto però non so dirti cosa, mi dispiace

si molto strano direi. Ti ringrazio tantissimo per il confronto, sei stato molto gentile. Grazie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More