Jump to content
Yebo

La page n’est pas redirigée correctement

Recommended Posts

bonjour

j'ai installé une boutique en ligne prestashop sur mon serveur distant et local .

le local avec wampserveur fonctionne parfaitement mais le distant ne fonctionne qu'avec le BO (tableau de bord) . lorsque je souhaite voir la boutique en ligne j'ai le message suivant :" La page n’est pas redirigée correctement . Firefox a détecté que le serveur redirige la demande pour cette adresse d’une manière qui n’aboutira pas. . La cause de ce problème peut être la désactivation ou le refus des cookies."

la question doit être souvent posée mais je n'ai pas trouvé la réponse .

merci à celle ou celui qui pourra m'aider à résoudre ce problème

 

Share this post


Link to post
Share on other sites

Vérifiez vos paramètres SEO & URL et votre configuration ssl (https)

Mais bon, sans URL c'est compliqué de vous aider, nous ne sommes pas devins^^

Share this post


Link to post
Share on other sites

Merci pour ces réponses

la base de donnée doit être bien configurée car elle a été créée automatiquement lors de l'installation de prestashop sur mon serveur distant . je n'ai pas migré le local car il ne me sert qu'à faire des essais et à pratiquer sur l'administration . en local, prestashop fonctionne parfaitement .

 

Pour Eolia

Lorsque je tente de me connecter sur mon site , qui est un sous-domaine pour l'instant, https://presta.joane.fr, je tombe sur le message : La page n’est pas redirigée correctement . Firefox a détecté que le serveur redirige la demande pour cette adresse d’une manière qui n’aboutira pas. La cause de ce problème peut être la désactivation ou le refus des cookies.

lorsque je me connecte à l'administration (tableau de bord prestashop) cela fonctionne parfaitement (je n'ai , pour l'instant rien changé aux éléments de démo) .

si je me connecte ailleurs que sur l'index, par exemple : https://presta.joane.fr/img/bg_500.PNG ,  je parviens à entrer dans le site(avec message d'erreur) mais c'est une preuve que cela fonctionne !!

Peut être s'agirait-il d'un problème d'htaccess ?

voici l'htaccess à la racine du site

# ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again
# .htaccess automaticaly generated by PrestaShop e-commerce open-source solution
# http://www.prestashop.com - http://www.prestashop.com/forums

<IfModule mod_rewrite.c>
<IfModule mod_env.c>
SetEnv HTTP_MOD_REWRITE On
</IfModule>

RewriteEngine on


#Domain: presta.joane.fr
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api$ api/ [L]

RewriteRule ^api/(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L]

# AlphaImageLoader for IE and fancybox
RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L]
</IfModule>

AddType application/vnd.ms-fontobject .eot
AddType font/ttf .ttf
AddType font/otf .otf
AddType application/font-woff .woff
AddType font/woff2 .woff2
<IfModule mod_headers.c>
    <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|svg)$">
        Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
</IfModule>

#If rewrite mod isn't enabled
ErrorDocument 404 /index.php?controller=404

# ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again

 

merci pour votre aide

Share this post


Link to post
Share on other sites
Resolving presta.joane.fr (presta.joane.fr)... 94.247.177.53
Connecting to presta.joane.fr (presta.joane.fr)|94.247.177.53|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://presta.joane.fr/index.php [following]
--2019-12-31 00:30:40-- https://presta.joane.fr/index.php
Connecting to presta.joane.fr (presta.joane.fr)|94.247.177.53|:443... connected.
ERROR: The certificate of presta.joane.fr is not trusted.
ERROR: The certificate of presta.joane.fr hasn't got a known issuer.
The certificate's owner does not match hostname ‘presta.joane.fr’

- Vous avez une redirection automatique vers https://
- apparemment, le sous-domaine presta n'a pas son propre certificat SSL
- Votre certificat SSL n'est pas correctement installé ou n'existe pas ou n'appartient pas aux presta de sous-domaine ...

- Vérifiez d'abord les fichiers SSL qui sont bien installés ou vous pouvez également désactiver SSL prestashop
Back-Office--->>>Shop Parameters--->>>General--->>>Enable SSL

- régénérez votre .htaccess dans
Back-Office--->>>Shop Parameters--->>>Traffic & SEO--->>>SEO & URLs--->>>Friendly URL    (l'activer et le désactiver, avec cela régénérer le .htaccess)

Edited by Gerardo Martinez G
changer le style de commande (see edit history)

Share this post


Link to post
Share on other sites

il y a aussi un souci dans les DNS:

dig +nocmd +noall +answer joane.fr NS @de3672.ispfr.net
  joane.fr.    86400  IN  NS  de3672.ispfr.net.
  joane.fr.    86400  IN  NS  dns.ispfr.net.


dig +nocmd +noall +answer joane.fr SOA @dns.ispfr.net
  <>

ton DNS secondaire n'est pas synchronisé sur ton primaire

certains surfeurs ne trouveront pas le site:

dig +short presta.joane.fr
  <>

mais le certificat est ok maintenant:

  nmap -p 443 --script ssl-cert presta.joane.fr
Subject: presta.joane.fr
Issuer:  Let's Encrypt Authority X3
start:   2019-12-31T07:43:19
end:     2020-03-30T07:43:19
Subject Alternative Name:
  presta.joane.fr

 

Share this post


Link to post
Share on other sites

Merci à toutes et tous pour vos réponses

Avec tout ceci, je vais essayer de débrouiller mon problème et reviendrai vers vous si ça coince encore quelque part .

bonnes fêtes de fin d'année

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More