Jump to content

[solved]Is there a way to reinstall the classic theme?


Dew1
 Share

Recommended Posts

I am working on prestashop 1.7 , and installed classic theme, but I selected to add the modules myself,

now I can not see the sign in and cart buttons in front page and I am not able to find out how to enable them.

any advice would be appreciated

Share this post


Link to post
Share on other sites

26 minutes ago, selectshop.at said:

Perhaps you unhooked the module ? Check on tab "Design -> Positions" if module is there. If not, then deinstall and reinstall shopping cart module again.

The "sign in" is the module "my account block". Do the same.

Thank you for the reply!

It seems to be hooked, please see attached.Capture.PNG.58894c2d994776ec5922a35a639e5691.PNG

Share this post


Link to post
Share on other sites

1 hour ago, selectshop.at said:

You are using some free modules, or tested free modules/themes ? Perhaps you are using some free or paid old modules which are triggering this behavior. Deinstall all what is not native Prestashop.

I upgraded the prestashop from 1.7.6.0 to 1.7.6.2, uninstalled all the other none prestashop modules, deinstalled and installed the shopping cart, still the same, 

maybe I need to reinstall the classic theme? 

Capture4.thumb.PNG.d0ff6edd2ca5d1df48fa70004e1ed922.PNG

Share this post


Link to post
Share on other sites

Theme install is only for one time. If you have a second theme you can disable it and install a new one. After this only switching (enable/disable) between themes is possible. Installation not, as this option is designed only for to work one time. The installation of a theme writes things also into database, which will be permanently active according to the setting you did. For this reason it is good to have a child of the theme, in where you make all the settings needed and maintain the theme itself native and untouched.

For your problem with the shopping cart. Deinstall all non-native modules. adroll for ex. is not a native module, besides this module interacts in the cart.

Share this post


Link to post
Share on other sites

8 hours ago, selectshop.at said:

Unfortunately your site is under maintenance mode. I was trying to access it, for to verify what's happening live on the site. Perhaps you are seeing something cached locally.

I turned off the maintenance mode.

When I was setting up the site, I selected classic theme, but there was 2 options not sure what the exact word was, but something similar to load the whole theme or customise it yourself, I selected customise it yourself, maybe this is causing the issue, I didn't load the whole theme from the start. 

 

Share this post


Link to post
Share on other sites

9 hours ago, selectshop.at said:

Theme install is only for one time. If you have a second theme you can disable it and install a new one. After this only switching (enable/disable) between themes is possible. Installation not, as this option is designed only for to work one time. The installation of a theme writes things also into database, which will be permanently active according to the setting you did. For this reason it is good to have a child of the theme, in where you make all the settings needed and maintain the theme itself native and untouched.

For your problem with the shopping cart. Deinstall all non-native modules. adroll for ex. is not a native module, besides this module interacts in the cart.

I have deinstalled all non-native modules

Share this post


Link to post
Share on other sites

I suppose you also disabled all overrides as well ? Add the shopping cart module manually to the hooks needed. You can do that by Design -> Positions -> Transplant a module. Simply choose there shopping cart module and then the hook displayNav2 and save. The same you can do with the other modules which the hook is missing/wrong.

Share this post


Link to post
Share on other sites

2 hours ago, selectshop.at said:

I suppose you also disabled all overrides as well ? Add the shopping cart module manually to the hooks needed. You can do that by Design -> Positions -> Transplant a module. Simply choose there shopping cart module and then the hook displayNav2 and save. The same you can do with the other modules which the hook is missing/wrong.

Disable all overrides was enabled, I also enabled 'disable non-prestashop modules, I don't have any displayNav2 hook, can I add it to  displayNav1?

 

Capture5.PNG.fab7ac3a0eb65ddae0e678f55dc37a42.PNG

 

Share this post


Link to post
Share on other sites

If you installed Prestashop by the scratch, instead of to upgrade it from PS 1.6 or 1.5. then this hook should be available. Take a look into the transplant available hooks. You should find it there. If you don't have this hook, then I suggest you reinstall Prestashop as a fresh install and migrate your data to this version. Perhaps your Prestashop version in use is broken.

grafik.thumb.png.e015634f4dbf786e1895ccdd82925c01.png

Share this post


Link to post
Share on other sites

29 minutes ago, selectshop.at said:

If you use the hook displayNav1, then shopping cart will be here:

grafik.png.58f656c39080eaf8da3004b3f4c4bbeb.png

Instead of displayNav2 here:

grafik.thumb.png.0f7ca48019e018e9cedaa9bda3fee099.png

Thank you, I just installed a fresh prestashop. as I didn't have the displayNav2 and I couldn't see the 'cart' even when I hooked it to displayNav1

Thank you so much for all the help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More