Jump to content

Recommended Posts

Bonjour, je vous sollicite aujourd'hui car je me trouve dans une impasse.
Après avoir fait la MAJ vers 1.7.6.2 j'obtiens une erreur 500, après avoir activé le debug je me retrouve avec un détail d'erreur plus complet, pouvez-vous m'aiguiller un peu et m'aider à trouver une solution pour corriger cela.

Merci par avance pour votre aide. 🙏

Erreur :

spacer.png

Configuration prestashop:

spacer.png

Edited by swanlefta (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

le soucis semble venir de l'override de la classe Tools donc il faut regarder pourquoi cet override est là et corriger ou désinstaller le module qui a installé cette surcharge.

Share this post


Link to post
Share on other sites
il y a 5 minutes, Mediacom87 a dit :

Bonjour,

le soucis semble venir de l'override de la classe Tools donc il faut regarder pourquoi cet override est là et corriger ou désinstaller le module qui a installé cette surcharge.

J'ai pourtant désactivé les modules non natifs et tout ce qui pourrait causer une surcharge avant d'upgrade.

Share this post


Link to post
Share on other sites

Désactiver les modules ne supprime pas les overrides et en plus il faut effacer le cache_index.php

Share this post


Link to post
Share on other sites
il y a 5 minutes, Eolia a dit :

Désactiver les modules ne supprime pas les overrides et en plus il faut effacer le cache_index.php

Comment est-ce que je pourrais identifier le module qui pose problème?

Share this post


Link to post
Share on other sites
il y a 6 minutes, swanlefta a dit :

Comment est-ce que je pourrais identifier le module qui pose problème?

Je pense avoir trouver finalement, il s'agit d'un module d'encaissement BTC, j'aimerais néanmoins le conserver.

spacer.png

Share this post


Link to post
Share on other sites

Demandez à son développeur de le mettre à jour car là il utilise 2 fonctions deprecated.

Share this post


Link to post
Share on other sites
il y a 5 minutes, Eolia a dit :

Demandez à son développeur de le mettre à jour car là il utilise 2 fonctions deprecated.

Problème résolu je viens d'upgrade vers la dernière version de Presta, pour le module il n'est même plus disponible sur le store Presta, du coup changement de module.
Merci pour votre aide à tous.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More