Jump to content
wolfs62

Probleme d'affichage sur mobile

Recommended Posts

Bonjour a tous,

Malgré mes recherche et mes manipulations une probleme d'affichage persiste sur le site mobile (aucun probleme sur le site classique). Je precise que le theme utilisé est compatible mobile.

j'ai bien modifié le fichier theme.css et custom.css (en passant par l'inspection cela corriger le probleme) mais rien ne fait, l'affichage des articles restent toujours à 33%.

la seule solution trouvé, est de passé l'affichage des produits en "list" mais pas tres pratique pour les clients 😕 .

je vous joint une capture d'ecran pour esperer etre plus clair ^^

le site www.beaute-elles.fr.

merci pour le temps que vous pourrez m'accorder :)

wolfs

Screenshot_20191214-035557.png

Share this post


Link to post
Share on other sites

J'ai trouvé sur certain sujet qu'il fallait modifié le fichier product-list.tpl, hors quand j'ouvre ce fichier rien ne correspond avec ce que l'on me demande de faire

Quote

{if isset($products) && $products} {*define numbers of product per line in other page for desktop*} {if $page_name !='index' && $page_name !='product'} {assign var='nbItemsPerLine' value=4} {assign var='nbItemsPerLineTablet' value=2} {assign var='nbItemsPerLineMobile' value=3} {else} {assign var='nbItemsPerLine' value=6} {assign var='nbItemsPerLineTablet' value=3} {assign var='nbItemsPerLineMobile' value=2}

c'est ligne n'apparaissent pas dans le fichier 😕

Share this post


Link to post
Share on other sites

Je vais finir par faire un topic a moi tout seul 🙄

j'ai remarqué que le site mobile modifie le fichier custom.css

voila mon fichier enregistrer:

.swiper-slide {
  -webkit-flex-shrink: 0;
  -ms-flex-negative: 0;
  flex-shrink: 0;
  height: 100%;
  position: relative;
  -webkit-transition-property: -webkit-transform;
  transition-property: -webkit-transform;
  -o-transition-property: transform;
  transition-property: transform;
  transition-property: transform, -webkit-transform;

et lorsque je regarde sur le site mobile j'ai 

.swiper-slide {
  -webkit-flex-shrink: 0;
  -ms-flex-negative: 0;
  flex-shrink: 0;
  height: 100%;
  width: 33%;
  position: relative;
  -webkit-transition-property: -webkit-transform;
  transition-property: -webkit-transform;
  -o-transition-property: transform;
  transition-property: transform;
  transition-property: transform, -webkit-transform;

est ce qu'un module peut faire cela?

Share this post


Link to post
Share on other sites

Bonjour Solsol69,

je n'y arrive pas, j'ai ce message d'erreur:

Quote

Le paramètre "{id}" de l'action "tvcmsblog-archive-wid-module" est requis (URL: "tvcmsblog/category/{rewrite}.html")

Le paramètre "{id}" de l'action "tvcmsblog-tag-wid-module" est requis (URL: "tvcmsblog/tag/{rewrite}.html")

Le paramètre "{id}" de l'action "tvcmsblog-single-wid-module" est requis (URL: "tvcmsblog/post/{rewrite}.html")

:(

Share this post


Link to post
Share on other sites

Bonsoir,

Pourrais ton au moins me donner des pistes vis a vis de la résolution de mon problème (même si elles sont fausses, rien n'est perdu ^^).

En ce moment, je vérifie chaque module 1 par 1, sans savoir quoi chercher, car je n'ai jamais appris le java (certaine chaines ressemble à du css/php mais très peu)

merci par avance

Share this post


Link to post
Share on other sites
Le 14/12/2019 à 4:14 AM, wolfs62 a dit :

Je precise que le theme utilisé

concernant votre problème je ne l'ai pas constaté sur mon mobile.Mais sachez que vous pouvez vous retournez auprès du créateur de votre thème afin qu'il solutionne votre problème.

Share this post


Link to post
Share on other sites

Bonjour,

Merci pour vos réponses :)

1 hour ago, solsol69 said:

concernant votre problème je ne l'ai pas constaté sur mon mobile.Mais sachez que vous pouvez vous retournez auprès du créateur de votre thème afin qu'il solutionne votre problème.

Vous êtes bien allez dans une catégorie? (genre "make up" par exemple) si oui pourriez vous m'indiquer la taille de résolution de l’écran? (ou son modèle et je l'a chercherai)

Malheureusement je n'avais une assistance que pour 3 mois et le thème a été acheter en février (la personne qui détiens le site l'a un peu laissé a l'abandon pendant tous ce temps car pas le temps de le maintenir a jour :/) sinon je ne serais pas venu vous embêtez ^^

1 hour ago, solsol69 said:

Peut etre en le bricolant il y a un debut de piste ici

https://github.com/PrestaShop/PrestaShop/issues/12026

Je vais regarder sa, merci :) (mais ce problème est juste pour les url simplifié non?)

Share this post


Link to post
Share on other sites
1 hour ago, solsol69 said:

Peut etre en le bricolant il y a un debut de piste ici

https://github.com/PrestaShop/PrestaShop/issues/12026

j'ai effectué les meme modification que sur le lien fournis, maintenant le site n'est plus accessible 😣 

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@beaute-elles.fr to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

 

Share this post


Link to post
Share on other sites

J'ai annulé les URL simplifié et le site re-fonctionne a nouveau.

Pour mes démarches, j'ai effectué ce qui était ecrit dans le lien, j'ai recherché le fichier tvcmsblog.php, ensuite j'ai recherché "tvcmsblog-archive-wid-module" est j'ai ajouté "{id}_" devant {rewrite} (j'ai fait pareil pour les 2 autres erreurs). J'ai ensuite été activer les URL simplifié. La plus d'erreur du coté prestashop mais site inaccessible.

Share this post


Link to post
Share on other sites
11 minutes ago, solsol69 said:

tenter de regenerer votre .htaccess une fois que vous avez reactiver vos url simplifié

comment fait on cela?

Share this post


Link to post
Share on other sites

J'ai un petit probleme, le gestionnaire de fichiers cPanel trouve bien le fichier .htaccess, mais il est invisible pour moi (impossible d'en faire une sauvegarde comment indiquer dans le lien)

Capture d’écran de 2019-12-17 12-14-41.png

edit: c'est bon, le fichier etait masqué ^^

Edited by wolfs62 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

je ne sais pas ce qu'il c'est passé mais l'affichage mobile est redevenu normal :)

par contre j'aimerai affiché 2 produits par ligne et non  seul comme c'est le cas actuellement. je ne sais pas ou modifié dans le fichier custom...

merci par avance

Share this post


Link to post
Share on other sites
.swiper-slide {
  -webkit-flex-shrink: 0;
  -ms-flex-negative: 0;
  flex-shrink: 0;
  height: 100%;
  position: relative;
  -webkit-transition-property: -webkit-transform;
  transition-property: -webkit-transform;
  -o-transition-property: transform;
  transition-property: transform;
  transition-property: transform, -webkit-transform;
 
}

c'est la partie du code a modifier je pense car quand je rajoute "width:50%" j'ai bien 2 articles par ligne, mais je ne voudrait en avoir 2 que sur mobile pas sur les pc. Comment faire?

Que veut dire "webkit" au passage?

merci a vous

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More