Jump to content
alexwee

'prestashop_e.prstshp_guest' doesn't exist

Recommended Posts

Hallo zusammen,

wenn ich in die Kundenverwaltung gehe, erscheint oben die Meldung:

Falsche SQL-Abfrage
Table 'prestashop_e.prstshp_guest' doesn't exist

Ich sehe daher nur die Statistik, wie z.B Durchschnittsalter, aber die Kunden sind bei mir nicht aufgelistet. 

Bis jetzt habe ich das auch nicht benötigt, jedoch will ich jetzt ein Affiliate System installieren und dieses benötigt (soweit ich weiß) genau diese Kundenverwaltung.

Daher die Frage, wie kann ich dieses Problem lösen bzw. die fehlende Datenbank wieder reinkriegen.

 

Ich hoffe Ihr könnt mir helfen, viele Grüße :)

Share this post


Link to post
Share on other sites

Hi,

ich gehe mal davon aus das prstshp dein Datenban Präfix ist...demnach fehlt dir die Tabelle guest...Hast du mal in deiner Datenbank nachgeschaut ob sie wirklich fehlt

Falls du kein Backup oder der gleichen hast wo du die guest Tabelle herausfiltern kannst...versuche einfach die Tabelle via phpmyadmin neu anzulegen...

Den entsprechenden Befehl findest du ganz unten in diesem Beitrag --->

Schau mal ob danach alles wieder wie gewohnt angezeigt wird

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hast du PrestaShop 1.7? Da hilft es manchmal schon, den Inhalt des Verzeichnisses /var/cache zu löschen.

Ansonsten hilft es, dieses Skript im SQL-Fenster von PHPMyAdmin auszuführen: ps_guest.sql.txt

Natürlich musst du zuvor anstelle von ps_ dein eigenes Präfix setzen.

  • Thanks 1

Share this post


Link to post
Share on other sites

Erstmal vielen Dank für eure Hilfe. Ich muss zugeben, dass ich im Bereich Datenbanken wirklich sehr wenig Ahnung habe..

 

Ja, ich benutze Prestashop 1.7.5.2 - Kann ich einfach so ohne Risiko den kompletten Inhalt im Verzeichnis var/cache löschen? Da dort vieles drin ist zögere ich grade noch.

Die entsprechende Datenbank finde ich weder in der jetzigen Datenbank noch in den Backups (bzw. dort weiß ich nicht wie genau ich suchen soll).

 

Ich habe nun wie in der Antwort von Magicalname beschrieben versucht per Befehl eine neue Liste anzulegen. Leider hat dies so erstmal keine Änderung gebracht. Hier ein Bild vom "Ergebnis", evtl. habe ich dort was falsch gemacht oder man sieht evtl. wo das Problem ist..

guestproblem.jpg.3b561892e35f762b23b25cf70b5f07e4.jpg

 

Ich hoffe ihr könnt mir hier nochmal kurz weiterhelfen, ich denke und hoffe dass es sich hier um kein allzugroßes Problem handelt. :)

 

Viele Grüße

 

 

 

 

Share this post


Link to post
Share on other sites

Ja kannst den Inhalt einfach löschen...Probier mal den Cache zu löschen und schau ob es eine Änderung bewirkt

 

Edit:

Es kann keine Änderung bewirken bevor du den Befehl absendest musst du ihn anpassen du hast die Tabelle ps_guest erstellt du brauchst aber prstshp_guest 😉 hatte @Wuschel aber erwähnt :)

Edited by Magicalname (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

Stimmt, danke :D nachdem ich dies nun gemacht habe erscheint stattdessen diese Fehlermeldung:

Falsche SQL-Abfrage
Table 'prestashop_e.prstshp_connections' doesn't exist

Merkwürdig..

Den Cache Ordner habe ich auch komplett gelöscht

Share this post


Link to post
Share on other sites

Ok dann fehlt dir auch die Tabelle prstshp_connections

Diese erstellst du mit diesem Befehl

DROP TABLE IF EXISTS `ps_connections`;

CREATE TABLE `ps_connections` (

`id_connections` int(10) unsigned NOT NULL AUTO_INCREMENT,

`id_shop_group` int(11) unsigned NOT NULL DEFAULT '1',

`id_shop` int(11) unsigned NOT NULL DEFAULT '1',

`id_guest` int(10) unsigned NOT NULL,

`id_page` int(10) unsigned NOT NULL,

`ip_address` bigint(20) DEFAULT NULL,

`date_add` datetime NOT NULL,

`http_referer` varchar(255) DEFAULT NULL,

PRIMARY KEY (`id_connections`),

KEY `id_guest` (`id_guest`),

KEY `date_add` (`date_add`),

KEY `id_page` (`id_page`)

) ENGINE=InnoDB AUTO_INCREMENT=3 DEFAULT CHARSET=utf8;

 

Bitte aber auch wieder anpassen

  • Thanks 1

Share this post


Link to post
Share on other sites

Super jetzt klappt alles! :)

Vielen vielen Dank für die Hilfe um diese Uhrzeit noch, hat mir sehr geholfen! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More