Jump to content

Translation problems


Recommended Posts

Hi guys,

I got a problem with the translations in prestashop v1.1, and i was thinking if you can tell me if this is a bug, or something from me.

After i imported my language (romanian), and i try to edit backend, frontend or the other translations pages, most of the fields go blank, and also the whole frontend and backend translations goes broken, i see the writing both in romanian and english combined

I have seen that several people have this problems, and somebody from here, spott said that by making the execution time to 600 ( i had it to 300 ) fixed it for him, but for me it didn’t.

This is very weird. Could it be a bug?

Hope you can give me a good advice on what could be the problem on this.


Link to comment
Share on other sites

i found a very big problems, i have right of writing on the files, and when i translate som fields in the modules section and i save, it isn't saved. The weird thing is that the file is modified, but it doesn't right in him. ( Example: i modify something tommorow, the file will have in his details that it has been modified with the day of tommrow but nothing writed in him).

The only thing could be is something in the source code not good, but i'm not 100% sure. This i need to ask of the the programmers that made this.

Link to comment
Share on other sites

I think I have found out the problem!

Looks like the problem come than out when exist different translations for the same English words.

Im my case that was different translations for "My account" in "my-account" and "order-follow" sections.
"my-account" section was already fulfilled, but "order-follow" not fulfilled. On the other side translations for the "My account" string was different for this two sections.
Every time I stored my translation, all translations after "my-account" were lost, and some strings in the section also.

As long as I made the transaltion for "My account" the same for both sections, I could save and translate without lost of data.

Take a look if You have the same problems!

Sorry, the problem is something else!
Looks like the problem ether with max_input_time variable or with the limit of POST buffer...

Link to comment
Share on other sites

post_max_size, but actually it's 8Mb by default - have to be enought.

Check also max_execution_time - it's 60 seconds by default...

I've changed all of this for my local shop directory, but it didn't work... :(

I wrote to my hoster's support...

Link to comment
Share on other sites

That's really strange...

I looked in the PHP scripts and can only say, that over POST will not sent all the 497 strings with translation.
It's either the problem of sending script or problem of the transfer of the data over POST method itself.

Link to comment
Share on other sites

I didn't test it too much. Had a problem to start it in subdomain directory and the problem with transaltions.
Other features I have tried had worked till now.
Did You find out more problems ?

See PM with my php settings.

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...