Jump to content
Francis.M

Err 500 lors de la création d'un produit pack

Recommended Posts

Bonjour, j'ai planté mon site en créant un produit sous forme de pack ; erreur 500. Ci-dessous le détail du bug. La fiche produit n'est pas accessible; page blanche. J'ai réussi dans les stock à mettre la quantité à zero  mais cela n' a rien changé. Comment ne plus le rendre visible sur le front office afin de débloquer la situation. Faut-il agir directement dans la base de données ?

Par avance merci.

[PrestaShopException]

Product with id 2266 is not a pack
at line 252 in file classes/Pack.php

247. $idProduct = (int) $idProduct;

248. $idProductAttribute = (int) $idProductAttribute;

249. $cacheIsPack = (bool) $cacheIsPack;

250.

251. if (!self::isPack($idProduct)) {

252. throw new PrestaShopException("Product with id $idProduct is not a pack");

253. }

254.

255. // Initialize

256. $product = new Product($idProduct, false); 257. $packQuantity = 0;

 

 

Share this post


Link to post
Share on other sites

Base de données :

table ps_product passer la colonne cache_is_pack à 0 pour le produit 2666

table ps_pack supprimer les lignes ou id_product_pack = 2666

Share this post


Link to post
Share on other sites

Merci pour votre réponse. Je me demande quel pb à pu se produire ? est-ce un pb de prestashop ? C'est le premier pack que je faisait depuis mon passge à 1.7. Les anciens ont ont migré normalement.   Encore Merci.

Share this post


Link to post
Share on other sites

Dans les tables :

table prstchop_product passer la colonne cache_is_pack à 0 pour le produit 2666  :     cette valeur était déja à 0

table ps_pack supprimer les lignes ou id_product_pack = 2666   :   table vide ????

Donc pour l'instant pas de changement

Share this post


Link to post
Share on other sites

le problème qui a du se produire c'est votre serveur à planté pendant l'enregistrement et qu'une des 2 tables n'était pas à jour. Du coup Prestashop est incapable de reconstruire ce produit incohérent.

Share this post


Link to post
Share on other sites

Effectivement après travail sur les différentes tables je n'ai pas pu corriger le pb. Ayant un backup journalier mon hébergeur à réinstaller le site ;uniquement les fichiers, sans mettre à jour la base de données  et le site fonctionne !    Merci encore pour vos réponses. Cdt Francis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More