Jump to content
Sign in to follow this  
fox8687

Liens CMS pour un site en français uniquement.

Recommended Posts

Bonjour à tous,

Je viens de mettre à jour mon site avec la version 1.4.
Mes liens CMS (conditions d'utilisation, a propos, etc...) ne fonctionnent pas (redirection automatique sur la page d'accueil)

D'après ce que j'ai pu lire et testé, lorsque j'active une deuxième langue et que je met à jour mon fichier .htaccess, cela fonctionne, sauf que l'accès aux catégories ne fonctionne plus !

Mon site, pour le moment doit être exclusivement en français.

Merci pour vos idées.

ps, j'ai également testé le changement du id_cms=$1 au lieu de id_cms=$2 dans le htaccess mais qui me provoque une erreur 500.

Share this post


Link to post
Share on other sites

Salut ,

ce n'est pas ton fichier .htaccess mais le "controlleur" , pour ma part : suite à l'installe d'un modules ( presta secur )

Plus aucun lien tous les lien du CMS sont redirigée vers URL de base , mais les liens des produits sont Ok .

Bizarre non ? je suis encore sur le problème en faite on est 3 sur le même problème.

Donc si ta pu trouvée . ;)

edit : ces bien le fichier ..htaccesss qui bug

Share this post


Link to post
Share on other sites

Bonjour,

Dans le fichier .htaccess, il faut remplacer :

RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*) /cms.php?isolang=$1&id;_cms=$2 [QSA,L]

par :

RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*) /cms.php?id_cms=$1 [QSA,L]

Testé sur ma boutique.

Stéphane

Share this post


Link to post
Share on other sites

Bonjour,

Un grand merci pour vos idées, mais malheureusement, cela ne fonctionne pas.
J'ai remis le fichier htaccess de l'ancienne version.

Tout fonctionne correctement, sauf que je beneficie pas de l'url simplifié, ni de l'optimisation, ce qui est vraiment dommage, mais bon. c'est un moindre mal.

Si quelqu'un est hegergé chez online.net, ça m'interresserait beaucoup de voir son fichier htaccess.

Merci à vous, par avance.

Share this post


Link to post
Share on other sites

La règle

RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*) /cms.php?id_cms=$1 [QSA,L] 



fonctionne parfaitement pour ceux qui ont une boutique en une seule langue, c'est à dire que dans l'url vous n'avez pas d'info de localisation (fr,en..). Sinon le problème vient d'ailleurs.

Merci @stephane-v

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More