Jump to content

Recommended Posts

Bonjour,

J'utilise une ancienne version (1.5.6.3) sous windows et je ne souhaite pas migrer pour l'instant.

Dans l'administration : catalogue > produits je ne peux plus créer un nouveau produit : page ne fonctionne pas HTTP ERROR 500

J'ai conservé les fichiers source d'installation. Ma question est la suivante :

> quel fichier je peux uploader pour écraser celui qui pose problème

Merci d'avance pour l'aide que vous pourriez m'apporter.

Bonne journée

Cordialement

Gilles

 

Share this post


Link to post
Share on other sites

A partir de la version 1.5, comme toujours en cas d'erreur 500 et pour en savoir plus, il faut modifier cette ligne au début du fichier config/defines.inc.php sur votre ftp :

define('_PS_MODE_DEV_', false);

en remplaçant false par true, ce qui donne:

define('_PS_MODE_DEV_', true);

Et donnez-nous l'erreur après avoir enregistré le fichier et rafraîchi la page

Share this post


Link to post
Share on other sites

Merci.

Après l'activation du debug j'obtiens :

Fatal error: Unsupported operand types in /web/gilles/domain.com/www/boutique/controllers/admin/AdminProductsController.php on line 859

J'ai le fichier source. Est-il suffisant de le charger pour écraser celui en place ? Est-ce que je risque de perdre de l'information ?

Share this post


Link to post
Share on other sites

Pourquoi vouloir écraser quoi que ce soit alors que le problème vient de votre version PHP ???

Prestashop 1.5 ne supporte pas de version PHP supérieure à 5.6

Share this post


Link to post
Share on other sites

L'informaticien ?

La version PHP se règle chez votre hébergeur directement, pas besoin d'informaticien.

Share this post


Link to post
Share on other sites

oui, comme dit plus haut Max: PHP 5.6

Votre hébergeur est en vacances ???

Share this post


Link to post
Share on other sites

Votre hébergeur c'est CLOUDFLARENET aux USA, m'étonnerai qu'il soit en vacances :) 

Share this post


Link to post
Share on other sites

C'est un intervenant local qui s'héberge sans doute là où vous dîtes. Je ne vois d'ailleurs pas l'intérêt d'être allé chercher cette information.

Par contre l'intérêt c'est qu'avec lui j'ai un contact, alors qu'avec un centre aux USA, bernique !

Share this post


Link to post
Share on other sites

Puisque je vous sens en forme 🙂 dites-moi si en migrant vers une version plus récente de Prestashop je vais perdre toute ma mise en page ?

www.chumeditions.com/boutique/index.php

Merci et très cordialement

Gilles

Share this post


Link to post
Share on other sites

Bonjour,

Je n'ai toujours pas avancé. Je veux bien que ma version de Prestashop ne soit pas compatible avec le PHP 7, mais pourquoi seule UNE fonction de l'admin ne fonctionne pas et pas les autres et pourquoi la librairie en ligne fonctionne-t-elle ?

S'il y a incompatibilité, c'est l'ensemble qui devrait être inopérant, ne croyez-vous pas ?

En tout cas, un petit coup de main m'aiderait vraiment

Cordialement

Gilles

Share this post


Link to post
Share on other sites

La ligne d'erreur est la suivante

Fatal error: Unsupported operand types in /web/gilles/chumeditions.com/www/boutique/controllers/admin/AdminProductsController.php on line 859

Mon problème est que je ne sais pas quoi faire...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More