Jump to content

Recommended Posts

Hallo zusammen,

ich versuche einen neuen Shop aufzusetzen. Gestern habe ich die aktuelle PS version installiert und kam auch problemlos in die admin Oberfläche.

Heute wollte ich dann den Shop anpassen und bevor ich loslegen konnte sieht das ganze dann schon anders aus, bekomme noch die Login Maske aber danach:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Das Strato Error log sagt mir:

14.11.2019 21:07:39 ******.de [client 77.20.25.0] FastCGI: "/home/strato/http/fastcgi/******/admin_***/index.php" aborted: no response after 123 sec (idle timeout 120 sec)

Ich habe schon define('_PS_MODE_DEV_', true); in der defines_inc.php gesetzt aber es kommt nicht mehr Information also ohne.

PHP Version ist 7.2 mit PHP Boost aktiv.

Es ist ein Shared Hosting (PowerWeb) und nicht super performant, allerdings war es gestern abend zufriedenstellend. Auch das Frontend ist (noch mit demo content) gut zu bedienen.

Habt ihr Ideen?

 

Share this post


Link to post
Share on other sites

Powerweb-Hostings gibt es bei Strato einige.

Hier scheint es sich schlicht und ergreifend um ein Timeout nach 120 Sekunden zu handeln, möglicherweise durch zu hohe Serverbelastung, das sollte dann allerdings zu anderen Zeiten nicht passieren.

Oft wird empfohlen, das Modul "Handelserfolg" zu deinstallieren, da es gern für lange Verzögerungen beim Aufruf des BackOffice sorgt.

Share this post


Link to post
Share on other sites

😐 das hat auch noch nicht geholfen..

PHP Boost ist aus.. gamification aus modules rausgenommen..

vielleicht installiere ich das einfach nochmal.. es ist ja noch nix drin..

ist 1.7.6.1 sonst "gut" für installation? oder sollte ich besser auf eine ältere Version gehen?

Ich fand das mit dem zip installer ganz praktisch.. ;)

Share this post


Link to post
Share on other sites

Der Checker hat nur ein paar gelbe, sonst alles grün:

# 				Required 	Recommended 	Current
max_input_vars 			1000 		5000 		4000
memory_limit 			64M 		256M 		256M
upload_max_filesize		4M 		128M 		64M
Image Processing (ImageMagick) 	No 		Yes 		No
Memcached 			No 		Yes 		No

ich werd' das wohl heute nochmal auf den Kopp hauen und neu installieren.

Es wird ja wohl nicht daran liegen, dass ich für die datenbank collation "utf_general_ci" eingestellt habe? standardmäßig war der auf "latin1_german1_ci"..

Share this post


Link to post
Share on other sites

Hallo zusammen,

gestern habe ich den Shop neu aufgesetzt.. DB geleert, Verzeichnis gelöscht und neu gemacht. Einstellungen habe ich so gelassen (PHP Boost aus).

Dann gestern den Shop in Maintenance gesetzt und angefangen anzupassen.. Frontend / Backend alles klasse.. gestern...

Heute dann wieder das gleiche.. 500 Internal Server Error... kann doch nicht sein..

Ich werd auch mal Strato drauf ansetzen.. vielleicht wissen die was?

 

Share this post


Link to post
Share on other sites

Hatte ich schon gesagt.. gleich im ersten Posting: "Es ist ein Shared Hosting (PowerWeb) und nicht super performant, allerdings war es gestern abend zufriedenstellend. Auch das Frontend ist (noch mit demo content) gut zu bedienen." :)

Es scheint einfach nach ein paar Stunden nicht mehr zu funktionieren. :/ Tageszeiten sind "all over the place".. die letzten Male hatte ich Abends installiert und alles war gut, dann am nächsten Morgen nix mehr.. heute eben nachmittags installiert und jetzt am Abend geht nix mehr.

die 1.7.5.2 hat mir noch gesagt:

To get the latest internationalization data upgrade the ICU system package and the intl PHP extension.
Install and/or enable a PHP accelerator (highly recommended).
Set short_open_tag to off in php.ini*. 

War aber installationsbereit - wobei die 1.7.6.1 performanter (und kleiner) war/ist..

Share this post


Link to post
Share on other sites

Wie ich bereits geschrieben habe, Strato PowerWeb sagt gar nichts weil das ein Sammelbegriff ist für verschiedene Pakete vom für Prestashop wohl ungeeigneten Einsteigerpaket bis zu halbwegs brauchbar.

Normalerweise sollte sich am Shop nicht von selbst etwas ändern, deshalb ist die Frage eher, was du zuletzt (als es noch funktionierte) gemacht hattest.

Share this post


Link to post
Share on other sites

okay.. ahh.. ich sehe.. das gibt's so nicht mehr.. dann kannst du natürlich auch nicht sehen was das ist. ;)

naja.. wie auch immer.. das letzte mal hatte ich PS installiert und es lief. wenngleich nicht so performant wie das aktuelle.

nichts weiter gemacht - sonst würde mich das jetzt ja nicht so überraschen. Also das letzte was ich gemacht habe ist das Fenster zu schließen - ohne auszuloggen..

beim ersten versuch habe ich nicht einmal irgendwelche weiteren Einstellungen gemacht.. bei den letzten beiden Versuchen noch den Maintenance Modus aktiviert.

 

Share this post


Link to post
Share on other sites

hab ich letztens gemacht .. heute eine reaktion bekommen.. "nicht unser skript, nicht unser problem" mit etwas anderen Worten..

Naja, es läuft ja auch super.. bis dann irgendwann.. was weiß ich.. irgendwas an- oder abläuft..

Share this post


Link to post
Share on other sites

Nichts dazugebucht.. alles auf Standard.. ich meine, dass einzige was sich seit der letzten funktionierenden Version geändert hatte ist PHP auf 7.2 ..

Ich hab im Forum jetzt einige Threads gelesen, die das gleiche Problem mit PS 1.7 bei Strato hatten - und offenbar keine vernünfige Lösung gefunden haben. :| ernüchternd

Share this post


Link to post
Share on other sites

Die "Lösung" von denen, die das gleiche Problem hatten, funktioniert auch bei mir:

Wenn ich das var/cache Verzeichnis vom PS lösche, dann komme ich wieder für eine Weile in die admin Oberfläche..

Ich hege die Hoffnung, dass diese Inkompatobilität in weiteren Versionen wieder verschwindet - denn es ging ja schon mal. :D

Share this post


Link to post
Share on other sites

Habe es heute mal ausprobiert und wie du sagst, für eine gewisse Zeit geht es. Bei mir waren es circa 2 Stunden, wollte mich nochmals neu danach einloggen und nichts ging mehr. Hab es wieder gelöscht und Zack alles funktionierte! 
 

komisch das es immer passiert wenn ich irgendetwas verändere.

Share this post


Link to post
Share on other sites

Ich habe das Ganze mal im Detail angeschaut und denke ich habe die Ursache gefunden. Strato (wie viele shared Webhoster) limitiert die Anzahl der Dateien auf dem Webspace (unabhängig vom Speicher) - siehe https://www.strato.de/faq/hosting/limitierungen-auf-geteilten-plattformen-shared-webhosting/
Das Ganze scheint dann im Modul "Update & Tipps" zu einem Speicherüberlauf/Endlosschleife zu führen. Ich habe das Modul bei mir mal deaktiviert und werde berichten ob das Problem damit behoben ist - vielleicht könnt ihr das ja auch mal testen. Falls der Fehler bereits besteht kann per FTP das Verzeichnis /modules/psaddonsconnect umbenannt werden.

Falls der Fehler wieder auftritt ist auf der o.g. Seite beschreiben wie Ihr prüfen könnt wieviele Dateien auf dem Hosting angelegt sind. Dauerhaft sollten auf dem Hosting Dateien gelöscht werden um weitere Probleme zu vermeiden.

grafik.thumb.png.96b902385579e2608ffb6219b6578260.png

  • Thanks 1

Share this post


Link to post
Share on other sites

Hallo zusammen,

@JBW: Die Anzahl der Dateien ist es bei mir nicht. ich komme nicht einmal annähernd an die max Anzahl.

Ich hatte allerdings auch noch weiter getestet und bei mir reicht es, wenn ich dieses Verzeichnis lösche: var/cache/prod/addons_advice

Wozu das Verzeichnis gehört habe ich aber noch nicht herausgefunden. ;)

Share this post


Link to post
Share on other sites

16 minutes ago, JBW said:

Wieviel Dateien hast du denn?

Wie oben geschrieben gehören die Dateien zum Addon Module - hilft es bei dir wenn du dieses deaktivierst?

Strato sagt ab 90% des max Wertes wird die Info erst angezeigt. .bei mir wird's nicht angezeigt. Grade mal zählen lassen.. insgesamt knapp 50 tausend Dateien.

Ein "Addon" Modul finde ich nicht. zumindest nicht auf der Admin Seite oder im Modules Verzeichnis. vielleicht hat es auch einen anderen Namen?

ich werde bei Zeiten mal den Sourcecode durchsuchen..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More