Jump to content
amal1410

Shop error Link to database cannot be established:SQLSTATE[HY000] [2006] MySQL server has gone away and Back working fine!

Recommended Posts

Bonjour,


Mon serveur s'est planté hier et ne veut plus démarrer.
J'ai donc dû faire une restauration du même jour et depuis, mon back-office prestashop fonctionne bien alors que sur ma botique j'ai ces messages d'erreur :

Notification : Utilisation de la constante indéfinie MCRYPT_RIJNDAEL_128 - supposée'MCRYPT_RIJNDAEL_128' dans /classes/Rijndael.php on line 124

Notification : Variable non définie : google_script dans /modules/tmmegamenu/tmmegamenu.php à la ligne 2609

Avertissement : PDO::query() : Le serveur MySQL est parti dans /classes/db/DbPDO.php en ligne 134

Avertissement : PDO::query() : Erreur de lecture de l'en-tête du jeu de résultats dans /classes/db/DbPDO.php à la ligne 134

[PrestaShopException]

Le lien vers la base de données ne peut pas être établi:SQLSTATE[HY000][2006] Le serveur MySQL a disparu
à la ligne 102 dans le fichier classes/db/DbPDO.php

 

Pouvez-vous m'aider s'il vous plaît ?

Remerciements

Citation

 

Hello,


My server has crashed yesterday and does not want to start anymore.
So I had to make a restore of the same day and since, my back office prestashop works fine while on my botique I have these error messages:

Notice: Use of undefined constant MCRYPT_RIJNDAEL_128 - assumed 'MCRYPT_RIJNDAEL_128' in  /classes/Rijndael.php on line 124

Notice: Undefined variable: google_script in /modules/tmmegamenu/tmmegamenu.php on line 2609

Warning: PDO::query(): MySQL server has gone away in /classes/db/DbPDO.php on line 134

Warning: PDO::query(): Error reading result set's header in /classes/db/DbPDO.php on line 134

[PrestaShopException]

Link to database cannot be established:SQLSTATE[HY000] [2006] MySQL server has gone away
at line 102 in file classes/db/DbPDO.php

 

Can you help me please ?

Thanks

 

 

Share this post


Link to post
Share on other sites

Le problème est lié a ton serveur de base de données. Tu dois donc commencer à chercher dans les logs de celui-ci le problème afin de le résoudre

Share this post


Link to post
Share on other sites

Merci pour votre réponse.
Le problème etait bien lié a mon serveur de base de données.

Merci 😉

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More