Jump to content
  • 0
tche

Problème d’affichage des différents modules dans l’admin

Question

Bonjour à tous et bonne année !
voila pour commencer l'année en beauté, j'ai un soucis au niveau de l'affichage des modules dans l'admin.
J'explique : je viens d'installer PS1.1 sur mon serveur dédié chez OVH en préproduction pour tester donc dans mon dossier httpdocs.
Tout c'est bien passé, j'ai redonné les droits sur les dossiers et sous dossiers.
Quand je vais dans l'administration de mon site ex: http://monsite.toto.net/admin488 j'accède à ma console d'administration mais quand je souhaite accéder à la gestion des modules je n'obtient pas la liste pour installer ou supprimer des modules (cf la démo en ligne) mais j'ai uniquement un bouton "ajouter un nouveau module" et l'onglet "position".

Je suis dessus depuis 2 jours et je n'arrive à rien.
Quelque peut-il m'aider ? un bon geste messieurs-dames.

Merci d'avance.
Tché

Share this post


Link to post
Share on other sites

32 answers to this question

Recommended Posts

  • 0
je ne peux pas te donnermon phpinfo car c'est un serveur d'un ami qui ne souhaite pas que je le diffuse, désolé.
et oui j'ai vidé mon cache et j'ai testé sur plusieur ordi mac et pc mais meme résultat.
est-ce que le .htaccess peut avoir un inscidence à ce niveau ou les permissions de fichiers sur un serveur ovh dédié ?

Merci pour vos réponses

Share this post


Link to post
Share on other sites
  • 0
je souhaiterais par exemple ajouter un module newsletter mais je n'ai pas accès à la liste des modules avec installer la newsletter.
Je peux juste greffer un nouveau module j'ai une liste déroulante avec plusieurs modules listé mais pas celui de la newsletter comme dans la démo.

Share this post


Link to post
Share on other sites
  • 0
Bonjour, bonne année 2009, et encore merci pour cette version 1.1 ;)

Donc j'avais la version 1.0, j'ai effectué la mise à jour afin de passer à la 1.1. Depuis je rencontre un problème dans le back office, dans l'onglet Module, je ne peux gérer aucun module ... voir le screenshot


Cela pourrait venir d'un mauvais CHMOD ?
J'ai mis le dossier Module et ses sous dossiers en 777.

J'ai vidé mon cache FF3, et réactualiser la page des module, toujours aucun module...

PS: je viens de voir que mon problème est identique à ce topic

Share this post


Link to post
Share on other sites
  • 0
J'ai exactement le même problème, je viens de vider le cache et de mettre le dossier module, ses sous dossiers et les fichiers avec un CHMOD 777, et rien n'a bougé ... étrange !

Share this post


Link to post
Share on other sites
  • 0
Un truc bizarre dans la capture c'est qu'il manque le footer :
[color=green]Powered by PrestaShop™ [ forum & contact ] - Version 1.1.0.5 - 3.121s[/color]

Ceux qui ont le problème pourraient peut-être regarder dans le code source de la page s'il n'y a pas une erreur PHP ou bien activer l'affichage des erreurs.

Share this post


Link to post
Share on other sites
  • 0
Bonjour à tous !
j'ai installé la [b]version 1.1 finale[/b] et au niveau de l'admin on a plus la liste des modules comme dans la version1.0 avec installer désintaller et configuerer. est-ce normal.
Je souhaite intégrer le module newsletter mais je ne l'ai pas dans la liste "greffer un nouveau module".
Peut-on ajouter ce module dans l'admin pour pouvoir l'insérer dans ma boutique. Comment faire ?
Quelqu'un a-t-il testé le blocknewsletter dans la version 1.1

Merci d'avance pour vos réponses.
Je suis vraiment coincé et il me reste peu de temps pour finir.
Tché

Share this post


Link to post
Share on other sites
  • 0
@Tche

Tu as déjà créé un topic à ce sujet... Ca fera pas avancer les choses plus vite malheureusement.

Je les merge...

EDIT : lis mon post plus haut... le fait qu'il manque le footer n'est pas normal...

Share this post


Link to post
Share on other sites
  • 0
Désolé Zendik
Effectivement c'est bizarre qu'il n'y ai pas le bas de page.
j'ai configuré mon .htaccess pour afficher les erreurs mais rien.
je peux éventuellement t'envoyer le code source de la page.
voici la fin du code source de la page module dans la console d'administration.

Merci pour votre aide

Share this post


Link to post
Share on other sites
  • 0
[quote author="Zendik" date="1231335963"]Un truc bizarre dans la capture c'est qu'il manque le footer :
[color=green]Powered by PrestaShop™ [ forum & contact ] - Version 1.1.0.5 - 3.121s[/color]

Ceux qui ont le problème pourraient peut-être regarder dans le code source de la page s'il n'y a pas une erreur PHP ou bien activer l'affichage des erreurs.[/quote]
Comment peut on faire pour afficher les erreurs ?
error_reporting(E_ALL); doit il être placée à un endroit précis ?

Share this post


Link to post
Share on other sites
  • 0
Salut Xdiz !
en fait il ne sert a rien de modifier ton .htaccess pour afficher tes erreurs puisque qu'il y un fichier qui bloque cette commande.
Il faut aller dans ton dossier config/ et ouvrir config.inc.php pour modifier la ligne suivante : @ini_set('display_errors', 'on');
tu pourras ensuite vérifier tes erreurs.

En ce qui concerne Zendik, j'ai trouvé la solution à mon problème c'est à dire pour afficher la liste des modules dans l'admin, ce sur quoi traite ce topic.
Il s'agit d'erreur d'url (parse_url() expects exactly) qui à mon humble avis pose problème sur certains serveurs.
J'ai contourné le problème en redonnant une adresse url absolue vers les modules.
Voilà.

À bientôt

Share this post


Link to post
Share on other sites
  • 0
Salut tche et Zendik,

Merci pour l'info, donc mon erreur proviendrait de Type.php qui n'est pas trouvable ...
[code]Warning: require_once(Parser/Type.php) [function.require-once]: failed to open stream: No such file or directory in ../tools/pear_xml_parser/Parser.php on line 29

Fatal error: require_once() [function.require]: Failed opening required 'Parser/Type.php' (include_path='.:') in ../tools/pear_xml_parser/Parser.php on line 29[/code]

Ton hébergeur est 1&1;? Tu as modifié [code]define('__PS_BASE_URI__', '/');[/code] comment ?

Merci de votre aide

Share this post


Link to post
Share on other sites
  • 0
alors essai de changer le lien dans le fichier parse.php avec un lien absolu par rapport à ton serveur et non un chemin relatif.
Pour moi çà a fonctionné mais tout dépend de la configuration de ton serveur. C'est en fait des include php qui ne font pas le bon relais par rapport à ton serveur.
Par contre si tu déplace ensuite l'emplacement de ton site in faudra bien penser à changer également ce lien sinon tu auras encore le même souci.

Bon courage à toi.
Tcé

Share this post


Link to post
Share on other sites
  • 0
Salut,

Merci pour tes conseils, mais je viens de voir après quelques jours (je suis long à la détente), que dans le fichier Parser.php
[code]require_once 'Parser/Exception.php';[/code]
Le dossier Parser avait un P majuscule, alors que sur mon ftp , il était avec un p minuscule.

J'ai eu le même souci avec mon dossier (tools/swift/) swift qui n'avait pas le S majuscule :)

Merci à la team Presta et aux forumeurs ;)

Share this post


Link to post
Share on other sites
  • 0
Vive les fonctions Recherche de ce forum.
Pas une question mais mes notes Wiki d'installation au cas où elles puissent aider, car je viens de rencontrer un souci identique:

[b]Le contexte:[/b]
PrestaShop Version 1.1.0.5
Serveur Plesk (8.3, dédié) running PHP5

[b]Le problème:[/b]
L'installation par défaut de Prestashop pose un souci assez dur à détecter sur serveur Plesk: Sections manquantes dans l'admin du site, et de façon vicieuse car la page apparait complète mais elle s'arrete au milieu.
Du coup pas de modules dont paiements, Paypal etc. En fait la source HTML de la page est effectivement tronquée: pas de fin de page.

[b]La cause:[/b]
Erreur fatale PHP, trouvée dans les logs du serveur Apache:
[client IP] PHP Fatal error: main() [function.require]: Failed opening required 'Parser/Type.php' (include_path='.:.:') in /var/www/mon-site/tools/pear_xml_parser/Parser.php on line 29, referer: http://votre-domaine.com/admin/index.php?tab=AdminPreferences&token=xx
En cause: lignes 29 et 34 du fichier /www/tools/pear_xml_parser/Parser.php: Le chemin include n'est pas accepté par un serveur Plesk PHP5.

[b](Ma /une ?) Solution:[/b]
Changer le lien include qui n'est pas accepté en l'état.
Possible: mettre "en dur" le chemin de votre serveur, mais effectivement à ne pas oublier en cas de migration !
Plus intéressant: en faire un chemin "relativement absolu" :-) fonctionnant même si le site est migré, en utilisant $_server['DOCUMENT_ROOT']."

Les appels deviennent donc

require_once $_SERVER['DOCUMENT_ROOT' ].'/tools/pear_xml_parser/Parser/Type.php';
require_once $_SERVER['DOCUMENT_ROOT' ].'/tools/pear_xml_parser/Parser/Exception.php';

et c'est réglé !

Edit: Je vais chercher s'il est intéressant de noter ceci dans le bugtracker ou le suggérer en solution, peut être plus efficace que dans un post perdu ? Je débute sur ce forum ;-)

Share this post


Link to post
Share on other sites
  • 0
Bonjour,
c'est l'horreur.
La migration d'un site de vente assez conséquent est prête (zencart -> prestashop). Je pensais mettre en prod depuis 1semaine mais que des soucis sur un serveur dédié OVH. Je pensais que cela venait de mon code et après avoir tout testé j'ai forcément essayé la version de base car j'ai fait pas mal de modif par rapport à celle-ci. Et là : BOUH des erreurs super difficiles à identifier et tout : j'ai effectivement pas de pied de page dans l'admin pour catégories, produit, modules. J'ai tenté beaucoup beaucoup de chose, les chmod, les base_uri, ta solution netagence et rien de positif.
Aie aie aie. Je devais mettre en prod cela depuis plus d'une semaine et je m'arrache les cheveux sur ce soucis qui doit être un vieux truc mais j'ai pas encore trouvé. J'ai mis des echo partout (construct des modules, display, etc. etc. mais pffff rien de très explicite).
Je suis perdu ! Bon, je test l'install sur serveur mutualisé... histoire de restester un truc mais je commence à saturer.

Quelqu'un a-t-il réussi à faire fonctionner Prestashop 1.1 sur serveur dédié OVH ?

Share this post


Link to post
Share on other sites
  • 0
Hé bien oui on ne gère quasiment que des serveurs dédiés, quelques-uns chez OVH, et ça fonctionne.
Si tu as accès à toute la machine les logs devraient t'aider, force l'affichage d'erreurs PHP et tu devrais les voir ? Le bug le plus courant qu'on a vu était ces pbs d'Includes que j'ai détaillé.
Bon courage.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×