Jump to content

Recommended Posts

Hilfe, plötzlich bekomme ich einen "500 Server Error" wenn meine Kunden beim Auschecken wollen.
In dem Moment, wenn man von "Adresse" auf Weiter klickt um zu Zahlungsarten zu kommen, erscheint plötzlich der Error!
 

Aus dem Nichts... ich hab nichts umgestellt oder geändert oder so...

Folgende Fehlermeldung bekomme ich, wenn ich in "config/defines.inc.php" Datei folgendes ändere

Quote

define('_PS_MODE_DEV_', false);
zu
define('_PS_MODE_DEV_', true);

Quote

(1/1) ContextErrorException

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

in MessageFactory.php line 197

at ErrorHandler->handleError(2, '"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?', '/var/www/web1704/html/shop/vendor/guzzlehttp/guzzle/src/Message/MessageFactory.php', 197, array('class' => 'GuzzleHttp\\Message\\MessageFactory', 'e' => 32767, 'file' => '/var/www/web1704/html/shop/vendor/composer/../guzzlehttp/guzzle/src/Message/MessageFactory.php', 'wasCached' => false))in DebugClassLoader.php line 146

at require()in DebugClassLoader.php line 146

at DebugClassLoader->loadClass('GuzzleHttp\\Message\\MessageFactory')

at spl_autoload_call('GuzzleHttp\\Message\\MessageFactory')in Client.php line 78

at Client->__construct(array('base_url' => 'https://api-addons.prestashop.com', 'defaults' => array('timeout' => '5.0'), 'headers' => array('Accept' => 'application/json')))in ModuleManagerBuilder.php line 159

at ModuleManagerBuilder->__construct()in ModuleManagerBuilder.php line 77

at ModuleManagerBuilder::getInstance()in Link.php line 782

at LinkCore->getImageLink('', 'de-default', 'large_default')in ImageRetriever.php line 226

at ImageRetriever->getNoPictureImage(object(Language))in FrontController.php line 1517

at FrontControllerCore->getTemplateVarUrls()in FrontController.php line 1843

at FrontControllerCore->makeLoginForm()in OrderController.php line 114

at OrderControllerCore->bootstrap()in OrderController.php line 79

at OrderControllerCore->postProcess()in Controller.php line 244

at ControllerCore->run()in Dispatcher.php line 428

at DispatcherCore->dispatch()in index.php line 28

 

Was bedeutet das? Warum läuft der Shop plötzlich nichtmehr? :////// HELP PLEASE 

Bildschirmfoto 2019-11-11 um 21.15.38.png

Edited by coffeefish (see edit history)

Share this post


Link to post
Share on other sites

Wenn ich den DEBUG Modus in Presta 1.7 anschalte kommt folgendes

Quote

(1/1) ContextErrorException

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

in UnitOfWork.php line 2636

at ErrorHandler->handleError(2, '"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?', '/var/www/web1704/html/shop/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php', 2636, array('class' => 'Doctrine\\ORM\\UnitOfWork', 'e' => 32767, 'file' => '/var/www/web1704/html/shop/vendor/composer/../doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php', 'wasCached' => false))in DebugClassLoader.php line 146

at require()in DebugClassLoader.php line 146

at DebugClassLoader->loadClass('Doctrine\\ORM\\UnitOfWork')

at spl_autoload_call('Doctrine\\ORM\\UnitOfWork')in EntityManager.php line 160

at EntityManager->__construct(object(Connection), object(Configuration), object(ContainerAwareEventManager))in EntityManager.php line 850

at EntityManager::create(object(Connection), object(Configuration))in appDevDebugProjectContainer.php line 1050

at appDevDebugProjectContainer->getDoctrine_Orm_DefaultEntityManagerService()in appDevDebugProjectContainer.php line 1126

at appDevDebugProjectContainer->getPrestashop_Adapter_DataProvider_ModuleService()in appDevDebugProjectContainer.php line 1305

at appDevDebugProjectContainer->getPrestashop_Twig_Extension_HookService()in appDevDebugProjectContainer.php line 1522

at appDevDebugProjectContainer->getTwigService()in appDevDebugProjectContainer.php line 2524

at appDevDebugProjectContainer->getSensioFrameworkExtra_View_ListenerService()in appDevDebugProjectContainer.php line 1949

at appDevDebugProjectContainer->ContainerJqhqung\{closure}()in EventDispatcher.php line 229

at EventDispatcher->sortListeners('kernel.controller')in EventDispatcher.php line 61

at EventDispatcher->getListeners('kernel.controller')in ContainerAwareEventDispatcher.php line 128

at ContainerAwareEventDispatcher->getListeners('kernel.controller')in TraceableEventDispatcher.php line 250

at TraceableEventDispatcher->preProcess('kernel.controller')in TraceableEventDispatcher.php line 134

at TraceableEventDispatcher->dispatch('kernel.controller', object(FilterControllerEvent))in HttpKernel.php line 139

at HttpKernel->handleRaw(object(Request), 1)in HttpKernel.php line 68

at HttpKernel->handle(object(Request), 1, false)in Kernel.php line 200

at Kernel->handle(object(Request), 1, false)in index.php line 88

 

Share this post


Link to post
Share on other sites
56 minutes ago, JBW said:

Selbe Fehlermeldung? Kann eigentlich nicht sein da die continue Warnung erst mit 7.3. eingeführt wurde, siehe

https://www.php.net/manual/en/migration73.incompatible.php

Es ist eh nur eine Warnung die bei deaktivierten Debug Modus ignoriert wird, denke du hast noch einen anderen Fehler drin.

Also ich meinte der 500 Server Error bleibt trotzdem.
Wenn ich den Debug einschalte kommt jetzt folgendes:

Quote

[PrestaShopException]

Kein Eintrag in Address->id_country
at line 954 in file classes/ObjectModel.php

949. } 950. 951. $message = $this->validateField($field, $this->$field); 952. if ($message !== true) { 953. if ($die) { 954. throw new PrestaShopException($message); 955. } 956. return $error_return ? $message : false; 957. } 958. } 959.

ObjectModelCore->validateFields - [line 272 - classes/ObjectModel.php]

ObjectModelCore->getFields - [line 529 - classes/ObjectModel.php]

ObjectModelCore->add - [line 174 - classes/Address.php] - [2 Arguments]

AddressCore->add - [line 487 - classes/ObjectModel.php] - [2 Arguments]

ObjectModelCore->save - [line 76 - classes/form/CustomerAddressPersister.php]

CustomerAddressPersisterCore->save - [line 157 - classes/form/CustomerAddressForm.php] - [2 Arguments]

CustomerAddressFormCore->submit - [line 111 - classes/checkout/CheckoutAddressesStep.php]

CheckoutAddressesStepCore->handleRequest - [line 61 - classes/checkout/CheckoutProcess.php] - [1 Arguments]

CheckoutProcessCore->handleRequest - [line 262 - controllers/front/OrderController.php] - [1 Arguments]

OrderControllerCore->initContent - [line 255 - classes/controller/Controller.php]

ControllerCore->run - [line 428 - classes/Dispatcher.php]

DispatcherCore->dispatch - [line 28 - index.php]

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More