Jump to content
Jürgen Weber

[PrestaShopException] No access reference in table module_access for id_module 90. at line 2538 in file classes/module/Module.php

Recommended Posts

Hallo zusammen,

ich habe ein großes Problem und dazu keine Lösung gefunden. (nur irgendwelche englischen Beiträge die ich mit meinem wenigen englisch als nicht zielführend empfand)

Ich habe gestern Prestashop 1.6.xx auf 1.6.1.24 geupdatet. Hatte mir vorher 1clickupgrade von Prestashop geholt. Nach dem Update haben viele Bilder und sonst noch was gefehlt und da es schon spät war, machte ich das Rollbackup.

Dann kam die Fehlermeldung wie sie auf dem Bild zu sehen ist. Ich habe dadurch KEINEN Zugriff mehr auf Prestashop.

Ich benötige dringend Hilfe 😭

Jemand eine Idee was ich alles probieren kann?

 

Ich  habe von der SQL-Datenbank vorher eine Sicherung gemacht.

Vom Prestashop selbst, dachte ich, ich hätte auch eine gemacht, hat sich aber heute morgen herausgestellt, dass da auch was schief gelaufen ist.

Bitte keine Fragen wieso ich so gehandelt habe, es ist so gewesen, ich kann die Zeit nicht mehr zurück drehen und über meine Dummheit, könnt ihr mir glauben, ärgere ich mich am meisten!

 

Danke vorab!!

 

 

image.thumb.png.44fea22e540b8bff5b964593912c8b46.png

Share this post


Link to post
Share on other sites

Wie hast du die Sicherung zurückgespielt? War das Rollback erfolgreich oder kamen dort Fehlermeldungen?

Es fehlt ein Eintrag für das Modul mit der ID 90 in der module_access Tabelle - entweder stimmt also die Datenbank nicht oder der Shop greift anders drauf zu. Temporär kannst du versuchen in der Datenbank der Modul mit der ID zu finden und dann dort oder durch umbennen des Ordners auf dem Server zu deaktiveren.

Dein Webhoster hat doch sicherlich auch Backups deines Servers - wenn nix hilft können die bestimmt mit einem Rollback helfen.

Bei nächsten Upgrade vorher auf einem Klon ausprobieren bevor du es live machst - weißt du sicherlich, kann man hier gar nicht oft genug wiederholen.

  • Like 1

Share this post


Link to post
Share on other sites

Danke für die Antwort @JBW

es war so, dass nach dem Update, einige Bilder nicht mehr angezeigt waren. Dann habe ich Rollback gedrückt und während dieses ausgeführt wurde, ist auf einmal diese Fehlermeldung erschienen.

Das Problem ist nun "gelöst". Wie Du richtig angemerkt hast, hat mein Webhoster für die letzten 6 Tage Backups. Also schonmal dieses Problem gelöst. Zum Glück hatte ich noch ein Backup der SQL-Datenbank gemacht bevor ich das Update durchgeführt habe.

So habe ich das Backup vom Webhoster eingespielt. Ging noch nicht.

Dann die gesamte (defekte?) SQL-Datenbank sicherheitshalber gesichert, und dann gelöscht. Danach mein Backup der SQL-Datenbank eingespielt und jetzt geht wieder alles!

Wie man es ohne diesen glücklichen Zustand gelöst hätte, keine Ahnung..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More