Jump to content
ballashop

Paypal native module has a problem with Google Tag Manager Enhanced Ecommerce (UA) - PRO module

Recommended Posts

Hi, 

I discovered that the Paypal native module has a problem with Google Tag Manager Enhanced Ecommerce (UA) - PRO module.
Since I upgraded the paypal module to 3.13.1, the GTM module no longer sends data to Google Analytics.
While orders with another payment system send the data correctly.
Checking paypal update date folder corresponds to the start of the GTM module malfunction.

Has anyone had the same problems?
I've contacted the developers of both modules, I'm waiting for an answer.
Thanks.

PS 1.6.1.24

Paypal 3.13.1

GTM 4.6.3

Edited by ballashop (see edit history)

Share this post


Link to post
Share on other sites

Yes also having the same problem and been hunting for a solution. I don't know if its because the sale is sent back to "/authentication?back=history" instead of an order confirmation page or if that's just a separate issue.

Share this post


Link to post
Share on other sites

Hi @Floobynooby

we made a test with paypal native module version 3.13.0, the previous version. The sandbox test worked. The problem could therefore depend on the new version of the Paypal module.

I await confirmation from other orders.

Thanks, bye.

Edited by ballashop (see edit history)

Share this post


Link to post
Share on other sites

I have this issue with paypal 3.13.1 and presta 1.6.1.4 - all orders are finished with history page with order-confirmation skipped... any solution for that?

Share this post


Link to post
Share on other sites

Hello @mszysko,

 

This issue has been fixed in the v.3.14.0. 

Please update your module and do not hesitate to contact our support team if you hav any additional questions.

 

Best regards,

 

 

 

Share this post


Link to post
Share on other sites

The current version for downloading is: v3.14.2-paypal does this version work for prestashop 1.6 as v.3.14.0 is no longer available ?

Share this post


Link to post
Share on other sites

Hello !

 

Yes, sure,  v3.14.2 will work in PS 1.6. You will see it when you download the module.

image.thumb.png.1cea5c8a7c98ebcedb0ef4693171e414.png

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More