Jump to content
HaMo

Backend-Login funktioniert nicht / Fehlermeldung http error 500

Recommended Posts

Hallo Community,

seit 04.11.2019 Vormittag können alle Zugangsberechtigte sich nicht ins Backend einloggen. Fehlermeldung: 

"Diese Seite funktioniert nicht

Name der Webseite.de kann diese Anfrage momentan nicht verarbeiten.

HTTP ERROR 500"

 

Kunden können den Shop besuchen. 
Die Umbenennung /module/gamification brachte keinen Erfolg.
 

Der Shop liegt auf einem one.com-Server. Php 7.3.; PrestaShop 1.7.2

Kann uns jemand helfen?

Beste Grüße
Feng Shui Team

Edited by HaMo
Ergänzung (see edit history)

Share this post


Link to post
Share on other sites

Ohne Eingriffe in den Core dürfte der Shop unter PHP 7.3 auch nicht richtig rundlaufen. Es gibt bisher keine 1.7er-Version, die mit PHP 7.3 voll kompatibel ist. Version 1.7.2 schon mal gar nicht! Darauf weist nicht nur PrestaShop hin, es wird auch in zahlreichen Beiträgen in diesem Forum immer wieder beklagt. 

Und um das gleich vorwegzunehmen: Es gibt zwar gute Anleitungen und Patches, um PreestaShop 1.5 oder 1.6 an PHP 7.3 anzupassen, aber mir ist keine für PrestaShop 1.7 bekannt.

Ach ja, und noch was: Um das Modul gamification unschädlich zu machen, reicht die Deaktivierung nicht aus. Ihr müsst es deinstallieren!

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites
vor 8 Stunden schrieb HaMo:

Hallo Community,

seit 04.11.2019 Vormittag können alle Zugangsberechtigte sich nicht ins Backend einloggen. Fehlermeldung: 

"Diese Seite funktioniert nicht

Name der Webseite.de kann diese Anfrage momentan nicht verarbeiten.

HTTP ERROR 500"

 

Kunden können den Shop besuchen. 
Die Umbenennung /module/gamification brachte keinen Erfolg.
 

Der Shop liegt auf einem one.com-Server. Php 7.3.; PrestaShop 1.7.2

Kann uns jemand helfen?

Beste Grüße
Feng Shui Team

 

Share this post


Link to post
Share on other sites

ERLEDIGT

Auf php 7.1 zurück gesetzt; funktioniert wieder. Nur wie lange? Wann funktioniert es auch mit php 7.2?

Share this post


Link to post
Share on other sites

Selbst die neueste Version 1.7.6.1 zeigt unter PHP 7.2 immer mal wieder Schwächen und Fehlermeldungen.

Am schönsten kann man das bei einer lokalen Installation unter Xampp beobachten, natürlich nur mit einer Minimalversion nach Abschaltung aller Speicherfresser wie dn Statistik-Modulen oder dem Oberbremser Handelserfolg (gamification). Da bei allen möglichen Aktionen eine der zahllosen Einzeldateien kompiliert oder gecached wird, häufen sich die 500er-Fehler exponentiell, wenn man z.B. eine zweite Instanz des Back Office in einem anderen Browserfenster laufen lässt, also z.B. in einem die Artikel, in einem anderen die Bestellungen. Irgendwann lädt eine Seite gar nicht mehr und das Programm hängt sich auf. Und spätestens bei drei verschiedenen Ansichten in Browsertabs ist endgültig Sendepause, denn 1.7 ist alles, nur nicht multitaskingfähig. 

PrestaShop hat es selbst nach über drei Jahren Entwicklungszeit nicht auf die Reihe gebracht, 1.7 zur Marktreife zu bringen. Und da immer noch soviel zu fixen ist  oder neue Fehler eingebaut werden, läuft man solchen Entwicklungen wie etwa der PHP-Version weit hinterher. Das steht eben nicht oben auf der Agenda.

Aber jeder User muss selbst wissen, was er sich und seinen Kunden zumutet.

Share this post


Link to post
Share on other sites
vor 10 Stunden schrieb HaMo:

Auf php 7.1 zurück gesetzt; funktioniert wieder. Nur wie lange? Wann funktioniert es auch mit php 7.2?

Deine Version ist ja schon recht alt, ggf. würde ich auf 1.7.5.2 (eher nicht auf 1.7.6.x) upgraden, PHP 7.2 sollte da laufen.

Share this post


Link to post
Share on other sites
16 hours ago, Wuschel said:

Am schönsten kann man das bei einer lokalen Installation unter Xampp beobachten, natürlich nur mit einer Minimalversion nach Abschaltung aller Speicherfresser wie dn Statistik-Modulen oder dem Oberbremser Handelserfolg (gamification). Da bei allen möglichen Aktionen eine der zahllosen Einzeldateien kompiliert oder gecached wird, häufen sich die 500er-Fehler exponentiell, wenn man z.B. eine zweite Instanz des Back Office in einem anderen Browserfenster laufen lässt, also z.B. in einem die Artikel, in einem anderen die Bestellungen. Irgendwann lädt eine Seite gar nicht mehr und das Programm hängt sich auf. Und spätestens bei drei verschiedenen Ansichten in Browsertabs ist endgültig Sendepause, denn 1.7 ist alles, nur nicht multitaskingfähig. 

Kann ich weder bei meinen lokalen Xampp Installationen noch bei eigenen und Kunden-Server Instanzen so bestätigen. Wenn Server und Shop gut konfiguriert sind laufen die eigentlich sehr stabil. Evtl. hast du ein lokales Problem mit deinem Browser o.ä. - aufhängen kann sich ja nicht Prestashop sondern nur dein Client oder der Server.

Share this post


Link to post
Share on other sites
1 hour ago, JBW said:

Evtl. hast du ein lokales Problem mit deinem Browser o.ä. - aufhängen kann sich ja nicht Prestashop sondern nur dein Client oder der Server.

Glaube ich eigentlich nicht, dass ich da ein Problem habe. Nur damit wir nicht aneinander vorbei reden: Ich sprach von 1.7.6.1 unter Firefox, Chrome oder Opera und PHP 7.2 im Vergleich zu PrestaShop 1.5.6.3 oder 1.6.1.10 bzw. 1.6.1.24.

Da Prestashop 1.7 nun mal in Symfony programmiert wurde, das PHP 7.3 nicht beherrscht, läuft es im Gegensatz zu den Vorversionen ja nicht unter der neuesten PHP-Version. Wie soll das dann erst bei PHP 7.4 oder gar 8 werden, die uns demnächst ins Haus stehen?

OK, 1.6 ist ohne gute  Anpassungen auch schon langsamer als 1.5, aber 1.7 geht doch schneller in die Knie. Trotz optimierten OPCache-Werten gerade mal wieder einen 500er kassiert, und das nur beim Import einer zusätzlichen Sprache, während zwei andere Fenster geöffnet waren. Man muss erst alle anderen Instanzen schließen, damit im Hintergrund wieder neu kompiliert werden kann für den Cache. Solche Aussetzer kennt man von früheren Versionen nicht. Symfony lässt grüßen!

Share this post


Link to post
Share on other sites
27 minutes ago, Wuschel said:

. Nur damit wir nicht aneinander vorbei reden: Ich sprach von 1.7.6.1 unter Firefox, Chrome oder Opera und PHP 7.2

Ja ich auch :) Wie gesagt grundsätzlich laufen die 1.7er Versionen seit 1.7.5 ziemlich stabil. 500er in Verbindung mit dem Cache treten bei mir auch bei einem Test-Shop auf und lassen sich nur durch Löschen von /var/cache beseitigen  - da scheint es wirklich ein grundlegendes Problem zu geben das man auch bei vielen Posts hier im Forum sieht. Seltsamer Weise funktionieren andere Instanzen in selber Version auf demselben Server einwandfrei.
 

Share this post


Link to post
Share on other sites

Nur kann man schlecht seinen Kunden raten, alle Nase lang den Cache manuell zu löschen.

Die Crux scheint doch zu sein, dass Prestashop 1.7 auf das Caching offenbar dringend angewiesen ist, weil sonst die Performance zu sehr leidet. Denk nur mal daran, dass bei der Installation angeraten wird, den Realpath Cache auf 5 MB zu setzen. Das hört sich nach mehr an als es ist, denn angesichts der abertausend Core-Dateien wird es rein rechnerisch selbst damit schwierig, auch nur zwei Instanzen des Shops gleichzeitig zu betreiben. Der Cache fasst also bei einer Kalkulation von 112 Bytes pro Eintrag  knapp 46.000 Einträge, die sind schneller erreicht, als man glaubt.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More