Jump to content
Atwist

(Gelöst) Sprach auswahl Kunden

Recommended Posts

Versuche im Frontend die sprach Auswahl für die Kunden hinzubekommen, weis eben nicht mehr wo ich es suchen muss.

Die sprachen Deutsch und Niederländisch sind installiert, normal steht, dann die sprach Auswahl neben die Anmeldung (siehe Bild)

Bin dass ganze Wochenende schon mit mein Shop beschäftigt um alles wieder herzustellen.  Dass war mein Problem

sprache.png

Edited by Atwist (see edit history)

Share this post


Link to post
Share on other sites

Ist das entsprechende Modul aktiviert und auf dem richtigen Hook zugewiesen?

Share this post


Link to post
Share on other sites

Hallo JBW,

Welche Modul muss dass sein, ist vielleicht eine blöde Frage, aber mein Kopf Platz grade noch nicht und habe etwas Zeitdruck der Webshop sollte am 1. November schon online sein.

 

Dass Modul hab ich gefunden, jetzt noch der Hook

 

Edited by Atwist (see edit history)

Share this post


Link to post
Share on other sites

Das Modul ist An Hook displayAdminAfterHeader Verbunden gleich wie die Anmeldung

Share this post


Link to post
Share on other sites

Das Modul "Sprachen Auswahl Block" gehört ind den displayNav2 Hook (zumindest beim 1.7. classic Theme)

 

grafik.thumb.png.d7820d85314a968c39fbf7ae3fb8308f.png

Share this post


Link to post
Share on other sites

Ist zwar *** off topic ***,  aber das muss ich jetzt doch noch los werden angesichts des vorstehenden Bildes.

Es rächt sich wohl allmählich, dass die für die Übersetzungen bei Prestashop zuständige Französin offenbar kein Deutsch spricht und es seit April anscheinend keinen deutschen Proof Reader mehr gibt. Nicht nur, dass im Frontend von 1.7 immer noch statt "inkl. MwSt." gelegentlich das Wort "Bruttopreis" hinterm Preis steht, auch so was hier stimmt neben vielen andern Ungereimtheiten bedenklich. Hier mal der Vergleich zur Übersetzung in 1.5/1.6:

Block Währungen --> Währungsblock

Block Sprachen --> Sprachen Auswahl Block

Block Kundenbereich --> Kundenanmeldungs-Link

Block Warenkorb --> Warenkorb

Das kann ja noch heiter werden!

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Ich habe Version 1.7.6.1

 

Weis nicht was ich Falsch mache bekomme auf jeden Fall kein sprach Auswahl block.

Sprach Auswahl block ist verbunden an displayNav2 Hook.

Immer noch kein sprach block.png

Edited by Atwist (see edit history)

Share this post


Link to post
Share on other sites

Wo ich dass sprach Auswahl block auch hinstelle (Hook) ich bekomme ihm nicht zu sehen.

Etwas stimmt nicht mit der Modul glaube ich, aber was ist jetzt die Frage.

Share this post


Link to post
Share on other sites

Aktiviert ist das Modul aber, oder? Bekommst du irgendwelche Fehlermeldungen wenn du den Debug Modus aktivierst?

Share this post


Link to post
Share on other sites

Ich meine Errors falls du die Frontend-Seite aufrufst, nicht den Admin-Bereich. Evtl. auch mal im Server-Error-Log schauen.

Share this post


Link to post
Share on other sites

Dass verstehe ich nicht, ich habe nur 2 Möglichkeiten Debug Ja / Nein kann es nicht anders einstellen.

Share this post


Link to post
Share on other sites

Wenn DEBUG auf JA eingestellt ist, dann erhältst du im Frontend eventuell Fehlermeldungen. Das scheint ja nicht der Fall zu sein. 

Hast du überhaupt das Default Theme im Einsatz oder nutzt du ein anderes Template? Falls jletzteres der Fall sein sollte, dann solltest du prüfen, ob dieses Template nicht eigene Module mitbringt. Dann müsste das Währungsmodul von PrestaShop nämlich deinstalliert und das Template-eigene installiert werden. Den Hook sollte es dann, vorausgesetzt, das Template ist mit deiner 1.7-Version kompatibel, auch von allein finden.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Dann ist die letzte Sache die mir einfällt dass evtl. eine der Sprachen zwar installiert aber nicht aktiviert ist!? Falls die auch beide aktiv sind müsste man sich den Shop mal genauer ansehen bzw. debuggen.

Share this post


Link to post
Share on other sites

Sind denn Caches in Prestashop und Browser gelöscht? Probiere mal einen anderen Browser / PC.

Share this post


Link to post
Share on other sites

Okay ich hab den Fehler gefunden,

Der Fehler wurde verursacht durch eine Module die ich für meine Hintergrund benutze "colorchange", diese Module ändert auch die Text Farbe von bestimmte Texte von andere Module.

Die Text bekommt dann die gleiche Farbe als die Hintergrund, siehe die Bilder.

Mann kann es einfach in der CSS Datei ändern

/modules/colorchange/views/css   und dann die Datei 1ch.css Zeile 3

#header .header-nav .currency-selector{color:#2fb5d2 !important}

#2fb5d2 ändern in deine Farbe.

Nach meine Meinung ist dass ein BUG in der "colorchange" Module

Farbe nicht okay.png

Farbe okay.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More