Jump to content
BriceVanZeg

[RESOLU] Update de 1.6.0.8 =>> 1.6.1.24

Recommended Posts

Bonjour a tous.
J ai un gros soucis, sur mon site, impossible de mettre a jour mes produits, ni d'en ajouter des nouveaux.
J ai vu sur le forum et autre, qu il y avait un patch pour changer qq fichiers, mais rien n y fait.
Donc, je voudrais updater ma version pour passer a la 1.6.1.24.  (je suis actuellement en 1.6.0.8)
Puis je simplement faire via le FTP un upload de la presta 1.6.1.24,  ou il y a des choses a changer dans la BDD.?
Merci de m éclairer, car ca fait une paire de semaine que je séche la dessus, et les fetes approchent.!
Au plaisir de vous lire les prestaunautes.

Fabrice

 

Edited by BriceVanZeg (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

utiliser le module autoupgrade -> mode expert -> version mineure et roule ma poule^^

  • Thanks 1

Share this post


Link to post
Share on other sites

Merci Eolia, je vois que tu es toujours a fond sur le Forum, Chapeau bas.!
Je teste ca dés ce soir, car c'est un peu l heure du rush (enfin facon de parler, car c'est pas non plus Byzance)
Je vous tiens au courant, j ai fait une sauvegarde via le FTP pour récupérer tous mes fichiers, Sauver ma BDD en plusieurs morceaux (car trop lourde), via Phpmyadmin.
J ai réglé le mode expert sur :


Version Mineures (recommandée)

Branch: Available
Name: 1.6.1 stable
Version number: 1.6.1.24
URL: https://download.prestashop.com/download/releases/prestashop_1.6.1.24.zip
MD5 hash: 8cd5dd3470bc42137c1018a1a8e97c0a

Options de Sauvegarde :
Back up my files and database : Non
Back up my images                     : Non

Options de Mise a jour :
Puissance du serveur                  : Basse
Désactiver les modules non-natifs : Oui
Upgrade the default theme         : Non
Switch to the default theme       : Non
Keep the customized email templates : Non

Edited by BriceVanZeg (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

Upgrade the default theme         : OUI

Et rajoutez les 2 champs cachés qui vont manquer dans votre contact-form.tpl

  • Thanks 1

Share this post


Link to post
Share on other sites

Attention il faudra aussi surement aussi réinjecter les js du thème par défaut et peut-être ajuster des éléments des templates address.tpl et product.tpl pour un parfait fonctionnement en 1.6.1.24

  • Thanks 1

Share this post


Link to post
Share on other sites

Yes, Merci...
Par contre, j ai pas upgrade le théme par défaut, mais j ai un théme enfant basé sur le défaut..
Je n ai pas eu trop de casse, a par le menu haut, quelques réglages, je continue a vérifier.
Pour l instant, tout c'est bien passé, je fait quelques controles, commandes, emails, etc... pour controler, mais ca a l air cool.
Encore un grand merci a toi.!

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, Eolia said:

Upgrade the default theme         : OUI

Et rajoutez les 2 champs cachés qui vont manquer dans votre contact-form.tpl

Effectivement, le formulaire de contact ne fonctionne pas.!
Qu'entends tu, par rajouter les 2 champs cachés ?

  • Thanks 1

Share this post


Link to post
Share on other sites

Prestashop a rajouté un controle un peu bidon dans le controleur associé et cherche ces 2 champs.

Si tu compares avec le theme par défaut (mis à jour mais tu ne l'as pas fait semble-t-il) tu verras ces 2 lignes qui te manquent

 

            <div class="submit">
                <input type="text" name="url" value="" class="hidden" />
                <input type="hidden" name="contactKey" value="{$contactKey}" />

                <button type="submit" name="submitMessage" id="submitMessage" class="button btn btn-default button-medium"><span>{l s='Send'}<i class="icon-chevron-right right"></i></span></button>
            </div>

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, katiee96 said:

D'après moi, je préfère d'updater le module par un automatique outil de migration. Dans le passé, j'ai reclassé m prestashop boutique  de 1.4 à 1.6 moi-même mais c'était très mal, il y avait beaucoup d'erreurs et je ne savais pas faire!! Mon ami m'a proposé une service de migration nommée litextension. je l'ai utilisé et je suis content parce que ils ont sauvé ma boutique! 

Oui, J utilise aussi LiteExtension pour passer d'un modèle de boutique a une autre, mais là, ca reste dans une 1.6, je viens de passer de 1.6.0.8 à 1.6.1.24... Donc, comme le précise Eolia, j'ai suivi ses conseils qui sont toujours pertinents et ca s'est plutôt bien passé.!
 

  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour Fabrice, Eolia, doekia et tout le monde,

Je suis dans le meme cas que vous ''Fabrice'', la nécessité en est absolue, je dois mettre a jour ma boutique du 1.6.1.4 vers 1.6.1.24.

J'aimerais juste souligner un point, on a complètement modifier le design du thème directement dans le fichier CSS. Est ce que c'etait votre cas aussi? 

Est ce que le module proposé par vous ''Eolia'' peut transférer ses changement du théme smoothly dans la nouvelle version 1.6.1.24 ?

Vos conseils sont les bienvenues :)

Share this post


Link to post
Share on other sites
6 hours ago, selfsky said:

J'aimerais juste souligner un point, on a complètement modifier le design du thème directement dans le fichier CSS. Est ce que c'etait votre cas aussi? 

Est ce votre CSS du thème par défaut ?

Oui, c’était mon cas également, mais comme je l ai dit, j ai oublié de mettre a jour mon thème dans les options de mis a jour.
Dans tous les cas, sauvegarder votre fichier CSS...!

 

6 hours ago, selfsky said:

Est ce que le module proposé par vous ''Eolia'' peut transférer ses changement du théme smoothly dans la nouvelle version 1.6.1.24 ?

Ce module est le module de base dans presta 'OneClick Update' qui pour moi, comme indiqué plus haut, a fonctionner a merveille.!
Votre Théme, ne sera pas mis a jour, si c'est un théme enfant (smoothly) .! Par contre, mettre a jour le thème par défaut, comme l indique Eolia plus haut..

J ai juste eu quelques réglages a faire, mais rien de bien méchant, et compliqué..

Bon courage,
Bonne Journée


 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

On le fera, merci infiniment.
Juste par curiosité, je vois des prestanautes parlent du version 1.7...
Savez-vous SVP si la version 1.7 est stable, desormais (Novembre 2019) ? S'il y en a, pourquoi vous n'avez pas fais un seul passage directement en 1.7?

Cordialement

Share this post


Link to post
Share on other sites

Si vous voulez vous amuser avec la 1.7 comme beta-testeur, libre à vous. Mais faire tourner 1 million de lignes de code au lieu de 300 000 pour moins de fonctionnalités et plus de bugs je n'y vois aucun intérêt.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More