Jump to content
fox@dog1

Warenkorb Button Probleme

Recommended Posts

Hallo Zusammen

Vieleicht kann mir jemand helfen. Ich suche seit Wochen nach einer Lösung für unser Problem. Es haben viele im Forum ähnliche Probleme, jedoch funktionieren diese Lösungen nicht bei mir.

Wenn ich alle Cookies lösche und dann unsere Seite besuche und ein Produkt in den Warenkorb lege, passiert nichts. Ich kann die Icons anklicken soviel ich will, jedoch ohne Ergebnis. Erst wenn ich die Seite manuell aktuallsiere, zeigt der Warenkorb die Produkte an. Und ab dann funktioniert der Button (Icon) richtig, sodass sich das Popup des Warenkorbs öffnet.

Im Debug-Modus zeigt es mir im BO und auf der Seite keine Fehler an sondern nur Warnungen (Translation not found). Ich habe mit den Browser Firefox und Edge versucht. Beide verhalten sich identisch.

Wir nutzen PS 1.7.5.1 mit der PHP Version 7.1.

 

Besten Dank im Voraus für eure Hilfe.

 

Gruss aus der Schweiz

 

ANjAS-SHOP

Warenkorb.JPG

Share this post


Link to post
Share on other sites

Das hat nichts mit der PHP-Version zu tun, sondern es ist ein seit anderthalb Jahren  bekannter Fehler von 1.7, dr wohl nicht bei jedem und vielleicht auch nur unter bestimmten Voraussetzungen auftritt. Da er umfangreiche Modifikationen erfordert, ist er bislang offenbar immer noch nicht behoben. Einige Theme-Entwickler ( z.B. Sunnytoo) haben daher zur Selbsthilfe gegriffen. Irgendwann schafft es das Prestashop-Team ja vielleicht auch.

Share this post


Link to post
Share on other sites

Danke für Deine Antwort.

Gibt es auch eine Lösung? Oder kann ich den Shop in die Tonne tretten. Weil kein Kunde kommt darauf die Seite zu akutalisieren ;-(

Share this post


Link to post
Share on other sites

Ich kann deinen Ärger gut verstehen. Du kannst entweder auf ein Template zurückgreifen, dass diesen Fehler kompensieren kann, dir einen Programmierer suchen, der die Fehler behebt oder auf eine stabile Prestashop 1.6-Version downgraden. Wir haben hier im Forum an zahlreichen Stellen immer wieder vom Live-Einsatz von 1.7 abgeraten.

Hilft dir jetzt vielleicht nicht viel weiter, aber wenn ich deinen Shop auf dem Smartphone aufrufe, kann ich den Fehler nicht reproduzieren. Das Produkt landet auch ohne Aktualislerung sofort im Warenkorb.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Hast Du mit dem Smartphone den neuen Shop ausprobiert? Link: http://shop.anjasshop.ch/

Hat dieser Bock (Bug) auch einen Namen? Und an was erkenne ich diese Templates, welche den Fehler kompensieren?

Als klar war, dass ich meinen Shop PS 1.5.6 aktualisieren muss, fragte im Forum, welche Version ich nehmen sollte. Damals hiess es, dass die Versionen ab 1.7.3 stabil wären. Und durch aus für den produktiven Gebrauch geeignet wären. Und die Warnungseinträge bei Google betreffs der PS 1.7 waren auch schon 2 Jahre alt.

So ein riesen Quatsch. Monate lange Arbeit und viel Geld für die sch… Module für die Tonne.

Es ist vielleicht an der Zeit ein anderes Shop-System zu suchen.

 

Share this post


Link to post
Share on other sites

Ja, in exakt diesem Shop habe ich es getestet.

Aber wieso aktualisieren? Wer hat dir denn bloß dazu geraten? Von mir hättest du die Antwort 1.7.3 bestimmt nicht bekommen. Ein 1.5.6er Shop unter PHP 7.2 oder 7.3 geht doch ab wie die Post! Die Anpassungen sind nicht sonderlich schwierig und hier zum Download: https://ps.multimedia-bodensee.de/index.php/prestashop-tutorials/prestashop-tricks-tipps/item/6-anpassung-prestashop-1-5-6-2-und-1-6-1x-an-php-7-2.

Laut Angabe von Sunnytoo sollen die Themes Transformer und Panda den 1.7er Fehler umgehen. Beide Themes laufen übrigens full responsive schon unter 1.5.6 und sind super konfigurierbar.

Edited by Wuschel (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

Danke, das ist eine wirkliche Alternative.

 

Ich habe eventuell die Lösung gefunden für meinen Shop. Da ich Daten vom Alten in den neuen Shop migriert habe, könnte da ein Fehler passiert sein.

Im Forum habe ich einen ähnlichen Fehler noch gefunden:

"We migrate old orders, where have id_cart saved.

But carts are not migrated, then started with id from 1.

So, when id_cart was same with id_cart from old order, here was a problem a cart cannot be use. (Due to protection of using carts with finished orders)

So solution was go to database and increase AUTOINCREMENT for column id in table cart to higher, than is higher id_cart in orders."

Nur leider kenne ich mich mit Datenbanken nicht aus und verstehe zurzeit nur Bahnhof. Ich muss schauen, dass ich irgendwo ein Schritt für Schritt Anleitung erhalte oder einen Entwickler finde, welcher mir das Problem in der Datenbank lösen kann.

Share this post


Link to post
Share on other sites

Ein Upgrade von einer 1.5er-Version auf 1.7 ist wirklich nur was für Profis, Probleme sind da vorprogrammiert.

Das Thema mit dem AUTOINCREMENT haben wir gerade in einem anderen Thread.

Share this post


Link to post
Share on other sites

Hallo wmunich

Merci vöu x (Danke viel Mals)! Du bist mein Held. Es hat funktioniert. Nach dem ich im Module Statistik "Plug-Ins-Erkennung" deaktiviert habe, funktioniert der Warenkorb. Ich habe es mit dem Mobile Browser, Firefox und Edge getestet und es läuft.

Im Debug Mode zeigt es mir nur noch Warnungen an. Eine davon ist: "Enabling the "sensio_framework_extra.router.annotations" configuration is deprecated since version 5.2. Set it to false and use the "Symfony\Component\Routing\Annotation\Route" annotation from Symfony itself". Ich weiss nicht, ob die wichtig ist.

Und im Firefox zeigt es mir noch diesen Fehler an:

"Source-Map-Fehler: Error: NetworkError when attempting to fetch resource. Ressourcen-Adresse: moz-extension://05b4729f-a482-4a18-bb77-2b46a53dcd86/content/js/purify.min.js Source-Map-Adresse: purify.min.js.map"

Aber der Shop läuft endlich. Hoffentlich war das der letzte riesen Fehler.

Und danke an euch Alle für eure Hilfe.

Share this post


Link to post
Share on other sites

Ja sorry, es ging mir mehr darum die Lösung meines Problem zu posten.

Ich danke Dir auch. Du hast mir auch sehr geholfen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More