Jump to content
Giampiero AOP

2 errori gravi con modulo PayPal v. 3.13.0 e 3.13.1 su PS 1.5.6.1

Recommended Posts

Buongiorno, su PS versione 1.5.6.1 nella settimana passata ho aggiornato il modulo Paypal alla versione 3.13.0

Ho subito avuto il problema che il cliente dopo aver pagato su PayPal non viene reinviato alla pagina di "Conferma Ordine", ma alla pagina "Storico ordine" oppure "Il mio account" a seconda se loggato o meno.

Ho subito inviato una segnalazione allo sviluppatore.

Successivamente ho visto che era disponibile la versione 3.13.1 (che correggeva alcuni bug) e pensando risolvesse l'ho installata subito.

Ho quindi fatto alcune prove di pagamento è ho riscontrato che il problema non solo non si è risolto, ma se ne è aggiunto un altro, ancor più grave!

Infatti i prodotti nel carrello vengono passati a Paypal arrotondati all'intero più vicino e non al decimale (es. 5,00 € al posto di 5,25 € o 4,75 €).

Quindi, il pagamento va a buon fine ma con l'importo completamente errato, il cliente è spaesato perchè non viene indirizzato alla pagina di conferma, in più viene generato un errore di pagamento nella pagina dell'ordine in backoffice.

 

Ho fatto una nuova segnalazione allo sviluppatore.

Ed essendo la situazione particolarmente grave, ho ripristinato tutto da Backup ad una settimana prima al modulo con meno errori.

 

Il modulo ancor precedente funzionava alla perfezione ma non so come reinstallarlo, non avendo il pacchetto.

 

C'è qualcuno che ha avuto lo stesso problema? e qualcuno che può darmi una mano a risolvere, sperando che nel frattempo facciano una nuova versione senza problemi?

 

 

 

 

Edited by Giampiero AOP (see edit history)

Share this post


Link to post
Share on other sites

Salve G.

io ho una 3.11.6 .....se vuole gliela carico. Certo la piattaforma dovrebbe aggiornarla alla 1.6. Di solito dalla 1.5 alla 1.6 non ci sono particolari traumi 

 

ciao

Share this post


Link to post
Share on other sites
23 hours ago, Fabry said:

Salve G.

io ho una 3.11.6 .....se vuole gliela carico. Certo la piattaforma dovrebbe aggiornarla alla 1.6. Di solito dalla 1.5 alla 1.6 non ci sono particolari traumi 

 

ciao

Grazie, si penso di aggiornare almeno a 1.6, ma col nuovo anno, in un periodo non di punta.

Attendo altre risposte, la sua la tengo cmq in considerazione.

 

Share this post


Link to post
Share on other sites

De nada:-)...quindi ha caricato un modulo precendente alla 3.13?..ossia il 3.12?...cmq la 3.11 non ha problemi per lo meno su ps 1.6.1.18/23 funziona perfettamente.

ciao

Share this post


Link to post
Share on other sites

Ho lo stesso identico problema su Prestashop 1.5.6.2. Nessuna ha trovato una soluzione?

Share this post


Link to post
Share on other sites
11 hours ago, Seetoweb said:

Ho lo stesso identico problema su Prestashop 1.5.6.2. Nessuna ha trovato una soluzione?

Ciao, poi io ho risolto aprendo un ticket allo sviluppatore tramite Prestashop Addons.

Il quale mi ha inviato una versione di prova con alcune modifiche per la mia versione.

Il file con il modulo PayPal che mi hanno inviato ha nome 5db814fb82313.zip

Te lo invierei, ma non so se va bene anche per la tua versione.

Ti suggerisco di provare a contattare l'assistenza e magari segnalare il mio caso risolto.

Ovviamente prima fai il Backup di tutto.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More