Jump to content
Sign in to follow this  
corint1

problema cu sitemap-ul in 1.4

Recommended Posts

ati verificat sitemap-ul generat de presta ? ... am o intrebare , cum se genereaza sitemap-ul presta 14 ? daca il folosesti ... mie imi da numai balarii ... linii duplicat sau pagini care mai apoi nu se regasesc ... de genul site.ro/0 ... nu stiu de unde scoate zero ala de la sfrasit ... il pune la fiecare categorie ... plus ca nu tine cont de robot.txt ... imi pune si paginile pe care ar trebui sa le igonore prin restrictia din robots.txt ... daca vaputeti da cu parerea ,,,,

merci pt timpul acordat

Share this post


Link to post
Share on other sites

Salut,

Eu in afara de Google sitemap nu stiu ca Prestashop 1.4 sa contina, acesta poate fii gasit in Back Office > Modules > Google sitemap. Incearca sa ii dai un update si vezi daca rezolva problema, eu personal inca nu am avut timp sa ma joc cu el.

Share this post


Link to post
Share on other sites

Din ce vad, mie imi genereaza bine sitemap-ul.
Am vazut ca ai deschis si un bilet pentru bug, chestia cu 0 o fi ceva ramasita de la modificarile pe care le-au facut cu iso_lang pentru continut duplicat.

Share this post


Link to post
Share on other sites
ati verificat sitemap-ul generat de presta ? ... am o intrebare , cum se genereaza sitemap-ul presta 14 ? daca il folosesti ... mie imi da numai balarii ... linii duplicat sau pagini care mai apoi nu se regasesc ... de genul site.ro/0 ... nu stiu de unde scoate zero ala de la sfrasit ... il pune la fiecare categorie ... plus ca nu tine cont de robot.txt ... imi pune si paginile pe care ar trebui sa le igonore prin restrictia din robots.txt ... daca vaputeti da cu parerea ,,,,

merci pt timpul acordat


Legat de ceea ce relatezi, este prefect adevarat, ca sa scapi de ramasita din www.exemplu-site.tld/0 raspund astfel. Nu este nici o erroare si nici ramasite din traducerea de limba. Iti indic sa intri in BackOffice pe sectiunea de Module->Advertise & Marketing-> Advertise Block v0.2 intri la configurare. In josul paginii ai sa descoperi acel ZERO de care multi isi fac probleme pe aici si nu am vazut inca un raspuns. Setezi in loc de zero "0" un link sau pui pur si simplu #.

Indicatia mea este sa folosesti friendly-url, te uiti la un link al producatorilor care ii ai sau un link de la orice altceva ce doresti si bagi doar ceea ce este dupa .../ adica renunti la partea www.domeniu.tld/1_producator , adaugand doar 1_producator.

Generarea robotului txt.
Pentru acest lucru indicatia este sa setezi permisiunea de scriere 666 si sa stergi doua din liniile generate prost de generatorul din presta si anume :

User-agent: *
# Directories



cele doua linii sa fie fara spatiul gol intre ele, apoi

# Files
Disallow: /addresses.php


dupa cum vezi si aici cele doua linii nu au spatiu intre ele.

In rest ce sa zic, folositi remove duplicate url, dar faza e ca e pe banuti :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More