Jump to content

Recommended Posts

Buenos días.

Tenía una tienda en Prestashop 1.7 en un dominio .es y lo necesitaba cambiar a .com

En el hosting, he cambiado el dominio asociado al .com

En el backoffice de la tienda, en URL y SEO he cambiado a la ruta nueva (.com) pero no me funciona. He mirado en la base de datos en el registro ps_shop_url y aparece el dominio .com. Pero si entro a la web me aparece: 

The website is not properly configured on this server

If you are the owner of this website, please contact your hosting provider

Si intento entrar al backoffice: 

404 Not Found

The server can not find the requested page:

xxxxxxxx.com/xxxxxx (port 80)

¿Alguien puede ayudarme? ¿Me he saltado algún paso?

Gracias.

Un saludo.

Edited by khasta83 (see edit history)

Share this post


Link to post
Share on other sites

¿Has borrado la caché? También mira en la tabla ps_configuration las entradas PS_SHOP_DOMAIN y PS_SHOP_DOMAIN_SLL, a ver si tienen los valores correctos. Además, si tenías activado un certificado SSL deberás renovarlo si quieres seguir accediendo mediante HTTPS. También puedes desactivar momentáneamente el acceso mediante SSL modificando en la misma tabla (ps_configuration) las entradas PS_SSL_ENABLED y PS_SSL_ENABLED_EVERYWHERE y poniéndolas con valor 0.

Share this post


Link to post
Share on other sites
5 minutes ago, Prestafan33 said:

¿Has borrado la caché? También mira en la tabla ps_configuration las entradas PS_SHOP_DOMAIN y PS_SHOP_DOMAIN_SLL, a ver si tienen los valores correctos. Además, si tenías activado un certificado SSL deberás renovarlo si quieres seguir accediendo mediante HTTPS. También puedes desactivar momentáneamente el acceso mediante SSL modificando en la misma tabla (ps_configuration) las entradas PS_SSL_ENABLED y PS_SSL_ENABLED_EVERYWHERE y poniéndolas con valor 0.

Hola.

En ps_configuration no me aparecen esas entradas. Lo que he hecho ha sido modificarlo en ps_shop_url como he visto en alguna web. 

Sobre la caché, que carpetas debo borrar por ftp?? He borrado las carpetas/cache/smarty/compile y /cache/smarty/cache (sin eliminar los archivos index.php)

Gracias

Share this post


Link to post
Share on other sites

Borra /var/cache.

En ps_configuration deberías tener las entradas que te comento. Busca en la columna "name", deberías encontrarlas.

Share this post


Link to post
Share on other sites
6 minutes ago, Prestafan33 said:

Borra /var/cache.

En ps_configuration deberías tener las entradas que te comento. Busca en la columna "name", deberías encontrarlas.

Acabo de borrar y nada. Y en ps_configuration no tengo ninguna de esas entradas. He desplegado todas las filas y buscado por filtro, y nada. Uso la última versión de Prestashop.

Share this post


Link to post
Share on other sites

 

14 minutes ago, Prestafan33 said:

Borra /var/cache.

En ps_configuration deberías tener las entradas que te comento. Busca en la columna "name", deberías encontrarlas.

Ya lo encontré. El valor es el .com, el que quiero

Share this post


Link to post
Share on other sites

Por fin funciona. Era problema de caché del router. He tenido que resetearlo. 

Lo que no me cargan son algunas imágenes. ¿Cómo soluciono esto?

Gracias

Share this post


Link to post
Share on other sites
9 minutes ago, khasta83 said:

Por fin funciona. Era problema de caché del router. He tenido que resetearlo. 

Lo que no me cargan son algunas imágenes. ¿Cómo soluciono esto?

Gracias

Las que no cargan es porque tienen la ruta del .es. ¿Existe la manera de modificarlo?

Gracias

Share this post


Link to post
Share on other sites

Para las imágenes, vete a Parámetros de la tienda -> Tráfico y SEO. Busca la opción donde dice "URLs amigables", desactívalo y luego vuelve a activarlo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More