Jump to content
Brave1

Erreur d'installation Prestashop 1.7 sur Hebergement OVH

Recommended Posts

Bonjour

Je n'arrive pas à installer Prestashop 1.7.4.3 sur mn hbergement OVH mutualisé perf2014x1 Gold.

Le support OVH me recommande d'installer en mode manuel , chose que j'ai suivi mais  en vain 

ci joint les Erreurs 

BD 1 : au debut de l'installation , je me connecte avec succes au niveau de la base de données 

BD 2 : L'installation ne se poursuit pas 

J ai relancé l'installation à plusieurs reprises ; meme changer de base de données et toujours le meme souci 

 

Merci de votre aide 

BD 1.png

BD 2.JPG

Share this post


Link to post
Share on other sites

Pourquoi installer la 1.7.4 alors que la 1.7.6 est disponible ?

Share this post


Link to post
Share on other sites

J ai le meme cas de figure qlq soit la version de Prestashop 

Share this post


Link to post
Share on other sites

Bonjour

J'ai eu beaucoup de soucis avec l'offre performance d'ovh.

il me semble que le serveur n'arrive pas  communiquer avec la base sql.

Avez vous tenté de recreer une base sql toute fraiche pour l'install ?

Share this post


Link to post
Share on other sites

Bonjour

Ou a moins, si vous avez la possibilité, ce serait de faire une install en utilisant une base sql autre que celle fourni avec votre hebergement.

et ensuite de l'exporter sur votre base sql fourni avec votre hebergement et enfin de modifier parameters.php dans le dossier app/config/parameters.php de votre serveur.

Share this post


Link to post
Share on other sites

Bonsoir 

Là si j'effectue l'installation en mode local avec WAMP je n'ai aucune erreur.
Au niveau de OVH je viens de creer une nouvelle base de données , fraîche jamais utilisée ; aussi sur certains forum on parle de droits ; donc au niveau de mon FTP le dossier d'installation je lui donne chmod 755

Je teste et je reviens 

Share this post


Link to post
Share on other sites

Bonsoir

D’après votre erreur il me semble que c'est lors de la création des tables que ça coince.

Share this post


Link to post
Share on other sites

entre nous , je ne sais plus où cela coince , 
Là je modfie droit sur FTP de 704 à 777

En analysant l'erreur selon ma perception , tous les pre requis sont là , le test de la base de donnée est ok , donc pour Presta et OVH ils sont d'accord
Quand je passe à l'ecran suivant l'installation s'arrete là je l'analyse :
- Presta cherche à se connecter à un serveur pour recuperer des trucs ; mais OVH bloque 
puis l'installation se bloque à 12%

La relation qui exsiste c'est l'utilisation du FTP , le CHMOD sur le dossier d'install je le modifie de 705  vers 777
avec ce changement j'autorise à Presta de faire tout ce qu'elle veut si je compare entre 705 et 777 y a de la différence en Permissions Publiques.
de plus en effectuant ce changement sur le rep qui contient mon site je vois des changement de 644 vers 777

D'une autre coté vous avez raison , la premiere base où j'effectuais l'installation contenait 2 installations de sites differents plus les essaies 

Là j ai une BD vierge et fraiche 

Si un conseil à me donner je suis preneur 

 

BD 1.png

droit 777.JPG

Share this post


Link to post
Share on other sites

Je ne sais pas si c'est une bonne chose de modifier les droits sur le repertoire principal de ton site.Avez vous la possibilité de creer une autre base sql sur un autre serveur ?

Share this post


Link to post
Share on other sites

Supprimer vos base sql inutile .Verifier votre base sql fraichement crée si elle contient des infos et faite le nettoyage a l'interieur.

essayer d'installer un autre cms type wordpress ou joomla pour tester si l'install arrive au bout

Share this post


Link to post
Share on other sites

Le droit CHMOD pour le dossier racine du site doit etre 0755 ou bien 0705 ?

image.thumb.png.2a3be1e32316b45f5013ed0fc2f7c90e.png

 

Là j ai une erreur 

image.thumb.png.c8bf86b0d36143c3283b17abfb7cc46b.png

 

 

Wordpress s'installe sans souci , Joomla aussi sur la meme base sans souci 

Là je vais tout faire de nouveau pour Presta 

Share this post


Link to post
Share on other sites

Bonjour SOLsol

Mon souci est resolu , je suis sur presta 1.7.6.1 , j utilise ma Template Dieu Merci
Alors les manips effectuées :
- Creation d'une nouvelle base de donnée
- Nouveau dossier racine où le site va y etre
- Au niveau du manager PHP 7.2 en mode production
L'installation , effectuée tout est bon aprés verification , avec la commande php info ()
La package Zend engine ajouté par OVH 

image.thumb.png.2482305909a94d123b73dd8258d63553.png

Share this post


Link to post
Share on other sites

Bonjour

Vérifie bien que l'ajout de ou la suppression de nouveau produit, par exemple, s'effectue sans soucis et qu'il n'y as pas de bug suspect avant d'aller plus loin.

Et sur quel base sql a tu fait l'install de presta car il me semble que sur ton offre il y a base sql privée non ? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More