Jump to content
Christine_Rus

Website won't work on PHP Version 7.0

Recommended Posts

I have no technical knowledge at all.  I upgraded WordPress site to Version 5.2.3 which requires at least 5.6.20 version of PHP.  We're using Gatorhost  and cpanel only has PHP version 5.4.45 or 7.0 or 7.1 as an option.  If I choose PHP version 5.4.45, my prestashop site works, but my WordPress site does not work.  If I choose PHP v.7.0, my WordPress site works, but my Prestashop site does not.  I forget the exact error, but I think it reads something like .... a http error 500- page is not working.  Can anyone help in very elementary terms, because I don't understand IT language?  I'm on Prestashop version 1.6.0.14. 

Both sites worked on PHP v 5.4.45, so I thought if I could restore back to the older version in WordPress, we could get both sites functioning again.  But when I tried installing my WordPress backup, it said backup failed.  Some parts were restored from the backup, but the version did not revert back to the older version.  I've attached the error report I received.    

Any guidance anyone can provide would be greatly appreciated.

backup failed 10.07.19.docx

Share this post


Link to post
Share on other sites

That version of prestashop won't work with php 7. I think you'll have to ask the host to add php 5.6.2

Share this post


Link to post
Share on other sites
On 10/12/2019 at 6:10 PM, Christine_Rus said:

I have no technical knowledge at all.  I upgraded WordPress site to Version 5.2.3 which requires at least 5.6.20 version of PHP.  We're using Gatorhost  and cpanel only has PHP version 5.4.45 or 7.0 or 7.1 as an option.  If I choose PHP version 5.4.45, my prestashop site works, but my WordPress site does not work.  If I choose PHP v.7.0, my WordPress site works, but my Prestashop site does not.  I forget the exact error, but I think it reads something like .... a http error 500- page is not working.  Can anyone help in very elementary terms, because I don't understand IT language?  I'm on Prestashop version 1.6.0.14. 

Both sites worked on PHP v 5.4.45, so I thought if I could restore back to the older version in WordPress, we could get both sites functioning again.  But when I tried installing my WordPress backup, it said backup failed.  Some parts were restored from the backup, but the version did not revert back to the older version.  I've attached the error report I received.    

Any guidance anyone can provide would be greatly appreciated.

backup failed 10.07.19.docx 15.17 kB · 0 downloads

Hi Christine_Rus,

The PrestaShop version 1.6.0.14 does not support the PHP v 7 or higher so it will be good to upgrade the PrestaShop version. You can also refer to the following discussion to find a solultion:

 

Share this post


Link to post
Share on other sites

for running multiple domains your hosting control panel needs to support php level by domain.  If you are missing a php version and your hosting control panel does not allow you to add a php version contact your hosting provider.

if your hosting package does not support php version by domain,  get new hosting.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More