Jump to content
hansoft

Total meltdown after Apache upgrade

Recommended Posts

Hello all

Sorry for starting a new topic, but I could not find one with this problem.

I had Apache 2.2 on Windows 7, and upgraded to Windows 10 and Apache 2.4.37.

I enabled PHP 7.0.33.

I have a shop with version 1.5.6.3 and it had worked perfectly for more than 5 years on the Windows 7 and Apache 2.2.

But after the upgrade, I can no longer access the following pages (it just stops and reloads forever): login and basket.

And that is 2 very important pages, because without it is impossible to place an order.

So what happened ? Why does the shop stop working on Apache 2.4.37 and PHP 7.0.33 ??

And another not so important question: Prestashop ver. 1.7.6.1 says in the PayPal module (when setting up in BO): that cURL module is not activated on server. But it is ?

Is there a bug in PayPal module ?

Thanks in advance.

Share this post


Link to post
Share on other sites

You cannot run Prestashop 1.5. with php 7.0. You need to upgrade your Prestashop version at least to 1.6. latest. For the curl problem please use the search bar (or google search) of the forum. You will find several topics related to this problem and possible solutions.

 

Share this post


Link to post
Share on other sites
5 minutes ago, selectshop.at said:

You cannot run Prestashop 1.5. with php 7.0. You need to upgrade your Prestashop version at least to 1.6. latest.

 

Ups...... thank you ...

 

How to upgrade 1.5.6.3 to 1.6xxx without loosing everything ?

Share this post


Link to post
Share on other sites

There is a module included for to upgrade. But you need to select manual upgrade package. Otherwise the module will upgrade to latest official version which is 1.7.x.

For manual upgrades there are several tutorials available over the net. Simply google and you will find them. There are also here some in the forum available. But it's hard work. If you don't want to put hand on it, contract somebody, or use a paid module of the market place (migration pro module).

Share this post


Link to post
Share on other sites

Hello

 

Now I have downloadet both 1.6.0.5 and 1.6.1.23 and tried upgrade via 1-click-upgrade.

I chose the local directory method under expert mode.

After both upgrades I can use BO, but when calling the shop, I get this:

500 Server Error

Oops, something went wrong.

Try to refresh this page or feel free to contact us if the problem persists.

 

I can use BO but not the shop .. anyone has an idea why ?

 

200 Euro for the upgrade module ...... pheewww ... does it work ?

Share this post


Link to post
Share on other sites

500 errors are server error logs.

1) Read the error logs of the server to get hint from what is not compatible anymore.configuration.

2) I presume you are using several old modules which are not compatible anymore with your new server. Enable debug modus and read/debug also these errors.

Share this post


Link to post
Share on other sites

much simpler to just use php 5.6 on your 1.5 shop, advice to upgrade was not best to get you back up and running, run php5.6, done

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More