Jump to content
sbourdon1

Soucis envoi email variable template pas remplacées

Recommended Posts

Bonjour à toutes et tous,

Sur une 1.7.5.2 j'ai depuis peu (après installation de modules transport et paiement CB) un soucis sur les emails envoyés.

Aucune variables n'est remplie : Bonjour {firstname} {lastname},
Merci d'avoir effectué vos achats sur {shop_name}!

Etc ...

J'ai pisté dans la classe Mail j'ai bien $templateVars qui contient toutes les infos jusqu'à ce qu'on fasse  $swift->registerPlugin(new \Swift_Plugins_DecoratorPlugin(array($toPlugin => $templateVars)));

Donc ca semble provenir de  /vendor/swiftmailer/.

Quelqu'un a t il déja rencontré ce soucis?

Merci de vos réponse.

Share this post


Link to post
Share on other sites

En fait ça arrive après une migration d'un 1.5 vers 1.7 avec le module de migration pro dispo dans le addon.

Tous les comptes migrés ont ce soucis, les comptes créés après la migration ont des emails parfaitement remplis avec les données.

En BDD les comptes clients anciens est nouveau (tables customer sont semblables), le cache n'est pas activé sur la boutique et j'ai vérifié tous les rep cache/ dans tous les endroits du ps ... sont vides.

Quelqu'un à une idée?

Merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More