Jump to content
filiplarlibe

[Résolu] Impossible de créer ou modifier un transporteur

Recommended Posts

Posted (edited)

Bonjour,

J'ai actuellement un problème sur un site prestashop que je suis en train de réaliser. J'ai installé le module PackLink pour bénéficier de tarifs plus avantageux. 

De ce fait, j'ai configuré le module et choisit 3 transporteurs : Mondial Relay, Colissimo et UPS. 

Quand je vais dans la liste des transporteurs, je vois bien les 3 transporteurs que j'ai choisi. Jusque là tout va bien. 

Par contre, quand je veux modifier un transporteur pour définir par exemple des tranches de prix en fonction du poids, je ne peux pas sauvegarder la modification. Je n'ai pas de boutons me permettant d'enregistrer mes modifs. Est-ce normal ? Pourquoi je ne peux pas modifier mes transporteurs ? 

J'ai testé le site sur un serveur en ligne et j'ai cet écran qui apparaît lorsque je veux modifier un transporteur (donc impossible d'enregistrer la modif) : 

capture_Ligne.thumb.JPG.99237ad43941d93ea83bbae8f9005ecf.JPG

Par contre, j'ai testé localement sur mon PC avec Wamp et là j'ai bien le bon affichage avec un bouton Terminer : 

Capture3.thumb.JPG.3e80ca71e39e7602473ee99b45832898.JPG

je ne comprends pas, la version de Prestashop est la même des 2 côtés : 1.7.6.1. 

La seule différence est la version de PHP. 

Avez vous déjà eu ce problème ? Pourriez-vous m'aider s'il vous plait ? 

Merci d'avance.

Edited by filiplarlibe (see edit history)

Share this post


Link to post
Share on other sites

vous avez votre js qui crache sur votre version en ligne. Ouvrez la console e(F12) et regardez l'erreur surement due à un autre module accroché en backofficeheader

Share this post


Link to post
Share on other sites

Effectivement il y a bien des erreurs :

 

Quote

jquery.alerts.js:244 Uncaught SyntaxError: Unexpected token }
jquery.smartWizard.js:451 Uncaught SyntaxError: Unexpected identifier
carrier_wizard.js:89 Uncaught TypeError: $(...).smartWizard is not a function
    at initCarrierWizard (carrier_wizard.js:89)
    at HTMLDocument.<anonymous> (carrier_wizard.js:31)
    at j (jquery-1.11.0.min.js:2)
    at Object.fireWith [as resolveWith] (jquery-1.11.0.min.js:2)
    at Function.ready (jquery-1.11.0.min.js:2)
    at HTMLDocument.K (jquery-1.11.0.min.js:2)

Par contre ces erreurs ne me parlent pas du tout, est-ce qu'elles vous parlent ? 

Merci pour votre aide. 

Share this post


Link to post
Share on other sites

Non je refuse de travailler sur les 1.7 mais il faudrait aller voir le contenu de 

jquery.alerts.js:244 Uncaught SyntaxError: Unexpected token }

Fichier jquery.alerts.js

ligne 244

Share this post


Link to post
Share on other sites

Voici le contenu du fichier jquery.alerts.js ligne 244 :

Capture_erreur.JPG.67bbcebb853d7d301e543974f5ee5c9b.JPG

Merci pour votre aide. 

Juste pour info, pourquoi vous refusez de travailler sur la version 1.7 de Prestashop ? Parce qu'elle est trop buggée ou instable ? 

 

Share this post


Link to post
Share on other sites

vous pouvez tout supprimer de la ligne 236 à 244 (ca ressemble à un copier/collé de ce qu'il y a juste au-dessus)

Quelqu'un a du toucher à ce fichier.

il y a 15 minutes, filiplarlibe a dit :

Juste pour info, pourquoi vous refusez de travailler sur la version 1.7 de Prestashop ? Parce qu'elle est trop buggée ou instable ? 

Les 2, plus des fonctionnalités et des modules en moins, un code 8 fois plus lourd etc... J'explique mes raisons sur mon site si ca vous intéresse^^

Share this post


Link to post
Share on other sites

Merci beaucoup c'était bien ça !!! 

J'avais également un autre fichier qui avait été modifié : jquery.smartWizard.js

J'ai remets les fichiers sans modif (de mon poste local) et ça fonctionne parfaitement. 

Je vous remercie beaucoup pour votre aide. 

Quote

Les 2, plus des fonctionnalités et des modules en moins, un code 8 fois plus lourd etc... J'explique mes raisons sur mon site si ca vous intéresse^^

Du coup, vous me conseillerez de rester sur la version 1.7 ou plutôt de partir sur la version 1.6 pour commencer un site Ecommerce  ?

En effet je suis au début de mon projet et donc je peux encore changer de version sans problème. 

Share this post


Link to post
Share on other sites

Perso c'est 1.6.1.24 max pour l'instant mais ca n'engage que moi.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More