Jump to content
Damien82

Gros problème de cache ?

Recommended Posts

Bonjour,

Je suis sous prestashop 1.7.5.2
J'ai un autre gros problème avec mon site prestashop (Voir ce problème en cours)
On dirait qu'il y a une sorte de probème de cache très bizarre. Par moment quand le client va sur une des page de l'admin, il est ejecté du site et doit à nouveau s'identifier. Et meme en s'indentifiant à nouveau sa l'ejecte en boucle tant qu'il ne vide pas le cache du navigateur. Les utilisateurs de la boutique ont aussi un problème de cache par moment quand ils font une commande les modes d'expeditions n'apparaissent pas tant qu'ils ne vident pas leur cache.
J'ai bien sur essayer de desactiver le cache de prestashop, le vider, installer un autre plugin de cache, mais rien ne change.

En local je n'avais pas de soucis avant de mettre le site en prod. Est ce qu'une mauvaise configuration serveur peut en être la cause ?
ça deviens vraiment très urgent car le client est très mécontant de ces bugs. Moi j'ai beau chercher sur internet je ne trouve aucune solution à mon problème qui fonctionne.
Et bien sur quand j'active le mode debug je n'ai absolument rien qui s'affiche sinon ça serait trop facile. (sauf pour mon autre bug sur l'autre topic).

Merci d'avance

Share this post


Link to post
Share on other sites

ce n'est pas un pb de cache mais de cookie (qui explose, trop gros, ou est regénéré modifié par du code) du coup Prestashop ne "reconnait" pas l'utilisateur.

Si vous avez le module "produits déjà vus" d'activé ça peut en être une cause.

Share this post


Link to post
Share on other sites

@EoliaJ'ai "Produits dans la même catégorie" mais pas "Produit déja vue" Mais en effet ça semble etre une idée cette histoire de cookie.
Comment je peux le résoudre ?

Edited by Damien82 (see edit history)

Share this post


Link to post
Share on other sites

Il faut décoder le cookie et regarder ce qu'il contient. Ca demande un peu de connaissances

Share this post


Link to post
Share on other sites

ah ... j'ai pas vraiment de connaissance en cookie ... sauf ceux aux pépites de chocolat ...
Si vous connaissez quelqu'un qui peu m'aider avec ça je suis preneur.

Share this post


Link to post
Share on other sites

Hum, quelqu'un pourrait m'expliquer ce que je dois faire exactement pour trouver et résoudre ce problème de cookie s'il vous plait ? ça devient vraiment très problématique 😕
Merci d'avance

Edited by Damien82 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More