Jump to content
GSheelm

Putenv

Recommended Posts

Sziasztok,

Az alábbi problémákba ütköztem:

(1/1) ContextErrorException

Warning: putenv() has been disabled for security reasons

in Kernel.php line 122

at Kernel->boot()in Kernel.php line 195

at Kernel->handle(object(Request), 1, false)in index.php line 86

 

A szolgáltatom nem hajlandó a putenv-t engedélyezni. Hol tudom kikapcsolni a prestashopba ezeket, hogy ne használja? Mi a megoldás?

Válaszotokat és segítségeteket előre is köszönöm.

Share this post


Link to post
Share on other sites

Az Admin panelre nem tudok belépni. A legújabb prestashop verzió. 1.7.6.1  a PHP verzió:PHP Version 7.3.9

Edited by GSheelm (see edit history)

Share this post


Link to post
Share on other sites

Udvozletem, nalam ugyan ez a problema, szabad megkerdeznem, hogy hogyan sikerult megoldani?

Share this post


Link to post
Share on other sites

Ha jól emlékszem akkor másik tárhelyszolgáltatóhoz való költözéssel.

Share this post


Link to post
Share on other sites

 Ne használd a szolgáltató telepítő segédjét. (softaculous) saját telepítéssel megy. Bár nem követelmény a putenv én végül más szolgáltatót választottam, ott sincs engedélyezve. Elsőre sima telepítéssel ment.

Share this post


Link to post
Share on other sites

Nem a szolgaltato telepitojet hasznalom hanem egy prestashop-os tema fejlesztoet (leotheme.com) es ott a  1.7.6.1 verziot de a PHP-et mar probaltam 5.0-tol 7.3-ig de semmi. Most egyenlore a web szolgaltatoval tortenik a komunikacio, meglatom mi lesz a vege. (forpsi.com) Mar eleg sok gondom  volt veluk, illetve minden egyes uj instalacional. :)

Share this post


Link to post
Share on other sites

Forpsi nem fogja engedélyezni ezt neked. Keress másik tárhelyszolgáltatót.

Share this post


Link to post
Share on other sites

Na a forpsi nem is fogja kikapcsolni azt a security mode-ot, hogy mukodjon a debug mode a prestashopban az oldalon. Ugy oldottam meg, hogy ftp-en kikapcsoltam a debug mode-ot es igy mukodik ha meg valamikor valami hiba volna akkor az oldalon bekapcsolom aztan megnezem a hibauzeneteket es ftp-en visszakapcsolom a debug mode-ot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More