Jump to content
sero2kk

(gelöst) "Shop-Einstellungen" aus dem Footer entfernen Ver. 1.7.6.1

Recommended Posts

Hallo,

im backoffice menü "shop-einstellungen"--->"kontakt"--->"shops" gebe ich alle daten ein, die später auch im kontakt formular sichtbar sein sollen. darüber hinnaus werden die ganzen daten aber auch noch im footer angezeigt, wie auf dem screenshot zu sehen ist. wie bekomme ich die weg? ich finde im backoffice keine option dafür.

beste grüße

2019-09-22.png

Share this post


Link to post
Share on other sites

Diese Angaben finden sich in den meisten Shops, absolut üblich und wird von Kunden auch erwartet. Nur die Überschrift "Shop-Einstellungen" sollte man ändern.

Zuständig ist das Modul "Contact Information".

Share this post


Link to post
Share on other sites

danke, aber leider nein, die überschrift lässt sich nicht ändern mit dem modul "kontakinformationen" dieses modul bietet nur die möglichkeit die email adresse anzeigen zu lassen oder zu verstecken, was aber auch nicht funktioniert. aber gut, email adresse soll auch angezeigt werden. aber überschrift ändern wäre schon schön...

Share this post


Link to post
Share on other sites

Du musst unter international / übersetzungen     in die Übersetzung des Moduls gehen und kannst dort die Überschrift ändern.

Und wenn du möchtest das deine Änderungen sichtbar werden, nicht vergessen sowohl Shop- als auch Browsercache zu leeren.

 

Sollte das auch nicht gehen (bei mir habe ich nicht die Übersetzung genutzt, könnte aber bei der alten Version verbuggt gewesen sein) musst du den Text im Notfall direkt in der Datei ändern.

Share this post


Link to post
Share on other sites

ok, den punkt in den übersetzungen habe ich gefunden und die überschrift geändert. browser und prestashop cache gelöscht und es ist trotzdem keine veränderung zu sehen.

Share this post


Link to post
Share on other sites

Finde ich auf Anhieb gerade auch nicht. Im Backend unter Übersetzung steht bei mir was anderes als im Frontend. Direkt in der TPL habe ich es auch nicht geändert...

Für dich aber erstmal die quick & dirty version:

Im Order /themes/classic/modules/ps_contactinfo    gibt es die Datei:     ps_contactinfo.tpl

Da in Zeile 28 sollte folgendes stehen:

<h4 class="text-uppercase block-contact-title">{l s='Store information' d='Shop.Theme.Global'}</h4>

Daraus machst du:

<h4 class="text-uppercase block-contact-title">Shop Informationen</h4>

 

wie gesagt, nicht schön aber dann hast du Zeit dich mit dem Thema richtig zu befassen. Nicht vergessen eine Sicherheitskopie der Originaldatei zu machen.

Share this post


Link to post
Share on other sites

ok, aber nur damit ich es verstehe, soll ich in die zeile wirklich "Shop Informationen" schreiben? oder ist das nur ein beispiel und ich schreibe dort meine gewünschte überschrift rein?

Share this post


Link to post
Share on other sites

Im Grunde kannst du da rein schreiben was du möchtest. Es KÖNNTE nur passieren das es wieder zurück gesetzt wird wenn du ein Shopupdate machst und diese Datei dabei überschrieben wird. Deshalb ist das nur die schnelle und schmutzige Lösung.

Ich suche noch wo ich meine Änderung gemacht habe aber bisher finde ich leider nichts. Könnte auch sein das ich es direkt in der Datenbank geändert habe, ist aber sehr unwahrscheinlich.

Anfangs gab es aber große Probleme mit der Übersetzungen Funktion, weshalb ich einige Übersetzungen direkt in den Dateien oder Datenbänken machen musste.

Edited by Shad86 (see edit history)

Share this post


Link to post
Share on other sites

Es geht über die Übersetzungen des classic templates unter Shop->Theme->Global->Store information

grafik.png.edd927927650e0cc05ecbdda15c2b9e5.png

Share this post


Link to post
Share on other sites
4 minutes ago, JBW said:

Es geht über die Übersetzungen des classic templates unter Shop->Theme->Global->Store information

grafik.png.edd927927650e0cc05ecbdda15c2b9e5.png

 

genau dort habe ich es auch geändert. es bleibt auch abgespeichert. nur wird es nicht im shop angezeigt. auch nach dem löschen des browser und shop cache passiert nichts.

Share this post


Link to post
Share on other sites

An der Stelle habe ich auch "Shopeinstellungen" stehen und das steht im Frontend nicht bei mir.

Genau das selbe steht auch drin wenn ich in den Übersetzungen des Moduls gucke.

Im Frontend steht bei mir aber "Shop Informationen"

Laut Datei holt er sich das ja von hier: s='Store information' d='Shop.Theme.Global'

Share this post


Link to post
Share on other sites

Also bei mir gehts über Shop.Theme.Global

grafik.png.e588db4adc0611deaa9afbe53150367f.png

Share this post


Link to post
Share on other sites

@JBW Welche Shopversion hast du denn?

Sowohl im 1.7.5.2 als auch im 1.7.2.6 stehen bei den Übersetzungen des Themes - Global und des Moduls, andere Sachen als im Frontend.

Edited by Shad86 (see edit history)

Share this post


Link to post
Share on other sites

ist dein shop nur auf deutsch? oder auch english? weil ich hab english deaktiviert und könnte mir vorstellen das ich deshalb auch eine fehlermeldung bekomme.

vielleicht liegt es an der fehlermeldung das es nicht funktioniert. ist aber halt nur eine vermutung das es an der sprache liegen könnte... was soll da sonst fehlen? hab ja nichts gelöscht

 

 

 

2019-09-23 (5).png

Share this post


Link to post
Share on other sites

Das "1 fehlt" ist keine Fehlermeldung. Da ist irgendein Feld nicht ausgefüllt weil der Deutsche Begriff der selbe ist wie der Englische. (Shop z.B.)

Und ich habe auch nur Deutsch, ich kann es zwar auch nicht über "Übersetzungen" ändern, aber ich habe es ja mal geändert. Aber wie gesagt evtl. direkt in der Datenbank. Selbst dann sollte im Backend aber der Begriff aus der Datenbank stehen.

Share this post


Link to post
Share on other sites

Ich habe 1.7.6.1 - ist allerdings ein Upgrade von diversen ältereren Versionen wo die Übersetzung schon drin war. Habe es jetzt aber auch mal in einem 1.7.6.1 Demo Store gemacht, klappt problemlos:

grafik.thumb.png.ecce2fb7f0ae9f56149c5cb340218dd3.png

grafik.thumb.png.98922189425c4a71569ca325596f7b37.png

grafik.png.4076962fca496c190fb8c37320eec9d9.png

Share this post


Link to post
Share on other sites

Die Cache Geflogenheiten bei den Übersetzungen in der 1.7.6er Version sind schon mal sehr gewöhnungsbedürftig. Es wirkt manchmal Wunder wenn man per FTP den Inhalt des Ordners "var/cache/prod" löscht - übrigens auch bei deaktivierten Cache.

Share this post


Link to post
Share on other sites

brachte leider ach keine abhilfe. direkt nach dem löschen sind auch gleich wieder viele dateien zu sehen... der legt die direkt wieder neu im cache an

Share this post


Link to post
Share on other sites

Hast du denn die Übersetzung jetzt gepflegt? Poste mal einen Screenshot davon. Bei mir muss ich da auch keinen cache löschen, Übersetzungen gehen auch ohne.

Share this post


Link to post
Share on other sites

Leider nicht. Du bist in den Modul Übersetzungen. Die richtige Stelle ist in den Theme Übersetzungen unter Shop.theme.global. siehe mein Screenshot

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More