Jump to content
Jean Francois G

[PS 1.7] Urls se terminant par "content_only=1" crées des erreurs google.

Recommended Posts

Bonjour,

Depuis une semaine, j'ai des URL indéxés par google qui se terminent par "content_only=1".

Exemple : https://www.vie-en-zen.com/accessoires-pour-huiles-essentielles/397-100-ml-d-alcool-96-a-parfum-denature-sans-odeur.html?content_only=1

au lieu de https://www.vie-en-zen.com/accessoires-pour-huiles-essentielles/397-100-ml-d-alcool-96-a-parfum-denature-sans-odeur.html

et cela me génère des erreurs d'indexation google, notamment au niveau mobile bien sur puisqu'avec cette terminaison d'URL, la page ressemble à n'importe quoi.

 

Quelqu'un aurait il une idée d'ou cela provient et pourquoi il me trouve maintenant ces URLs ?

 

Share this post


Link to post
Share on other sites

Bonjour,

C'est curieux, content_only=1 sert a afficher les popup du genre de l'affichage rapide du produit ou des CGVs, mais via des appels ajax. Il n'y a normalement pas ces Urls dans le code source des pages, donc elles ne devraient pas être indexées. Sauf si un module ou le thème utilise ce paramètre en 'dur' dans un template (Vérifier par des recherches sur 'content_only' dans les affichages codes sources des pages).

Voir aussi si ces Urls ne se trouvent pas dans le sitemap.

Edited by lagui (see edit history)

Share this post


Link to post
Share on other sites

Bonjour et merci pour cet première réponse. 

Je ne savait pas à quoi servait ce content_only. 

Sur les conseils donnés, j'ai donc vérifier : 

- le sitemap : Pas de content_only dans la page

- La page d'accueil : Pas de correspondance non plus

- La page catégorie : Pas de correspondance non plus

- La page produit : Pas de correspondance non plus

- Toute la procédure checkout : Pas de correspondance non plus

Aucune idée de comment il m'a trouvé ces articles se terminant par cette ligne. 

Je suis allez sur google webmaster tools et j'ai paramétré la ligne content_only=1 comme non indexable dans les comportements URL. Cela devrait il être suffisant ? il va quand même falloir que je supprime les articles indexés en double (normaux et avec content_only) dans google wmt non ? Sinon je ne pourrais aps corriger les erreur d'indexation mobile.. 

J'ai aussi tenté de faire une regle d'url rewriting dans le htaccess, mais je suis trop mauvais dans ce domaine (le htaccess) et malgré tous les exemples du web je n'ai pas réussi a faire la règle souhaitée. Domage cela aurait été une bonne soluce je pense. 

 

Share this post


Link to post
Share on other sites

Une règle dans l'htaccess sur le paramètre content_only=1 risque de bloquer tous les popups.

Il faut trouver comment google récupère ces Urls...

Pas de nouveaux modules ou autre modif avant que le problème ce soit déclaré ?

Share this post


Link to post
Share on other sites

Je cherche dans ma mémoire mais je crois bien que non... j'ai juste mis a jour le module mondial relay, mais je vois pas en quoi il aurait rajouté du codage dans les article  ?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More