Jump to content
Ocul

Error actualizar de 1.7.4.2 a 1.7.6.1

Recommended Posts

Buenas tardes!!

tengo un problema, al intentar actualizar con el modulo: 1click upgrade. Tengo la versión 1.7.4.2 e intento actualizar a la 1.7.6.1, este es el mensaje de error que arroja:

[INTERNAL] /homepages/22/d523587589/htdocs/modules/autoupgrade/classes/ZipAction.php line 111 - ZipArchive::close(): Can't open file: Permission denied

Could not close the Zip file properly. Check you are allowed to write on the disk and there is available space on it.

 

Los permisos están OK, y no hay problemas de espacio....

Alguien sabe que puedo hacer??

 

Muchas gracias de antemano!!

panpresterror.jpg

Share this post


Link to post
Share on other sites
hace 3 horas, Phottozen dijo:

Si amigo, tienes que ir a tu Cpanel y en la seccion de PHP debes activar la casilla ZIP

Y comprobar el espacio libre

Share this post


Link to post
Share on other sites
En 12/9/2019 a las 12:44 PM, gusman126 dijo:

Y comprobar el espacio libre

 

En 12/9/2019 a las 9:27 AM, Phottozen dijo:

Si amigo, tienes que ir a tu Cpanel y en la seccion de PHP debes activar la casilla ZIP

Gracias por las respuestas. Tengo el hosting con IONOS, en la sección de PHP solo puedo elegir la versión. El espacio es ilimitado. Hablé con IONOS comentándole el error y me dijeron que estaba todo OK... Creo que voy a seguir en esta versión y cuando pase la navidad (la web es de regalos navideños) trastearé a ver si doy con la tecla porque realmente no se que está pasando

Share this post


Link to post
Share on other sites
hace 7 minutos, Ocul dijo:

 

Gracias por las respuestas. Tengo el hosting con IONOS, en la sección de PHP solo puedo elegir la versión. El espacio es ilimitado. Hablé con IONOS comentándole el error y me dijeron que estaba todo OK... Creo que voy a seguir en esta versión y cuando pase la navidad (la web es de regalos navideños) trastearé a ver si doy con la tecla porque realmente no se que está pasando

Ayer justo me paso lo mismo.

Al final hice una copia desde el Cpanel, comprimiendo todos los ficheros, exportando la base de datos

En la configuración del modulo de actualizar, desactive la copia de seguridad y listo, se actualizo correctamente

Como tenia la copia de todos los ficheros en Cpanel + base de datos, no me preocupo hacer esa actualización

 

Share this post


Link to post
Share on other sites
hace 1 minuto, gusman126 dijo:

Ayer justo me paso lo mismo.

Al final hice una copia desde el Cpanel, comprimiendo todos los ficheros, exportando la base de datos

En la configuración del modulo de actualizar, desactive la copia de seguridad y listo, se actualizo correctamente

Como tenia la copia de todos los ficheros en Cpanel + base de datos, no me preocupo hacer esa actualización

 

Tiene sentido, pues el problema lo da mientras trabaja en el backup. Gracias!!!

Share this post


Link to post
Share on other sites

A mi me pasa igual que al usuario ocu, tengo ionos y me da el mismo error al actualizar,

He desactivado la casilla no hacer copia de seguridad como dice gusman 126 y sigue saliendo el mismo error:

[INTERNAL] /homepages/7/d465837781/htdocs/modules/autoupgrade/classes/ZipAction.php line 111 - ZipArchive::close(): Can't open file: Permission denied

Copia de seguridad de archivos en curso. 47858 archivos restantes

 

Could not close the Zip file properly. Check you are allowed to write on the disk and there is available space on it.

Share this post


Link to post
Share on other sites
hace 5 minutos, carlosantelo dijo:

A mi me pasa igual que al usuario ocu, tengo ionos y me da el mismo error al actualizar,

He desactivado la casilla no hacer copia de seguridad como dice gusman 126 y sigue saliendo el mismo error:

[INTERNAL] /homepages/7/d465837781/htdocs/modules/autoupgrade/classes/ZipAction.php line 111 - ZipArchive::close(): Can't open file: Permission denied

Copia de seguridad de archivos en curso. 47858 archivos restantes

 

Could not close the Zip file properly. Check you are allowed to write on the disk and there is available space on it.

Comprueba siempre el espacio en el disco del servidor, parece que el error es al descomprimir el fichero de la actualización, necesitas minimo 500Mb libres, bueno son menos, pero por si acaso 

Share this post


Link to post
Share on other sites
  1. El caso es que tengo dos web en el mismo hosting con todo igual pero con dominios diferentes y una se me ha actualizado sin problemas y la otra no, con el mismo espacio

Share this post


Link to post
Share on other sites

acabo de hacerlo esta mañana, una la he actualizado de la versión 1.7.6.3 a la ver 1.7.6.5 y se ha actualizado correctamente

y la otra de la ver 1.7.5.1 a la ver 1.7.6.5  y esta actualización es la que me esta dando el error comentado 

 

 

Share this post


Link to post
Share on other sites

1-.He mirado en ionos y me pone esto en la base de datos:

Almacenamiento

134 de 1024 MB utilizados

2-. Esto en espacio web

Memoria

6.54 GB de ilimitado usados

Archivos

144.539 de 262.144 utilizados

Share this post


Link to post
Share on other sites

Solucionado, no le di a guardar en las opciones de copia y por eso seguía igual el error.

 

En la configuración del modulo de actualizar, desactive la copia de seguridad y listo, se actualizo correctamente

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More