Jump to content
LupLup

Grundpreis verschwindet nach Bearbeitung der Artikeltexte

Recommended Posts

Hallo zusammen

Version 1.7.6.0 + und 1.7.6.1

Leider verschwindet der Grundpreis     nachdem ich irgendeine Kleinigkeit an dem Artikel ändere

Sei es eine Buchstabe im Artikeltext, oder sei es der Startpreis selbst, oder auch sei es dass ich die Kategorie ändere

 

Sobald eine Änderung  von mir stattfindet, verschwindet der Grundpreis und auch die Grundpreisanzeige verschwindet

 

Im Backoffice bei dem jeweiligen Produkteinseinstellungen steht bei Grundpreis dann 0,00000 .. 

 

Wenn ich hier manuell den Preis eingebe und auf speichern gehe, kommt die grünfarbene Meldung dass die Einstellungen gespeichert wären

Aber bei Reload steht wieder 0.00000 dort

 

folglich wird  bei dem Artikel im Front auch kein Grundpreis angezeigt

Ich habe sehr viel nach Lösung gesucht .. leider nicht gefunden

DIESES PROBLEM TRITT AUF WENN DER ARTIKEL VARIANTEN BESITZT !!!

 

 

Ich bitte um Hilfe und danke im voraus

 

 

 

Bzgl. Server - Falls jemand Serverproblem sagen möchte 

Jeweils gleiche Fehler passieren in zwei unterschiedlichen Servern bei unterschiedlichen Anbietern

Edited by LupLup (see edit history)

Share this post


Link to post
Share on other sites

Du sprichst von einem "Startpreis", so etwas gibt es ja in einem normalen Shop nicht, läuft bei dir irgendein Auktionsmodul?

Bezüglich Server, zwei Server bei zwei Anbietern heißt ja gar nichts, welche PHP-Version läuft denn?

Ist es ein neuer Shop oder hat der Grundpreis schon einmal funktioniert? Hast du einmal per Einstellung alle Fremdmodule und Overrides deaktiviert? Hast du mal an der Datenbank rumgebastelt?

Share this post


Link to post
Share on other sites

 

Quote

Du sprichst von einem "Startpreis", so etwas gibt es ja in einem normalen Shop nicht, läuft bei dir irgendein Auktionsmodul?

ich spreche von varianten !!! 

am anfang hat das produkt einen preis (startpreis)

und die variantenauswahl erzeugt einen anderen preis ---- oder auch nicht 

 

Quote

Bezüglich Server, zwei Server bei zwei Anbietern heißt ja gar nichts, welche PHP-Version läuft denn?

ich hatte ja auch das erwähnt damit niemand ratespiel daraus macht und server wechsel vorschlägt

php versionen sind bei beiden 7.2

 

Quote

Ist es ein neuer Shop oder hat der Grundpreis schon einmal funktioniert?

es ist ein neuer shop wo der grundpreis funktioniert , auch mit varianten funktioniert !!!!

ABER NUR BIS DANN wenn man den artikel welcher VARIANTEN hat irgendwie irgendwo ändert .. artikeltext , kategorie, startpreis, egal was !

Quote

Hast du einmal per Einstellung alle Fremdmodule und Overrides deaktiviert? Hast du mal an der Datenbank rumgebastelt?

gibt kaum fremdmodule - es gibt rechtsicherheit, dsgvo, kundenvorteile
alles andere war das was von prestashop mitgeliefert wurde

 

----------------------

----------------------

Also , falls ein artikel varianten hat , löscht sich der grundpreis SOBALD eine änderung am artikel gemacht wird 

dies ist denke ich ein programmfehler und ich bin sicher dass alle dieses problem haben dürften

falls nicht (auf eigenes risiko) einfach mal einen artikel ändern und man wird es sehen .- oder einfach mal einen shop aufsetzen und das selbst testen


lg

Share this post


Link to post
Share on other sites

Daß der Fehler nur bei Artikeln mit Varianten auftritt, verrätst du erst am Ende deines Posts. Aber auch da gibt es keinen "Startpreis", darunter versteht man eben den Preis, mit dem man eine Auktion startet. Hast du mal versucht, als Produktpreis 0 einzugeben und dann bei jeder Variante deren Preis? Tritt das Problem auch auf, wenn der Produktpreis X ist und alle Varianten den gleichen Preis (also Auswirkung auf den Preis 0) haben?

PHP 7.2 ist OK, mancher hat schon auf 7.3 umgestellt und damit ist Prestashop noch nicht voll kompatibel.

Zitat

es ist ein neuer shop wo der grundpreis funktioniert , auch mit varianten funktioniert !!!!

Jetzt komme ich nicht mehr mit, vorher sprachst du von (gleichen oder unterschiedlichen?) Shops auf 2 verschiedenen Servern, die NICHT funktionieren und jetzt von 1 Shop, der aber funktioniert(e)? Wie hattest du die Artikel in den Shop eingefügt? Per CSV-Import? Was passiert, wenn du einen neuen Artikel mit Varianten über das BackOffice erstellst und den dann zu ändern versuchst? Ohne Hintergrundinfos ist es einfach unheimlich schwer, irgendwo anzusetzen, ich halte es für unwahrscheinlich (wenn auch nicht unmöglich) daß es sich um einen generellen Bug bei Prestashop 1.7.6.x handelt.

Zitat

 

Im Backoffice bei dem jeweiligen Produkteinseinstellungen steht bei Grundpreis dann 0,00000 .. 

Wenn ich hier manuell den Preis eingebe und auf speichern gehe, kommt die grünfarbene Meldung dass die Einstellungen gespeichert wären

Aber bei Reload steht wieder 0.00000 dort

 

Hier schreibst du den Preis einmal mit Komma und einmal mit Punkt, um Fehler damit auszuschließen, probiere mal ob bei Preisen ohne Nachkommastellen das Problem auch auftritt.

Probiere einmal einen anderen Browser sowie auch einmal einen anderen PC.

 

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More