Jump to content
gaiarome

Mondial relay - Les commandes n'apparaissent plus

Recommended Posts

Bonjour, j'ai un nouveau souci, et de taille, puisque les commandes passées et basculées "en cours de préparation" n'apparaissent plus sur dans l'onglet commande/mondial relay.

J'ai donc tenté de tout encoder dans un CSV pour l'importer sur leur site... mais les points relay choisis par nos clients n'apparaissent nulle part, ce qui bloque toute possibilité de faire cela manuellement (sans téléphoner à nos clients et perdre un temps précieux, sans parler du manque de professionnalisme de la démarche).

J'ai tenté de contacter Mondial Relay Belgique, Mondial Relay France et le développeur de l'addon.

Jusqu'ici, c'est silence radio total...

D'autres personnes connaissent ce problème également ?

Cordialement, Eric

Prestashop 1.6.1.23 et Mondial Relay V2.3.3

Edited by gaiarome (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

Dans la config du module/Détails du compte... est-ce que le bouton 'Vérifier la connexion' fonctionne-t-il encore ?

Il me semble avoir connu un problème similaire qui était lié à une configuration d'un lien quelque part en 'http' plutôt qu'en 'https'... A l'époque mon problème avait été résolu via le chat sur le site fr de Mondial Relay.

Désolé, pas plus à apporter...

 

Share this post


Link to post
Share on other sites

Oui, les configs sont bonnes. Le problème a duré une dizaine de jours puis s'est résolu par lui même 🤨

Merci pour votre aide.

Share this post


Link to post
Share on other sites

Bonjour

 

J'ai le même problème Prestashop 1.6.1.23 et Mondial Relay V2.3.3 et pour le moment pas de réponse de chez eux .

Peux tu m'indiquer ou tu as trouve le type de fichier commande à importer sur leur site .. ( je ne sais pas les champs nécessaires)

Cordialement

 

Share this post


Link to post
Share on other sites

C'est souvent un conflit JS au niveau de la page de commande. La liste des points relais n’apparaît pas et du coup le client passe commande sans données pour les étiquettes. Il faut voir avec une console intégrée au navigateur si elle détecte un conflit sur la page.

Maintenant concernant le fichier CSV, il se génère dans le BO sur la page des commandes. Il faut évidement sélectionner la bonne période, etc... (chez moi, ça se trouve dans le coin droit en haut du tableau, la flèche "exporter"). Puis il faut ré-encoder correctement le tableau en fonction des besoins de mondial relay : les colonnes ne sont pas compatibles. C'est loin d'être évident, mais c'est tout ce que j'ai trouvé...

Cordialement,

Share this post


Link to post
Share on other sites

idem de mon coté sur une 1.7 depuis la dernière mise à jour mon mondial relay ne trouve aucune commande a traiter alors qu'il y en a..

Aucune idée du pourquoi..

Share this post


Link to post
Share on other sites

Ils viennent de faire une grosse upgrade du module (ce qui est cool) mais chez moi,  le problème persiste. Du coup, ils ont mis la boite de dev dessus. Je vous tiendrai au courant ici.

Share this post


Link to post
Share on other sites

Module mondial relay passé en version 3.0 et MAUVAISE NOUVELLE :

Que des erreurs depuis la mise à jour..

Si je veux modifier un poids : Une erreur s'est produite pendant la mise à jour de l'objet. mondialrelay_selected_relay (Unknown column 'id_address_delivery' in 'field list')

Si je veux vérifier les anciens bons  : Unknown column 'a.date_label_generation' in 'field list'

Et si je veux verifier le trasnporteur : Prestashop incrémente L'ID, mais mondial relay reste sur l'ancien..

On pourrais se dire, desinstallons et réinstallons.. Mais si on fait ça, le transporteur n'est plus lié et il faut en recréer un, avec la joie de devoir re-modifier tous les articles pour l'incorporer à la liste des transporteurs autorisés..

 

Edited by Jean Francois G (see edit history)

Share this post


Link to post
Share on other sites

Ils ont bossé la journée hier et ont réglé un problème, mais il en reste encore pas mal... C'est galère cette mise à jour, ça ne règle pas grand chose...

Share this post


Link to post
Share on other sites

Alors j'ai résolu le problème. 

J'ai supprimé le module, effacé le dossier sur le serveur, et effacé les tables dans la base de données. 

Ensuite j'ai réinstallé le module comme au premier jour et remis les paramètres de compte. 

Comme le module ne trouve plus de transporteur, j'en ai créé un de base. Ensuite je suis allé dans la table correspondante dans la BDD mondial relay et 'jai changé l'ID du transporteur que je venais de créé par celui qui était déjà présent avant le reset. 

Ensuite j'ai supprimé le transporteur temporairement créé puis j'ai nettoyé la base de données manuellement pour supprimer toute trace de ce transporteur fantome .

Le module se retrouve doncc fraichement installé avec l'ancien transporteur et toutes les tranches de prix, ainsi que le lien mondial relay. 

Les commandes nouvellement créés sont bien detectées pour la création du bon et je n'ai plus de message d'erreur. 

Attention : IL faut, avant de faire cette manip, que toutes les commande en attente (mondial relay) soient traitées. Sinon elles perdent les infos du point relais choisi par le client. 

Voila ! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More