Jump to content
mikeyt

SOLVED: 1.6 Smarty Permissions issue after apache/PHP upgrade

Recommended Posts

My VPS server had an apache and php upgrade. Prestashop (1.6.1) then stopped working due to permission issues. My host redid all permissions on folder/files to 0755 and 0655.

That got a bit of progress but I then ran into a Smarty Cache problem giving warning message of:

Fatal error: Uncaught --> Smarty: unable to write file /var/www/html/prestashop/cache/smarty/compile

So to test I cleared out the contents of the two folders COMPILE and CACHE in the CACHE/SMARTY/ folder, and then changed both folders to 0777 (unsecure I know!).

The site then loaded up correctly.

So this is where is gets interesting (and confusing) for me.

Looking at the ownership of the files in the CACHE/SMARTY/ folders, before I cleared out the contents the ownership of all the files were by: PAWSFOUR which is the login I use to access CPANEL/FTP etc. (is this the root user?)

When Prestashop wrote the files to the smarty cache once the folder was set to 0777 the owner appeared as: 99

From what I have read across many other related posts is that Prestashop uses a different user when it writes to the server and as I understand it, the problem with the server not allowing Prestashop to write is because this user (in my case called 99) is not part of the apache user group? This is where I am starting to get a little confused and I am not sure how exactly to explain this to my Host provider?

Can anyone explain exactly what needs to be done in terms of the users in apache/php groups etc on the host server in terms that I can explain to the host provider? I don't know which user is the root user etc (PAWSFOUR, 99) or which user needs to be added to what group (apache group?) so it's rather difficult to explain to the Host what needs to be done. I've tried looking at all the other topics on this but none really seem to explain it in a way that I can pass on to my Host.

Any help greatly appreciated.

Edited by mikeyt (see edit history)

Share this post


Link to post
Share on other sites

Turns out it was the case that prestashop was using the apache user which was not part of the root user group.

A specific module (server module not prestahsop module) on the server was missing after the upgrade, called: mod_suexec

Once that was added it all started working properly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More