Jump to content

Recommended Posts

Salve, ho sviluppato un sito di ecommerce per un cliente su una nostra piattaforma gestionale in un sotto-dominio.

Finito il lavoro ho proceduto a migrare il sito su server Aruba del cliente.

Ho seguito tutte le procedure ma non riesco a visualizzare il sito sul nuovo server e non riesco neanche ad accedere al bo.

L'unico modo per farlo funzionare è creare il file .htacces col redirect verso il sotto-dominio di sviluppo.

Cosa sbaglio?

 

error-bo.txt

error-fe.txt

Share this post


Link to post
Share on other sites

Ho guardato solo ora i due file. Quindi il web server ti risponde con il sorgente PHP ? 

Share this post


Link to post
Share on other sites
Just now, ziobudda said:

controllato nel DB che sia memorizzato l'url corretto ? 

M.

Si si, ho modificato tutti i records del database, rifatto il nuovo .htaccess, cambiato gli url e uri nel bo del vecchio sito, non c'è verso. Ma poi non capisco il mancato accesso al bo sul nuovo server

 

Share this post


Link to post
Share on other sites
1 minute ago, ziobudda said:

Ho guardato solo ora i due file. Quindi il web server ti risponde con il sorgente PHP ? 

si esatto

 

Share this post


Link to post
Share on other sites
2 hours ago, prosoft-servizi said:

si esatto

 

Allora è un problema a livello di webserver. Dovrebbe interpretarlo come PHP non come testo. 

Share this post


Link to post
Share on other sites
On 8/30/2019 at 2:54 PM, ziobudda said:

Allora è un problema a livello di webserver. Dovrebbe interpretarlo come PHP non come testo. 

Si ok, ma non so come risolvere

 

Share this post


Link to post
Share on other sites

Ciao,

dovresti andare a vedere il log degli errori del webserver.
Hai provato a controllare i permessi dei files? Magari è quello.

Buona giornata,
Federica

Share this post


Link to post
Share on other sites
3 minutes ago, fedesib said:

Ciao,

dovresti andare a vedere il log degli errori del webserver.
Hai provato a controllare i permessi dei files? Magari è quello.

Buona giornata,
Federica

Ciao, si si abbiamo verificato tutto. Pare che il problema sia l'hosting di Aruba e la versione PHP che offre. Su Netsons con il sito in lavorazione, andava bene la versione PHP 7.1.31, ma su aruba sono fermi alla 7.1.21 se non ricordo male, quindi abbiamo richiesto il cambio server e la versione 7.2 del PHP. Speriamo di risolvere così

Share this post


Link to post
Share on other sites

Il problema non dovrebbe essere nella versione php, infatti il mio sito prestashop funziona sia con php 7.0 che con php 7.3 (server Tophost).

Quello che dovresti controllare, sono la tabella  ps_shop_url (ti allego un'immagine) e il file parameters.php localizzato in /app/config (che gestisce la connessione al DB
Nell'immagine ho fatto riferimento al sito installato nella root (phisycal_uri = / )

tabella.JPG

Share this post


Link to post
Share on other sites
2 hours ago, maxi1973 said:

Il problema non dovrebbe essere nella versione php, infatti il mio sito prestashop funziona sia con php 7.0 che con php 7.3 (server Tophost).

Quello che dovresti controllare, sono la tabella  ps_shop_url (ti allego un'immagine) e il file parameters.php localizzato in /app/config (che gestisce la connessione al DB
Nell'immagine ho fatto riferimento al sito installato nella root (phisycal_uri = / )

tabella.JPG

Ciao, avevo già modificato quei record nel nuovo database.

Alla fine ho risolto contattando il provider. Hanno messo il tutto su un nuovo serve con caratteristiche dedicate (non è dato sapere esattamente quando si tratta di Aruba). La versione del PHP è sicuramente superiore alla 7.1.21 che c'era sul vecchio server e tutto pare funzionare al meglio.

Grazie a tutti per l'aiuto e la disponibilità 😉

Share this post


Link to post
Share on other sites

Sono contento che si sia risolo tutto. Personalmente mi tengo alla larga da Aruba come mi terrei lontano dalla peste.  🤣

Share this post


Link to post
Share on other sites
22 hours ago, maxi1973 said:

Sono contento che si sia risolo tutto. Personalmente mi tengo alla larga da Aruba come mi terrei lontano dalla peste.  🤣

Ti capisco benissimo, anche io me ne tengo alla larga, ma il cliente aveva appena rinnovato l'annualità e non voleva spostarsi. Grazie ancora :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More