Jump to content
HelpdeskGIS

PS 1.7.4.2 - Modulo Stripe ufficiale (SCA-ready) - Avviso di richiesto aggiornamento da Stripe

Recommended Posts

Buongiorno,

abbiamo ricevuto una notifica da Stripe che ci avvisa della normativa che introduce la Strong Customer Authentication e abbiamo provato a contattare il supporto Stripe per capire se da parte nostra è necessario aggiornare completamente l'istanza PrestaShop oppure basta tenere aggiornato il modulo.

Attualmente stiamo utilizzando questo modulo:

https://addons.prestashop.com/it/pagamento-carta-credito-wallet/24922-stripe-ufficiale-sca-ready.html

Il supporto Stripe ha risposto con questa frase:

Quote

Entrando subito nel merito della vostra richiesta, Prestashop si rende responsabile dell'integrazione dei nostri servizi sul vostro e-Commerce. In altre parole, saranno loro ad apportare le dovute modifiche ai vostri moduli di pagamento, assicurandosi che l'esperienza di pagamento lato client e server sia ottemperante con la normativa PSD2

La sensazione è che si stia parlando dell'AddOn e non di tutta l'installazione, ma vorremmo esserne sicuri.
Abbiamo provato a contattare il servizio telefonico PrestaShop al numero indicato a fondo di questa pagina 

https://www.prestashop.com/it/assistenza

ma l'operatore telefonico ci dice che il numero è inesistente.

Qualcuno ha qualche informazione in merito?
Grazie

Share this post


Link to post
Share on other sites

L'intero modulo stripe sta avendo problemi, sfortunatamente i forum di supporto sono sparsi tra il francese e l'italiano e altre lingue, quindi è un incubo completo cercare di capire dove siamo noi o chiunque altro con la situazione e rispondere in inglese sui forum francesi è solo risultato negli avvertimenti dei moderatori, nonostante noi inglesi che siamo in grado di tradurre tramite Google !. Buona fortuna, siamo nella stessa posizione sul nostro sito ma per ora siamo tornati a una versione precedente che funziona, ma per quanto tempo non lo sappiamo.

Share this post


Link to post
Share on other sites

Ringraziamo per la risposta, anche se non ci fornisce alcun dettaglio utile.
Ci teniamo infatti a precisare che, nel nostro caso, il modulo Stripe non presenta alcun problema. Stiamo solo cercando di capire se l'aggiornamento riguarderà solo il modulo oppure tutta l'istanza PrestaShop.

Se qualcuno avesse delle informazioni in questo senso, ci aiuterebbe. Grazie

Share this post


Link to post
Share on other sites

Hey Helpdesk!

l'aggiornamento é solo sul Modulo!!. Ancora non mi sono informato riguardo alle API e non só se dovranno essere rigenerate sulla piattaforma..cmq poi vi faccio sapere.

Quel modulo che indica pocanzi é la versione free gratuita sviluppata da 202ecommerce.....quindi gratis!!. Io la utilizzo su vari shop in europa la 1.5 non ha problemi e funziona come dice lei

Ma adesso dobbiamo adeguarci alle nuove normative imposte dal carrozzone EU e quindi utilizzare un nuovo modulo Stripe compatibile che faccia dialogare PS con la piattaforma Stripe e purtroppo da quello che leggo la nuova versione sviluppata ha problemi.

Io non starei a perdere tempo con questa versione ma andrei su una versione a pagamento cosí per lo meno in caso di problemi avrá anche un supporto dai developer.

Ancora non ho provato questa nuova versione free, proveró oggi a vedere se va..ma di sicuro non staró a perderci tempo perché é peggio perdere ordini e clienti che non acquistare un modulo che funziona, alla fine sitamo parlando di attivitá che fatturano e questo fá parte delle spese di aggiornamento di uno shop..poca cosa in relazione ai benefici:-).

Nella piattaforma addons di Prestashop di sicuro incontra alternative al modulo free...cerchi Stripe e vedrá che escono fuori altri moduli con la stessa funzione.

 

ciao

Share this post


Link to post
Share on other sites

Grazie Fabry,

noi ci siamo orientati verso quel modulo, a di la della gratuità, per il fatto che è sviluppato da un'azienda partner, e quindi ci sembrava maggiormente affidabile. 

Ci sembra di capire che tu invece abbia esperienza con altri moduli per Stripe, hai consigli in merito?

Grazie

1 hour ago, Fabry said:

Hey Helpdesk!

l'aggiornamento é solo sul Modulo!!. Ancora non mi sono informato riguardo alle API e non só se dovranno essere rigenerate sulla piattaforma..cmq poi vi faccio sapere.

Quel modulo che indica pocanzi é la versione free gratuita sviluppata da 202ecommerce.....quindi gratis!!. Io la utilizzo su vari shop in europa la 1.5 non ha problemi e funziona come dice lei

Ma adesso dobbiamo adeguarci alle nuove normative imposte dal carrozzone EU e quindi utilizzare un nuovo modulo Stripe compatibile che faccia dialogare PS con la piattaforma Stripe e purtroppo da quello che leggo la nuova versione sviluppata ha problemi.

Io non starei a perdere tempo con questa versione ma andrei su una versione a pagamento cosí per lo meno in caso di problemi avrá anche un supporto dai developer.

Ancora non ho provato questa nuova versione free, proveró oggi a vedere se va..ma di sicuro non staró a perderci tempo perché é peggio perdere ordini e clienti che non acquistare un modulo che funziona, alla fine sitamo parlando di attivitá che fatturano e questo fá parte delle spese di aggiornamento di uno shop..poca cosa in relazione ai benefici:-).

Nella piattaforma addons di Prestashop di sicuro incontra alternative al modulo free...cerchi Stripe e vedrá che escono fuori altri moduli con la stessa funzione.

 

ciao

 

Share this post


Link to post
Share on other sites

Ciao Help,

la mia esperienza in merito é relativa allo stesso modulo free, non ho avuto particolari problemi se non renderlo compatibile con i vari moduli one/supercheckout. Ora peró dovró  affrontare questa nuova problematica. Nei prossimi gg provo questa nuova versione sempre free eppoi decideró, ma da quello che leggo nell'internazionale il modulo non funziona.

Le versioni a pagamento non le ho provate, peró di solito in teoria dovrebbero essere funzionali visto che sono a pagamento e per lo meno il supporto dovrebbe essere efficace.

Cmq le faccio sapere appena risolvo questa faccenda. Molto probabile che compreró uno di quei moduli  pagamento eppoi incrociamo le dita:-).

 

ciao

 

Share this post


Link to post
Share on other sites

salve ragazzi ma state avendo problemi con questo modulo ? i miei clienti inserendo i dati delle proprie carte non riescono ad andare avanti 

Share this post


Link to post
Share on other sites

In questi giorni abbiamo contattato lo sviluppatore 202ecommerce che mantiene l'Addon che stiamo utilizzando ed abbiamo linkato sopra.

La sua risposta in merito alle nostre perplessità è stata la seguente:

Quote

Hi,
Stripe 2.0 is compatible with the new DSP 2 directives.
You can configure the SCA option directly in the Stripe Dashboard, this option will be available in September 14th.
You can configure this option directly in the Stripe Dashboard.
Radar > Rules
We also recommend the activation of 3D Secure for payments over 30 euros.
To do this, you will need to create a custom rule through the same tab.
You can install the version 2.0.4.134 of the module

e, interrogato sulla compatibilità rispetto alla nostra versione di PrestaShop e l'ugrade del modulo corrente ha riferito quanto segue:

Quote

Yes, this version works with PrestShop 1.7.4.2 and solve some bugs.
We will publish on addons marketplace this week.
Please follow this procedure:
• uninstall the current version of Stripe
• Empty the Prestashop cache
• Install the new module
Please, check LIVE and TEST Keys after installation.
Best regards,

 

Share this post


Link to post
Share on other sites

Fatto tutto per come ti hanno detto ma non è cambiato nulla. 

Come vedi dalla foto che ho allegato inserendo i dati della carta e andando avanti per confermare il pagamento non si muove da questa pagina.

I clienti non riescono ad andare avanti in nessuno modo

 

stripe 2.png

stripe 1.png

Share this post


Link to post
Share on other sites

Buona fortuna, come ho detto in precedenza, abbiamo installato gli aggiornamenti e abbiamo notato che non funzionava, quindi abbiamo contattato lo sviluppatore e ci è stata offerta l'ultima versione prima del rilascio che ancora non ha risolto il problema, al momento stiamo utilizzando una versione precedente che funziona ma non è compatibile con SCA e non abbiamo sentito altro dallo sviluppatore. Sembra che alcuni abbiano funzionato, ma ci sono molti che non lo fanno, ma senza ulteriori informazioni o indicazioni dallo sviluppo non siamo sicuri su come procedere o se abbandonare questo modulo e guardare altrove.

Share this post


Link to post
Share on other sites

Installazione del modulo stripe_official fallita. La versione del tuo modulo non è adatta alla tua versione di PrestaShop.

Cosa posso fare sto impazzendo con questo Stripe 😢

Share this post


Link to post
Share on other sites

 

5 minutes ago, lizzami said:

Installazione del modulo stripe_official fallita. La versione del tuo modulo non è adatta alla tua versione di PrestaShop.

Cosa posso fare sto impazzendo con questo Stripe 😢

Spiacenti, avrei dovuto indovinare che la versione non sarebbe probabilmente la più recente per Prestashop, stiamo eseguendo 1.6.1.24 ed è una versione piuttosto vecchia del modulo. Stiamo quasi per andare con un altro modulo, anche se è una versione a pagamento in quanto abbiamo clienti all'estero che probabilmente non saranno in grado di utilizzare il nostro negozio dopo la scadenza di SCA, quindi a meno che lo sviluppatore non riesca a risolvere i problemi o almeno a iniziare riconoscendoli su questi forum, probabilmente vedranno molte persone abbandonare questo modulo

Share this post


Link to post
Share on other sites
5 minutes ago, lizzami said:

posso fare un downgrade di versione prestashop?

A meno che tu non abbia un backup della versione precedente, non avrei nemmeno possibilità di provarlo, e anche con un backup potrebbe essere disastroso per il tuo negozio e database, non perderlo, cerca un altro modulo che funzioni o, peggio, considera cambiare i fornitori di servizi di pagamento che offrono un modulo gratuito.

Share this post


Link to post
Share on other sites

Cerca un altro fornitore di pagamenti che offra un modulo gratuito se non puoi permetterti di acquistarne uno, se puoi permetterti di acquistarlo uno con uno che offre la maggior parte dell'elaborazione dei pagamenti, almeno in questo modo sarai coperto per più fornitori di pagamenti.

Share this post


Link to post
Share on other sites

Stiamo ancora cercando un modulo adatto, purtroppo siamo nella stessa posizione di te e di tutti gli altri, se riesco a trovare qualcosa che posterò indietro :)

Share this post


Link to post
Share on other sites

Buongiorno AmicaSoap, lizzami,
Posso solo incoraggiarti a contattare l'assistenza per aiutarti ad affrontare i problemi che incontri.
Il modulo Stripe 2.0.4 è stabile da metà agosto e il nostro supporto è a vostra disposizione per correggere eventuali problemi specifici riscontrati con PrestaShop.
Il supporto del link ver sle, che ti risponde in inglese, francese e italiano:
https://addons.prestashop.com/it/contact-us?id_product=24922

Buona giornata

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More