Jump to content
dalloz

Malheureusement, aucun moyen de paiement n'est disponible.

Recommended Posts

Bonjour à tous,

Désolé t'ouvrir un topic pour ça mais je n'arrive pas à trouver la solution à mon problème.

Quand un client va pour terminer sa commande un bandeau 'Malheureusement, aucun moyen de paiement n'est disponible.' sur la partie paiement. Cependant, je n'ai que 2 modules actuellement actif et configuré (cheque et virement).

Quand je vais dans Module Manager / Modules / Gestionnaire de modules ; je vois que les modules chèque et virement ne sont pas dans la catégories paiement mais dans la catégorie autres. Est ce que mon problème viens de la ? si oui, comment déplacé ce modules car je n'y arrive pas.

Bien évidement avant de poster ce message j'ai réinitialisé et reconfigurer les modules sans succès, je les ai aussi désinstaller et réinstallé sans succès.

Merci d'avance pour vos réponses.

Cordialement,

JD

 

Version presta 1.7.5.2

 

Edited by dalloz (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai tout vérifié dans le menu Paiement -> préférence. Tout est coché.

Cdt,

JD

Share this post


Link to post
Share on other sites

Si quelqu'un à une propositions je suis preneur car j'ai vraiment tout essayé.

 

Merci d'avance.

 

Cdt,

JD

Share this post


Link to post
Share on other sites

Si les préférences sont bien configurées, si les modules sont bien greffés sur les bon hook, si tout est bien configuré alors difficile de savoir pourquoi vous n'avez pas un seul moyen de paiement, il faudrait plonger dans votre backoffice et le code pour comprendre.

Share this post


Link to post
Share on other sites

S'il faut rentrer dans le code je n'ai pas les compétences pour analyser cela. est ce que vous pourriez le faire pour moi ?

Je peux vous donner mes accès

Share this post


Link to post
Share on other sites

Ces modules sont greffé sur le hook displayPaymentReturn.

 

Est ce le bon ?

 

Cdt,

JD

Share this post


Link to post
Share on other sites

Merci pour votre réponse.

J'ai trouvé le hook PaymentOptions en cochant ''afficher les modules invisibles''.

image.png.5242818418937c6cf0205ec7346f88f3.pngimage.png.891a33b50523c2c0e458dbd680a154cc.png

J'ai pu trouvé la solution de mon problème en retournant dans Paiement > préférence et en décochant tout les case liés au modules vivawallet (mon compte est en court de validation chez eux). En mettant ce modules en off les autres sont redevenus fonctionnel.

Merci quand même pour le temps que vous m'avez consacré et bonne journée.

Cdt,

JD

image.png

Edited by dalloz (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More