Jump to content

MaXi32

Members
  • Posts

    100
  • Joined

  • Last visited

Posts posted by MaXi32

  1. I never used docker but have experienced using vagrant as my main website development for many years but I just stopped there. I know vagrant and docker, the concept still the same. Do not over obsessed with the purpose of this technologies. They are not developed to make your development easy but the point is to make the testing environment better by working with team. Normally if you work with team, you need to use docker or you gonna have miscommunication. So the other people can test your work without asking you "what do I need to run this thing" and you wasted a lot of time for setting up the same environment? if you are like me working alone, I just use private git repo + ftp push. You don't need docker.

    Normally this is what I do without docker or vagrant. Only do this if you don't share your server configuration with other team:

    1) Create a random dev subdomain for testing purposes like dev.mywebsite.com, install prestashop in here with the database dev_prestashop. You can put more tests in the same server like dev2.mywebsite.com, dev3.mywebsite.com. So the dev.mywebsite.com is like a beta version of the live site in www.mywebsite.com

    2) Secure this dev.mywebsite.com with httpd or nginx password and only you and your team can access this

    3) Now create an empty git repository inside this directory and push as a new repo at your git online repo (I choose my own hosted gitlab svn.mywebsite.com)

    4) Now you have the test server with the same configuration as live server and git-able with your team! The reason I don't see the need of Docker.

    So, how do you update changes to live production on www.mywebsite.com? What about the database? Here is how I did it:

    1) in the public_html for my dev.mywebsite.com, I created a new folder that stores prestashop sql files -> public_html/mydb/ . Then, I dump the sql file without zip or gz compression (eg. dev-prestashop.sql) so I can detect changes from my private git.

    2) If let say I want to commit the dev project, I have to set a rule that I always need to copy a new database inside the directory so it will be synced.

    3) Then, for the live production, I can just pull it from the dev repository and make changes there

     

  2. Opss.. you are not alone. I took few days for them to response and fixing issue. I purchased the plugin (25th December 2016) anduntil today even with the latest version i have never been able to use it for live production. There are so many problems. One more thing to note is that, Knowband marketplace was only designed to work with the default theme (most of the functionality the GUI uses the front-end prestashop. Seller has no access into the backoffice). This means, if you have premium theme with the marketplace plugin, high chance that the theme might have problem with your layout, javascript issues, then you have to prepare writing bugs and send to them to resolve issue (if they are willing to help on time!)

    • Like 2
  3. You need customization or a premium theme. Lazada menu consist of 2 categories. One for the home navigation (only display on home page), and the other is sticky navigation (it will display everywhere). Example what I have tried for my shop is iqit warehouse theme I bought from themeforest. But I only tried on prestashop 1.7+ not sure about 1.6. You can look at their demo here: 

    https://iqit-commerce.com/ps17/demo9/en/  (for top sticky menu category navigation)

    then you can combine the design with this one to achieve your objective. This is for home menu navigation:

    https://iqit-commerce.com/ps17/demo5/en/

  4. On 5/12/2018 at 3:31 PM, Rho_Bur said:

    Have a look on this https://www.prestashop.com/forums/topic/633857-server-requirements-for-ps-17/

    But it is true that PS should shed more light upon the PHP7.2 versions compatibility.

    I still not found the exact answer from the link given. Reading from the sentence given quote here:

    QUOTA:

    Quote

     

    From PS 1.7.3.X to latest

    You need at least php 7.0. (best performance with fpm-php + opcache + ngnix proxied)

     

     

    I'm confused with the recommendation given by the sentence 'at least'. Does this mean, 7.1 works perfectly with 1.7.3.X? Why is this not documented properly?

     

  5. From the official documentation, prestashop mentioned that they are running 'good' with PHP 5.4+ and never mentioned about the breaking issue. When I try prestashop 1.7.3.2, on the latest PHP 7.2, I got error message that defnitely has compatibility issue.

    Can we being honest and in documentation we specify like this:

     

    PHP 7.2 for prestashop 1.7.4+

    PHP 7.1 for prestashop 1.7.1

    PHP 7.0 for prestashop 1.7.1.2 - 1.7.1.9

     

    Again I still cannot find the proper system requirement for prestashop or recommendation PHP version. What I read is just bunch of suggestion and recommendation from the community. Can anyone explain this ?

     

    If I use prestashop 1.7.3.2 is it guarantee to work with PHP 7.2 ? The guaranteed issue is what causes me to ask this question.

  6. I have purchased Knowband marketplace on 25th september 2016. The first time installation, there was an error of 500 http. I contacted Knowband, they just put a bracket on the code to solve the issue. and after fixed this first issue, developer asked for 5 stars rating ^_^


     


    The second problem was, the layout problem, I tried to fix myself but the codes for this module are like hard coded, hard to read. So, what they did was, put back a css layout code that I think should be put there since the beginning.


     


    The third problem was about the javascript field issue, where u cannot enable javascript compression in BackOffice of your prestashop


     


    Next the javascript crashed issue. This issue has not been solved.


     


    and there are many more problems. I haven't been able t o use this product on live production almost a month. Just to prepare a documentation, screenshot, FTP access to developer on how to solve his own problem.


     


    --------------------------


    Dear prestashop team,


     


    What happen to my old conversation between me and the developer? All gone. Can you answer this prestashop team? Did you delete them after I rated 1 star for this module?


     


    I had a very long conversation with the developer on how to fix the issue using the developer contact form. I provided my FTP access, backoffice password and everything that I could. Yesterday, I rated this plugin to 1 star due to many problems. And today morning I found out that all conversation between me and the developers are gone. I'm not sure why.


     


    Please prestashop team, I need this plugin working or ask the developer to refund back that money so that I can purchase a new working module! Developer is not responding.


     


    The price of this module is expensive. 99.99 Euro which equivalent to 110.17 USD. http://addons.prestashop.com/en/21669-knowband-marketplace.html


     


    Developers know that this module has error but it has not been updated since 4 months.


  7. The problem is because you install prestashop without example data. Prestashop will automatically delete (in a dirty way) all the content of the products, default couriers and many more from database during the installation and left the auto increment number messy. That's why you have the problem. If you install prestashop with example data, there will be no problem. This problem normally occurs when you install prestashop through 1 single click from your hosting provider.

  8. Yeah your file ownership is outta whack. Without knowing how your site is set up, my best guest based on what you posted is that your permissions should be set to apache:apache

     

    Try

     

    chown apache:apache * -R
    on your prestashop files.

     

    With your server being managed, they should at least be able to help you set the ownership of your files properly. If this doesn't work I would press them to help you get them owned by the correct user:group

     

    -Andy

     

     

    can this be done in a shared hosting?

  9. ok 

    well i just checked this one and seems it is still the original

     

    my advise is , upload the account.html with an ftp programm into the /mails/en folder

     

    if this one keep still the same original then log in on your hosting and see if the GID is apache or your hosting username

     

    if it is apache then go back til you see mails , select this folder and reset owner 

    then you are able to change the mail templates

     

    Hi, please help me on this. I reset the GID and able to edit the template and add new template but Prestashop will not be able to edit this template using the email template editor that is built in at the Translator -> Email template. How do I reset back the GID to apache after editing ? Because I think the GID username other than 'apache' is preventing the Prestashop to update the files.

  10. doesn't work at all with javascript. even with a simple code like this:

    <html>
    <head>
    <script type="text/javascript">
    function myFunction(){
    alert("hello");
    }
    </script>
    </head>
    <body>
    <input type="submit" onClick="myFunction()">
    </body>
    </html>

    please provide a small example like a hello world function to make it work. sorry im newbie.

  11. I cannot install this module. Same error like previous users reported as attached here.

     

    My configuration:

     

     CONFIGURATION INFORMATION

    This information must be provided when you report an issue on our bug tracker or forum.

     SERVER INFORMATION

    Server information Linux #1 SMP Thu Dec 18 02:18:37 EST 2014 i686

    Server software version Apache/2

    PHP version 5.3.29

    Memory limit 128M

    Max execution time 30

     DATABASE INFORMATION

    MySQL version 5.5.34

    MySQL server localhost

    MySQL name -

    MySQL user -

    Tables prefix ps_

    MySQL engine InnoDB

     STORE INFORMATION

    PrestaShop version 1.6.0.14

    Shop URL -

    Current theme in use default-bootstrap

     MAIL CONFIGURATION

    Mail method You are using the PHP mail() function.

     YOUR INFORMATION

    Your web browser Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36

     CHECK YOUR CONFIGURATION

    Optional parameters Please fix the following error(s)

    • magicquotes

     

    EDIT: SOLVED. I DELETED THE DATETIME STAMP in the PHP file and it works.

    post-991799-0-02513100-1430644744_thumb.png

  12. Hmm,

    seems to work OK here. Latest Chrome (Mac)

     

    Took a little while, where you see the loading icon, but then it disappears and zooms a it should:

    attachicon.gifjqzoom works.png

     

    Works for me too on XP with Chrome 42.0.2311.135 m

     

    Hi there, I forgot to put another step to reproduce the error. I have updated my post. Can u try it out? The step is to select different size and I can see the loading zoom is stuck. Without that step, it works fine too.

     

     

     

    Maybe clear browser cache and cookies...

     

     

    Actually, I have done that several times.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More