Jump to content

Zalps

Members
  • Posts

    6
  • Joined

  • Last visited

Everything posted by Zalps

  1. Hello again, as I see no one did reply, anyway I can come with a proper solution. The problem occurs in class PaymentModule and specifically in function validateOrder. In line ~540 there is this block of code : if (Configuration::get('PS_STOCK_MANAGEMENT') && ($order_detail->getStockState() || $order_detail->product_quantity_in_stock <= 0)) { $history = new OrderHistory(); $history->id_order = (int)$order->id; $history->changeIdOrderState(Configuration::get($order->valid ? 'PS_OS_OUTOFSTOCK_PAID' : 'PS_OS_OUTOFSTOCK_UNPAID'), $order, true); $history->addWithemail(); } In my case, the statuses PS_OS_OUTOFSTOCK_PAID and PS_OS_OUTOFSTOCK_UNPAID were not set as name values in the ps_configuration, and the only similar name I could find was PS_OS_OUTOFSTOCK. So what you have to do is to create these two names and match them with the proper values.
  2. Hello, In my case error_log writes noththing, because the order actually completes and is submitted in the back-office. I also receive bankwire email confirmation. The problem is that the order confirmation page always returns with error 500 when my payment method is bankwire. I tried the solutions that were suggested above, truncate the ps_order_status and the ps_order_status_lang but unfortunately it didn't work. Can anyone suggest anything? This is a serious bug, and I haven't seen a clear solution. Why is this considered as solved? PS: The version I use is PS 1.6.1.5 and is clean install.
  3. Thanks for the response but I think that everyone's problem is that we would like to have the ability to keep our initial id_category_default. Removing massively the superfluous assignment to the home category, is something that could be also be done with a query in the database.
  4. Why solved? It still makes id_category_default the home category....
  5. Καλησπέρα. Το πρόβλημα είχε δημιουργηθεί απ τις μεταφράσεις. Πήγα στα module και έσβησα τα αρχεία των μεταφράσεων μέσα στο θέμα και τα modules επανήλθαν. Το αναφέρω σε περίπτωση που κάποιος συναντήσει το ίδιο πρόβλημα.
  6. Καλησπέρα στο forum, Χρησιμοποιώ την πλατφόρμα το τελευταίο 4μηνο και μου συνέβη κάτι για πρώτη φορά και ήθελα να το μοιραστώ στην κοινότητα μήπως το χει συναντήσει κάποιος και μπορέσει να με βοηθήσει. Με λίγα λόγια χάλασαν τα modules στα positions, εκτός απ τις μεταφράσεις των modules, χάλασαν επίσης και τα logos των modules και μου εμφανίζει επαναλαμβανόμενα το σήμα του module paypal. Πάω να κάνω edit σε ενα module στη σελιδα positions και δεν μου το ανοιγει,ξανακάνει απλά refresh τη σελίδα.Υποψιάζομαι ότι αυτο συνέβη μετά την προσθήκη νέας γλώσσας στο site. Είχα στήσει το site στα ελληνικά και ενεργοποίησα και τα αγγλικά. Αυτό που με απασχολεί περισσότερο είναι το κομμάτι που μου εμφανίζει τα συνεχόμενα logo του paypal και δεν μπορώ να "δω" και να κάνω edit τα πραγματικά module που υπάρχουν στη σελίδα(displayTop,displayLeftColumn κλπ). Ελπίζω να ήμουν κατανοητός, προκαταβολικά ευχαριστώ για την όποια ιδέα η συμβουλή.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More