Jump to content

Maria Gonzalez

Members
  • Posts

    66
  • Joined

  • Last visited

Everything posted by Maria Gonzalez

  1. Hola, tengo prestashop 1.6.1.7, mi actual servidor tiene PHP 5.4. Ahora cambiaremos de hosting para uno que tiene PHP 7.2. El problema que nos hemos encontrado es que prestashop 1.6.1.7 no es compatible con PHP 7.2 y la web no va. Por otro lado, actualizar el prestashop en mi hosting actual tampoco funciona ya que prestashop 1.6.1.24 no es compatible con PHP 5.4. Cual es el procedimiento para actualizar prestashop a la ultima version de la 1.6...para que funcione en el hosting nuevo con PHP 7.2 ?
  2. Hola, estoy intentando instalar PS 1.7.3.3, tengo PHP 7.2 en nginx 1.10, la instalacion da un error 200 : "1: HTTP 200 - parsererror -" en el paso "Instalando módulos Addons". Alguna idea de que pasa y como solucionarlo? gracias
  3. Is a virtual product, It send an email to the customer and marks the product as delivered
  4. That is what I need! Another question, sometimes my code will "fail" (i.e. if not enough stock). Is anyway to automatically relauch that script (that own module, so recheck if enough stock and continue without failing), for example every 10 minutes.....
  5. I'll use only payments that are processed so the payment is really confirmed! (paypal, credit cards, etc..)
  6. Hi, Since this morning my shop is not working....I did not modify anything.... The error is : Shop not found at line 418 in file classes/shop/Shop.php 413. 414. //echo var_dump($default_shop); 415. 416. // Hmm there is something really bad in your Prestashop ! 417. if (!Validate::isLoadedObject($default_shop)) { 418. throw new PrestaShopException('Shop not found'); 419. } 420. 421. $params = $_GET; 422. unset($params['id_shop']); 423. $url = $default_shop->domain; ShopCore::initialize - [line 114 - config/config.inc.php] 109. 110. $context = Context::getContext(); 111. 112. /* Initialize the current Shop */ 113. try { 114. $context->shop = Shop::initialize(); 115. $context->theme = new Theme((int)$context->shop->id_theme); 116. if ((Tools::isEmpty($theme_name = $context->shop->getTheme()) || !Validate::isLoadedObject($context->theme)) && !defined('_PS_ADMIN_DIR_')) { 117. throw new PrestaShopException(Tools::displayError('Current theme unselected. Please check your theme configuration.')); 118. } 119. } catch (PrestaShopException $e) { I removed cache....but nothing changes... The problem I think is at: $shop = new Shop($id_shop); Which creates a null object... any help please?
  7. Hi, I'll like to change the color (on the hover event) of the < and > signs on the homeslide on PS1.6 but cannot make it work, I can change background but not the text itself... I do that: #homepage-slider .bx-wrapper .bx-controls-direction a:hover { background: #2fb5d2; color:red; } What I'm doing wrong? Thanks
  8. For all payment methods I have enabled? So..there is no single point?
  9. Hi, I need to execute a php code once the payment has been received, until now I had only 1 payment method so I wrote in on the confirmation hook of that payment method, but now I'll add more payment methods...so I'll like to know if there is a common place to put that code, instead of each payment confirmation for each different method. So I have to write it once! Thanks
  10. I have "Enable SSL on all pages" enabled, should I disable?
  11. Hi, I have my site with SSL (All pages). One of my modules needs a callback in HTTP, I made an exception in my nginx config to enable that. How ever prestashop when receives that HTTP redirects it to an HTTPS (as have the base URL in HTTPS). How can I solve that? I need the site in SSL except an HTTP callback from a module, how? THANKS
  12. Hola, gracias por tu respuesta. He estado intentando lo del puenteo http, pero como tengo el nginx configurado para forzar a ir en https, no funciona ya que se cmabia a https.....he puesto una excepcion en el nginx para que esa URL sea forzadamente por http, y parece que funciona deja acceder en http en esa URL, pero como prestashop tiene como URL base en https lo cambia a https, asi que se forma un bucle infinito, nginx lo pasa a http y prestashop a https......Como puedo configurarlo para que funcione tu codigo?
  13. Hola, tengo un prestashop 1.6 todo me ha funcionado correctamente hasta que ahora estoy poniendo un certificado en la web para que vaya por https. Todo bien, se ha instalado correctamente y todo esta en https. He forzado la redireccion de todo el trafico a https, y funciona. El problema viene al procesar los pagos por redsys, parece ser que redsys no le gusta el certificado y no me hace el callback con lo que el pedido no se registra. Como puedo solventar este problema? gracias
  14. Hi, I just installed 1.7.0.4 fresh install, in the backoffice when I click on Modules -> Modules & Services it shows my frontend page (my shop), the url is www.mysite.com/index.php?q=%2Fadmin4562lqn4m%2Findex.php%2Fmodule%2Fcatalog&_token=0Je1qPbXE1yxK7bHyU8H0pBvVdokmpYFlUvd61DoGvs Is a fresh install I tried 1.7.0.3 and 1.7.0.4 same result.... is a bug? or I'm missing something?
  15. Hi, I have added a shop on my prestashop install (with shared stock). Till then when I go to product -> quantities (with the default group on the shop combo), the Save button keeps spining and never ends.....for any product and anytime...if I remove the option to share stock the button works and is active again. How can I solve it? I'm on Prestashop 1.6.1.7 Thanks Maria
  16. No , OK. You are right. I was looking that user in the another shop!!! The user hasn't any group, I added it and now it works!!! Thanks
  17. Hi, yes my customer is id_customer => 8 and on ps_customer_group It seems that id_customer (8) is in id_group (3) all the users are on id_group (3)
  18. Hi, I have a multistore prestashop installation, they are an exact copy just another language and different configurations. I have modified the css from the top horizontal menu (but both shops are the same, in fact they use the same theme so is exactly the same). In one of them I have no problem at all. But in the other (I just creating it), the top horizontal menu disappears, but only when the user is logged in, works well if the user is not logged in!!. When debug is activated I get this error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') GROUP BY c.`id_category` ORDER BY c.`level_depth` ASC , category' at line 10 SELECT c.*, cl.* FROM `ps_category` c INNER JOIN ps_category_shop category_shop ON (category_shop.id_category = c.id_category AND category_shop.id_shop = 2) LEFT JOIN `ps_category_lang` cl ON c.`id_category` = cl.`id_category` AND cl.id_shop = 2 LEFT JOIN `ps_category_group` cg ON c.`id_category` = cg.`id_category` RIGHT JOIN `ps_category` c2 ON c2.`id_category` = 14 AND c.`nleft` >= c2.`nleft` AND c.`nright` <= c2.`nright` WHERE 1 AND `id_lang` = 2 AND cg.`id_group` IN () GROUP BY c.`id_category` ORDER BY c.`level_depth` ASC , category_shop.`position` ASC at line 791 in file classes/db/Db.php 786. if ($webservice_call && $errno) { 787. $dbg = debug_backtrace(); 788. WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97); 789. } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) { 790. if ($sql) { 791. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>'); 792. } 793. 794. throw new PrestaShopDatabaseException($this->getMsgError()); 795. } 796. } DbCore->displayError - [line 425 - classes/db/Db.php] - [1 Arguments] DbCore->query - [line 643 - classes/db/Db.php] - [1 Arguments] DbCore->executeS - [line 585 - classes/Category.php] - [1 Arguments] CategoryCore::getNestedCategories - [line 480 - modules/blocktopmenu/blocktopmenu.php] - [4 Arguments] Blocktopmenu->makeMenu - [line 730 - modules/blocktopmenu/blocktopmenu.php] Blocktopmenu->hookDisplayTop - [line 587 - classes/Hook.php] - [1 Arguments] HookCore::coreCallHook - [line 542 - classes/Hook.php] - [3 Arguments] HookCore::exec - [line 580 - classes/controller/FrontController.php] - [1 Arguments] FrontControllerCore->initContent - [line 37 - controllers/front/IndexController.php] IndexControllerCore->initContent - [line 189 - classes/controller/Controller.php] ControllerCore->run - [line 367 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 28 - index.php] Any ideas of what is happening? Thanks
  19. Hola, he estado leyendo el foro, pero aun asi no se como solucionar el problema. Mi prestashop es la version 1.6.1.7. Tengo instalado el modulo oficial de redsys version 3.0.0. Estoy aun con el TPV en modo pruebas. Hace bien el pago, me llega el dinero a mi backoffice de la TPV, pero a la hora de volver va a parar al historico de pedidos, y el pedido no se confirma, no aparece en el backoffice de prestashop. Tengo URL amigables activadas y la llamada a index.php?controller=order-confirmation/....., me llega en el log del servidor web como /confirmacion-pedido/....... gracias por la ayuda Maria
  20. Tal como has puesto en la imagen adjunta seria lo ideal... Que version tienes? Yo tengo la 1.6.1.7 y los campos no son como en tu version...(adjunto foto)
  21. Hola, tengo un problema al introducir el precio de mis productos con el Prestashop 1.6.1.7. Cada vez que introduzco el precio de venta final en la casilla PVP le suma los impuestos de la regla de impuestos que tengo asociada. Para que esto no me pase, la única solución que he encontrado es introducir el precio sin IVA que tengo que calcular manualmente, lo que es un incordio. Cómo puedo hacer para que el PVP sea el precio final incluyendo los impuestos? Muchas gracias de antemano.
  22. I did the test you told me, before going back to my site I checked my back office and the order was there, then I clicked on paypal page to return to my site and yes it went to the confirmation order just fine....... However I did another test, this time I went faster and did not look at back office....and it failed it redirected me to order history (the recently made order wasn't on the list), then I went to back office and the order was there...refreshed order history and the order suddently appeared............so the problem is that paypal is not fast enough? any solution to that?
  23. ok I see. And if the order is not created means that I have an error on validation.php? or paypal is not fast enough?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More