Jump to content

Malemi

Members
  • Posts

    47
  • Joined

  • Last visited

Everything posted by Malemi

  1. Opened a bug report here: http://forge.prestashop.com/browse/BOOM-2737 Please, anyone interested, we do need help on this. Thank you
  2. Me cannot believe this is still an open issue on 1.7.0.6 Is this the normal behaviour for PS 1.7 in next future ? Me could not find, this still not being pointed out on Forge ? Thank you
  3. Hello, I have been in contact with SendinBlue support team (just want to give them thanks for their patience). That is my follow-up related with this addon: 1. SendinBlue addon for PS does sync (two way) user being PS client and/if being included in "Black List" in SendinBlue website list. 2. SendinBlue addon for PS is not capable to sync back a user being "permanently removed" form SendinBlue list, does not matter is a client or just a subscriber. 3. SendinBlue addon for PS is capable to sync a subscriber contact (being no client) to SendinBlue website list. 4. SendinBlue addon is not capable to sync back the same user (being no client) from SendinBlue to PS once removed permanently in SendinBlue list. Because many users require to be removed, not to be put in "Black List", that is, in my opinion, a limitation of this addon. As far as I am required by any user to be permanently removed (because of Privacy Law), I should manually remove permanently in SendinBlue and in PS. Have to say: have been trying others addons, same behaviour: 1) It seems most of PS news sync addon are not capable to remove permanently any subscriber from PS database. 2) Default PS "Newsletter subscription" addon is not capable to remove permanently any subscriber from PS database. It just disables a user, not removing from database (even if being not displayed in addon panel). 3) In order to remove permanently any subscriber from PS database, we should manually do it from database. Anyone using SendinBlue, please give us a feedback. Thank you
  4. Poor me ! I missed the most important: For anyone interested, I got it this way: /classes > Form > CustomerFormatter.php (sign-in form) $format['siret'] = (new FormField) ->setName('siret') ->setType('text') ->setLabel($this->translator->trans( // Please localize this string with the applicable registration number type in your country. For example : "SIRET" in France and "Código fiscal" in Spain. 'Identification number', [], 'Shop.Forms.Labels' )) ->setRequired(true) ; /classes > Customer.php (for customers accounts page) 'siret' => array('type' => self::TYPE_STRING, 'validate' => 'isSiret', 'required' => true), classes > Validate.php (Switch to a new validation system replacing the default French SIRET) Hope it helps
  5. Hello, Please, could someone help? I am not able to make a field "required", instead of current "optional", in PS 1.7 sign-in form Thank you :-)
  6. Salve a tutti, Vorrei poter stabilire come obbligatorio il campo SIRET durante la registrazione, uso PS 1.7. Ho letto che é possibile con PS 1.6, ne avrei bisogno con PS 1.7, per cortesia aiutatemi. Ho provato in questo modo: 1. Line 189 - classes/Customer.php: 'siret' => array('type' => self::TYPE_STRING, 'validate' => 'isSiret', 'required' => true, 'size' => 60), 2. line 523 - controllers/admin/AdminCustomersController.php: $this->fields_form['input'][] = array( 'type' => 'text', 'label' => $this->trans('SIRET', array(), 'Admin.OrdersCustomers.Feature'), 'name' => 'siret', 'required' => true 3. Nel momento in cui provo a registrarmi, e validando correttamente un SIRET, ricevo il seguente errore: [PrestaShopException] Property Customer->siret is empty at line 915 in file classes/ObjectModel.php 910. } 911. 912. $message = $this->validateField($field, $this->$field); 913. if ($message !== true) { 914. if ($die) { 915. throw new PrestaShopException($message); 916. } 917. return $error_return ? $message : false; 918. } 919. } 920. ObjectModelCore->validateFields - [line 248 - classes/ObjectModel.php] ObjectModelCore->getFields - [line 489 - classes/ObjectModel.php] ObjectModelCore->add - [line 261 - classes/Customer.php] - [2 Arguments] CustomerCore->add - [line 447 - classes/ObjectModel.php] - [2 Arguments] ObjectModelCore->save - [line 189 - classes/form/CustomerPersister.php] CustomerPersisterCore->create - [line 61 - classes/form/CustomerPersister.php] - [2 Arguments] CustomerPersisterCore->save - [line 133 - classes/form/CustomerForm.php] - [3 Arguments] CustomerFormCore->submit - [line 46 - controllers/front/AuthController.php] AuthControllerCore->initContent - [line 201 - classes/controller/Controller.php] ControllerCore->run - [line 366 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 28 - index.php] Mille grazie Saluti cordiali
  7. Hello, I have been reading this being possible on PS 1.6, I would like to get it on PS 1.7, please help. Have been trying this way: 1. Line 189 - classes/Customer.php: 'siret' => array('type' => self::TYPE_STRING, 'validate' => 'isSiret', 'required' => true, 'size' => 60), 2. line 523 - controllers/admin/AdminCustomersController.php: $this->fields_form['input'][] = array( 'type' => 'text', 'label' => $this->trans('SIRET', array(), 'Admin.OrdersCustomers.Feature'), 'name' => 'siret', 'required' => true 3. As signing-in a new user (SIRET code being OK) I get this error: [PrestaShopException] Property Customer->siret is empty at line 915 in file classes/ObjectModel.php 910. } 911. 912. $message = $this->validateField($field, $this->$field); 913. if ($message !== true) { 914. if ($die) { 915. throw new PrestaShopException($message); 916. } 917. return $error_return ? $message : false; 918. } 919. } 920. ObjectModelCore->validateFields - [line 248 - classes/ObjectModel.php] ObjectModelCore->getFields - [line 489 - classes/ObjectModel.php] ObjectModelCore->add - [line 261 - classes/Customer.php] - [2 Arguments] CustomerCore->add - [line 447 - classes/ObjectModel.php] - [2 Arguments] ObjectModelCore->save - [line 189 - classes/form/CustomerPersister.php] CustomerPersisterCore->create - [line 61 - classes/form/CustomerPersister.php] - [2 Arguments] CustomerPersisterCore->save - [line 133 - classes/form/CustomerForm.php] - [3 Arguments] CustomerFormCore->submit - [line 46 - controllers/front/AuthController.php] AuthControllerCore->initContent - [line 201 - classes/controller/Controller.php] ControllerCore->run - [line 366 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 28 - index.php] Thank you Regards
  8. Hello, as a follow-up of this thread: This seems fixed on PS 1.7.1.0 Beta 1 :-)
  9. Made ;-) Follow up of another thread https://www.prestashop.com/forums/topic/576578-create-classic-subtheme/
  10. Hello, Reported as a possible bug http://forge.prestashop.com/browse/BOOM-2581 Anyone interested and getting the same error, please report Thank you
  11. Hi, First of all thanks to Andrej Stas and memp500 for your inputs! For anyone interested it seems "Products in the same category" is still not working properly on PS 1.7.1.0 Beta 1 Strange issue, this module seems to be uploaded in /themes/classic/modules/ Despite of that, module "Products in the same category" is not being displayed in modules panel. A bug ?
  12. Hi bellini13, thanks for detailed answer! No problem in my case, I had all previously backuped :-) By the way, have you tried adding a new theme on PS 1.7 ? This theme is not valid for PrestaShop 1.7 No way to get it working neither on PS 1.7.0.5, nor on PS 1.7.1 beta1 A bug ? Regards
  13. Hello, Had exactly the same issue upgrading from 1.7.0.5 to 1.7.1-beta Regards
  14. Hello, I am getting exactly the same error, I am trying either duplicating Classic Theme, or adding Starter Theme. This theme is not valid for PrestaShop 1.7 No way to add a new theme in PS 1.7.0.5 Any help or tip ? Thank you
  15. Hello, I forgot to upload the following screen-shot in order to point out and display my issue. The following is supposed (as far as I understand) to be the manual cronjob to sync back from SendinBlue to PrestaShop. As far as I can try this out, it seems not working with PS 1.7 Any help will be appreciated!
  16. Hello: For anyone using PrestaShop 1.7 and SendinBlue (me currently using 1.7.0.5): I have been in touch with SendinBlue and trying to fix this, it seems sync back from SendinBlue to PrestaShop does not work as we run manually cronjob (suposed to do it) from addon control panel. PLEASE, anyone trying SendinBlue addons on PS 1.7., your feed-back and help is welcomed here! To sum it up, I just send this answer to SendinBlue. Best Regards
  17. Hello, Fist issue has been fixed by enabling SMTP mails :-) Still cannot sync back contacts from SendinBlue to PrestaSho, we are trying to get it fixed. Me using PS 1.7.0.5 I will let you know. Best Regards
  18. Hello, As a follow up of this thread, I have been asked by SendinBlue support to enable SMTP mails in order to fix 40 seconds waiting to get to "Configure" panel. I am going to have a try and give here a feed-back. Still cannot sync back contacts from SendinBlue to PrestaSHop, Best Regards
  19. Hello, Thank you everyone taking part of this thread. This seems unresolved on PS 1.7.0.5. Anyone taking care of this towards next versions, in order to avoid us to modify custom code? It seems fix has not been scheduled on next versions: http://forge.prestashop.com/browse/BOOM-1755 Thank you
  20. Opened an "improvement" report here, for anyone interested http://forge.prestashop.com/browse/BOOM-2378 It will be fixed in 1.7.1.1
  21. That seems to be a bug, For anyone interested, just seen it has already been pointed out here http://forge.prestashop.com/browse/BOOM-1984 It seems to be resolved, waiting for next version to check it out. Thank you
  22. Hello, I am trying SendinBlue addon for PrestaShop, I would like to share my early feed back: First problem: I cannot sync back contacts from SendinBlue to PrestaSHop, for instance: a removed subscriber located in SendinBlue list will not be removed in our PrestaShop list (even running a sync cron job suposed to do it). Once installed I attemp to configure, 40 seconds waiting to get to "Configure" panel ! Once inside settings panel, I am required - please check attached pic : "Your server configuration does not allow to send emails. Please contact you system administrator to allow outgoing connections on port 587 for following IP ranges ... " I have been asking to support, they say it is for SMTP mails. Me using PHP mails setting, even so they say we cannot remove that message! That seems to me a bit weird, could someone give a feed back-up on SendinBlue, how does it really work? Me doing something wrong ?? Me, using PS 1.7.0.4. Thank you Malemi
  23. Hello, I am using PS 1.7.0.4, default language is Spanish. Cannot translate "INVOICE" word located at the top right of invoice PDF (please look at pic attached). Opening pdf/header.tpl it seems "INVOICE" is not available for translation: {if isset($header)}{$header|escape:'html':'UTF-8'|upper}{/if} Please, any help to translate it? Me could remove and write there directly being this not the best fix (I guess this file is being used by other PDF files). Thank you Malemi
  24. Great info. Thank you, rocky! Best regards
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More