Jump to content

GrafFoto

Members
  • Posts

    73
  • Joined

  • Last visited

Everything posted by GrafFoto

  1. Hello Darkf3d3, you saved my day! It works perfect! I`ve had some problems, that the icons did not appear. But it is no problem to solve it with some lines of css. For those, who are not sure, where they should place the code - here is my code without icons and the place in the code: original code in /templates/checkout/_partials/cart-detailed-product-line.tpl : <div class="current-price"> <span class="price">{$product.price}</span> {if $product.unit_price_full} <div class="unit-price-cart">{$product.unit_price_full}</div> {/if} </div> </div> New code after this (with german text): <!-- availability --> <div class="cart-product-availability"> {if $product.stock_quantity<=0} <span class="product-not-available">Zur Zeit nicht verf&uuml;gbar</span><br><span class="product-not-available-2">Bitte aus dem Warenkorb entfernen.</span> {elseif $product.stock_quantity < $product.quantity} <span class="product-insufficient-stock">Nur {$product.stock_quantity} St&uuml;ck verf&uuml;gbar</span><br><span class="product-not-available-2">Bitte passen Sie den Warenkorb an.</span> {else} <span class="product-available">Verf&uuml;gbar</span> {/if} </div> CSS: .cart-product-availability .product-not-available, .cart-product-availability .product-insufficient-stock { color: white; background-color: darkred; padding: 5px 8px; border-radius: 5px; } .cart-product-availability .product-available { color: white; background-color: green; padding: 5px 8px; border-radius: 5px; } .product-not-available-2 { padding-top: 5px; line-height: 30px; font-weight: bold; }
  2. In dem Modul sind getrennte Anmeldedaten für DHL / Post - und über den Postshop verschicke ich meine getrackten Sendungen.
  3. Hallo, ich klinke mich hier mal ein, weil hier ja einige, die hier gepostet haben, das Modul auch für den Briefversand mit Tracking nutzen. Ich bekomme es nicht hin hin mich im Modul ordnungsgemäß anzumelden. Leider bieten weder Anleitung noch Demoshop hier Hilfe. Wir brauchen das Modul NUR für den Briefversand - Kundenkonto bei der Post ist vorhanden, aber wenn ich die Postshop-Anmeldedaten im Modul eingebe kommt immer eine Fehlermeldung?! Kann mir jemand sagen, wie ihr euch da im Modul angemeldet habt?
  4. Guck dir doch mal OrgaMax von Deltra an - hat eine Prestashop-Schnittstelle: https://www.deltra.com/ Ich hab es nicht im Einsatz, deshalb kann ich nicht mehr dazu sagen, aber ich liebäugele immer damit.
  5. Hello again, after some research I think the right file for the shopping cart should be: themes / classic / templates / checkout / _partials cart-detailed-product-line.tpl
  6. Hello Dark, thx for your answer. But are you sure, that this works in the BASKET? I would think this code is for the product-page?! If I try this, nothing changes at the basket, but I have an error at my product page?
  7. (Doppel)Problem - aktuell bei mir bei 1.7.5 : Wenn der Kunde etwas im Warenkorb hat, was inzwischen nicht mehr lieferbar ist, dann wird das nirgendwo angezeigt, nur der "Zur Kasse gehen" / "Kaufen" Button ist ausgegraut. Der Kunde kann aber unmöglich erkennen, welches Produkt Ärger macht. Zusätzlich wird das Problem dadurch noch größer, dass im Warenkorb die Menge beliebig erhöht werden kann, was auf der Produktseite nicht geht. In 1.6 gab es wenigstens noch eine AVAILABLE Ampel im Warenkorb, die ist aber auch verschwunden. Ich bin auf der Suche nach jemandem, der (auch bezahlt) das Problem angehen kann. Minimallösung wäre: Verhindern, dass im Warenkorb die Menge unkontrolliert angepasst werden kann + Anzeige der Produkte, die nicht mehr verfügbar sind. Superlösung: Automatische Anpassung des Warenkorbes, wenn ein Produkt inzwischen nicht mehr lieferbar ist mit Hinweisfenster für den Kunden, dass der Warenkorb angepasst wurde.
  8. Am Anfang gab es gar keinen Merkzettel ... ich hatte dann ein Modul von Codecanyon, das war aber Mist, weil nichts vom Merkzettel in den Warenkorb kannst. Inzwischne gibt es aber ein paar ... ich hab die neulich mal alle durchgetestet und mich für "Advanced Wishlist | Favorites" entschieden (kannst du auf meiner Seite im Einsatz sehen). Bin ganz zufrieden damit, habe nur ein paar CSS-Anpassungen gemacht. Nachteil (brauch ich aber nicht): Du kannst deine Merkzettel Produkte nicht in verschiedenen Kategorien sortieren.
  9. Hello everybody, can you please tell me where you have to put the code in the product-add-to-cart.tpl ?! THX
  10. Jetzt hab ich aber doch noch mal nachgeschaut ... und tatsächlich, ich hab auch ein Modul für den Button ...was übrigens auch spurlos verschwunden ist von 1.6 auf 1.7 ist der Merkzettel ... Viele Grüße und ein schönes Wochenende
  11. Ich bin mir grade auch gar nicht mehr ganz sicher wo meiner herkommt ... man verliert irgendwann den Überblick über seine Module ...
  12. Hallo. Bei mir läuft die 1.7.5 Version ... da gibt es den Button noch. Guck mal unter: Shopeinstellungen >> Artikel Dort in der Rubrik "Artikelseite" Button "In den Korb" in Listenansicht immer anzeigen Was es allerdings nur über ein Modul gibt ist die Mengenauswahl direkt in der Listenansicht.
  13. Hier gibt es auch noch was Neues ... allerdings erst ab Version 1.7.3 ... https://www.onlineshop-module.de/eu-fernverkaufsregelung-ps17.html?utm_source=sendinblue&utm_campaign=Juli__EUFernverkaufsregelung&utm_medium=email
  14. Das mit dem Backup solltest du aber unbedingt mal klären, bevor du richtig online gehst, sonst schießt du dir irgendwann deinen Produktivshop mit allen Bestellungen und Kundendaten ab. Ich benutze für mein Presta-Backup schon länger Akeeba: https://www.akeeba.com/products/akeeba-solo.html Die Installation und Ersteinrichtung ist etwas fummelig, wenn man kein Serverexperte ist, aber nach der Ersteinrichtung kannst du mit einem Klick alle Dateien des Servers + Datenbank sichern. Die Wiederherstellung geht dann ähnlich einfach. Es treten bei Akeeba (im Gegensatz zu allen Presta-Modulen, die ich getestet hatte) auch keine Timeout Fehler auf, die zum Abbruch des Backups führen.
  15. Hallo JBW, vielen Dank für den Link zur richtigen Datei ... steht bei mir alles genau so drin ... die Logos sind trotzdem nicht da. Den <label ... Code find ich im Quelltext z.B. bei Vorabkasse wieder, aber da wird kein IMG ausgegeben. Da das IMG in eine if-Anweisung gepackt ist, dachte ich, dass es da vielleicht irgendwo im Shop was einzustellen gibt. Aber ist jetzt auch egal ... nicht so ein wirklich wichtiges Problem.
  16. Hallo Andreas, das Problem habe / hatte ich auch. Es taucht manchmal auch auf, wenn du die richtige Versandart voreingestellt hast. Ich bin noch nicht dahintergekommen, wann die Seite mit dem falschen VERSANDKOSTENFREI angezeigt - aber ich habe es gelöst, indem ich die Übersezung zusätzlich angepasst habe auf: ab 2,60 (meine niedigste Versandstufe). Du findest das bei den Übersetzungen unter Theme CLASSIC (auch wenn du ein anderes Template nutzt!): >Theme >Checkout >FREE Im Modul Rechtssicherheit habe ich dann noch folgenden Text druntergesetzt: (Anzeige der genauen Versandkosten nach Auswahl des Lieferlandes)
  17. Hallo allerseits, ich bin gerade dabei meinen Shop wieder auf die Standardbestellseite von PS umzustellen (1.7.5.0) Die Zahlarten werden als reiner Text untereinander angezeigt - ich hätte aber gerne, dass dahinter die entsprechenden Logos angezeigt werden. Finde aber nix, wo man das einstellen kann.
  18. Hallo, das Problem hatte ich auch ... der Support von 202ecommerce ist da leider unterirdisch ... erst fordern sie einen Testzugang und Screenshot an, dann tun sie aber NICHTS ... außer darauf hinweisen, dass es nicht an ihrem Modul liegt ... Das Problem (und die Lösung) ist, dass die KEY-Felder im Modul ausgefüllt sein müssen ... ich habe aber Stunden gebraucht herauszufinden, wo ich die Testdaten herbekomme - auch hier habe ich eine völlig falsche Info vom Support bekommen.
  19. Hallo Claudio, danke für die Lösung ... habe gerade festgestellt, dass der Fehler auch in der Version 1.7.6 noch nicht behoben ist. Hab es noch nicht probiert - aber bei mir ist die Zeile in der Datei etwa bei Zeile 820. War bei mir noch nie jemandem aufgefallen - aber jetzt hatte eine Kundin aus Österreich mit Angabe der Steuernummer auf Rechnung bestellt. Da ziehe ich die MWSt. nach der Bestellung ab. Sie hat aufgrund des Mails direkt überwiesen und die dort angegebene MWST. abgezogen ... in meiner Rechnung stand da dann natürlich was Anderes.
  20. Hallo Ruki, ich kann dir deine Fragen auch nicht beantworten, kann mein Problem aber weiter eingrenzen. Ich habe nämlich auch ausführlich mit einer Kundin gemailt. Das Paypal Fenster hat sich geöffnet ... aber dann fehlten die ganzen Überweisungsdaten, sie konnte also die Bestellung nicht abschließen. Anscheinend wurde noch keine Verbindung mit Paypal aufgebaut. Ich habe es geschafft KOntakt zum technischen Support zu bekommen, die sehen aber keine Fehlermeldungen. Und sie sagen, dass sie detaillierte Infos der Kunden brauchen ... Browserlink, technische Angaben ... damit will ich aber meine Kunden nicht nerven. Aber wenn es bei euch so ähnlich läuft, dann habt ihr eine hohe Dunkelziffer ... weil die Leute dann oft eine andere Zahlungsoption wählen (wenn es gut läuft). Ich habe heute morgen mal versucht mein PP-Modul auf die aktuelle Version zu bringen ... damit habe ich mir PP jetzt ganz abgeschossen ... aber immerhin sehe ich in den Logs jetzt wer mit PP zahlen wollte und kann die Leute sofort kontakten.
  21. Hallo allerseits. Nur mal eine kleine Frage in die Runde? Bin ich der einzige, der seit etwa drei Wochen regelmäßig Probleme mit Paypal hat? Kunden können ab und zu nicht zahlen, 10 Minuten vorher / nachher funktioniert aber alles. Ich habe schon länger nichts am System rumgewerkelt, vorher lief das seit etwa einem Jahr völlig reibungslos. Ich weiß auch gar nicht wie groß das Problem ist ... die Bestellungen kommen ganz normal an, allerdings mit Zahlungsoption "Vorabkasse". Wenn die KundInnen nix sagen, kann ich nicht sehen, ob das gewollt oder ein Paypal Problem war. Aber es häufen sich die Mails "Wollte mit Paypal zahlen, aber die Weiterleitung hat nicht funktioniert."
  22. Hallo Christian. Verstehe ich nicht ganz. Ich habe doch ein Backup gemacht und dann alles neu angelegt und das Backup dann in den Ordner / die Datenbank eingespielt. - neue Domain - neuer Ordner (Domain wird richtig aufgerufen, wenn ich hier eine index.html zum prüfen hinterlege) - neue Datenbank Änderungen wie oben angegeben gemacht ... aber trotzdem werde ich umgeleitet auf die Hauptdomain von meinem Shop.
  23. Hallo. So ... htaacess angepasst ... 2x Domain in der Datenbank angepasst ... Datenbank Aufruf im Ordner /app/config/ angepasst ... zum Schluß Cache gelöscht und Browsercache gelöscht ... aber ich werde immer noch von der Testseite zu meiner Hauptdomain umgeleitet??? Hat noch jemand eine Idee für mich?
  24. Danke! ... unglaublich, ich hab stundenlang alle Dateien vom Server runtergeladen ... und welcher Ordner fehlt? Der /app/config/ ... werde ich morgen mal ausprobieren.
  25. Hallo allerseits, in der Datenbank habe ich die URL-Einträge geändert. Cache gelöscht, htaccess angepasst ... aber ich lande immer noch beim Originalshop. Ich vermute, dass es daran liegt, dass irgendwo die alte Datenbank aufgerufen wird ... aber ich krieg nicht raus, wo in 1.7.5 die Datenbank definiert wird. Habe mir schon das gesamte Verzeichnis auf die Festplatte gezogen und mit Volltextsuche nach dem Datenbanknamen gesucht ... aber nix gefunden. Weiß jemand, in welcher Datei die Datenbank in 1.7.5 definiert wird? Dank und Gruß Jürgen
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More