Jump to content

samiorfali

Members
  • Posts

    28
  • Joined

  • Last visited

Posts posted by samiorfali

  1. yes please... I found this solution but it doesn't work:

     

    To re-size subcategories images in prestashop 1.4 follow this instructions

     

    1. Go to Back Office Preferences/Image and create new image with the desired size

     

    2. Edit /themes/YOURTHEME/category.tpl subcategories section and change ALL MEDIUM instances

     

    getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}" title="{$subcategory.name|escape:'htmlall':'UTF-8'}">

    {if $subcategory.id_image}

    getCatImageLink($subcategory.link_rewrite, $subcategory.id_image, 'medium')}" alt="" width="{$mediumSize.width}" height="{$mediumSize.height}" />

    {else}

     

    {/if}

     

     

     

     

    TO

     

    getCategoryLink($subcategory.id_category, $subcategory.link_rewrite)|escape:'htmlall':'UTF-8'}" title="{$subcategory.name|escape:'htmlall':'UTF-8'}">

    {if $subcategory.id_image}

    getCatImageLink($subcategory.link_rewrite, $subcategory.id_image, 'YOUR-NEW-IMAGE-NAME')}" alt="" width="{$YOUR-NEW-IMAGE-NAMESize.width}" height="{$YOUR-NEW-IMAGE-NAMESize.height}" />

    {else}

     

    {/if}

     

     

     

     

    3. Edit /themes/YOURTHEME/css/category.css subcategories section and change

     

    body#category #subcategories li { height: 136px; width: 108px; margin-right: 3px }

     

     

     

    TO

     

    body#category #subcategories li { height: NEW-SIZE-IN-PIXELSpx; width: NEW-SIZE-IN-PIXELSpx; margin-right: 3px }

     

     

     

    The height should be higher then the actual image height in order to display the hyperlinks correctly

     

    4. Edit /controlers/CategoryController.php go to section self::$smarty->assign(array(

    and add

     

    'YOUR-NEW-IMAGE-NAMESize' => Image::getSize('YOUR-NEW-IMAGE-NAME'),

     

     

     

    adding this line will fix the problem of images not displayed in Internet Explorer

    • Like 1
  2. Hi,

     

    I have decoration shop in spain, and I need to clear some points:

    I have local shipping service and I use it to deliver orders to Spain, Portugal, France, Belgium, Italy, Germany and UK. How can I configer the write shipping cost to each country? Can it be sync to the shipping configuration of Prestashop?

     

    I'm interested of your module but I have to learn more bout it before I decide to use it.

     

    Thanx

  3. Hola a todos...

    En primer lugar quisiera agradecer el trabajo de todos aquellos usuarios que con su trabajo y dedicación consiguen que este foro "nos saque las castañas del fuego" a más de uno.
    Muy especialmente a sgame por la versión inicial de este módulo; tambien a ecomesana por su fantástica actualización a la versión v.061 que corrige algunas deficiencias más o menos relevantes de la version inicial (fantástico eso de solucionar el pedido que no quedaba anotado cuando el cliente no pulsaba el aceptar en la página de CECA), y a todos aquellos que con sus comentarios e indicaciones van arrojando pinceladas de luz. (Gracias bernardo2201 por ese tutorial recopilatorio que es de ayuda para muchos).

    Una vez dicho esto, me gustaría dejar aquí escritos un par de comentarios, fruto de experiencia personal con este módulo, por si acaso tambien sirven de ayuda a alguien:

    -Confirmar que la versión v.061 de ecomesana, descargable en este mismo hilo (página 9 creo recordar) funciona OK y mejora sustancialmente versiones anteriores. (especialmente lo ya comentado de un bug al anotar pedidos en el BO).
    Matizar tambien que facilita la instalación pues tan sólo hay que editar "a mano" el archivo cecatpv.php para definir en el la clave de encriptación proporcionada por CECA.

    -Aclarar al amigo bernardo2201, que en su tutorial se dan unas instrucciones que no son imprescindibles y en mi opinión pueden liar al personal.
    En esta versión v.061 de ecomesana, ya no es necesario usar los archivos de cálculo (los que se suben en modo binario por FTP).
    Esta versión reliza la firma mediante la función SHA1 por lo tanto, ese paso es totalmente prescindible. (Yo tengo este módulo sin dichos archivos y funciona correctamente)

    OJO!.. Insisto en que estos archivos de cálculo no son necesarios en la actualización esta hecha por ecomesana... En la original (la de sgame) sí que hacían falta. Así que aseguraos bien cual es el módulo que estais utilizando.

    Lógicamente, si subes los archivos de cálculo a este módulo actualizado por ecomesana funcionará igualmente.. claro está!.. pero no son imprescindibles y tal vez alguien se lie con todo eso del binario, etc...

    -Y avisar de un error que me encontré usando esta versión v.061.
    Resulta que si activo la opción de depuración en la configuración del módulo, este deja de funcionarme.
    Lo he probado en repetidas ocasiones y es así de curioso.
    Con depuración=ON, tras introducir los datos en el formulario del banco devuelve "OPERACIÓN INCORRECTA"; si pongo depuración=OFF y lo reintento funciona perfectamente.

    No es que para mi sea imprescindible recibir ese e-mail debug pero... creo que está bien que se sepa por si acaso a alguien más le pasa... estuve horas y horas peleándome con el módulo a ver porque me daba siempre error si tenía todo perfectamente configurado hasta que se me ocurrió apagar esa opción.
    Desde ese momento.. ¡mano de santo!..

    Saludos a todos.


    Hola bernardo2201,

    Necesitamos ayuda en este modulo para prestashop 1.4.2.5 .... nos puedes ayudar
    Nos da error de comunicación

    Socorrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrro
  4. Muchas gracias por el tutorial. Funcionando a la perfección. Simplemente una anotación, ya que en la instalación, el módulo se mostraba en la sección de otros módulos y no en el de pagos. Solucionando editando el archivo config.xml y cambiando la linea de payments por la que aparece debajo.

    <?xml version="1.0" encoding="UTF-8" ?>

    cecatpv
    CECA TPV
    0.61
    Aceptar pagos con tarjeta vía CECA

    payments_gateways
    1
    0


    Hola PabloGoGo,

    Y o utilizo el modulo CECA 0.61 y últimamente actualicé a prestashop 1.4.2.5, y volví a instalar el modulo y funcionó, pero no apareció como modulo en la sección de “Pago” (sino en la sección de “otros módulos” en el apartado de “Modulos”) ni apareció en el apartado de “Pado -> Restricciones de países”. Al modificar los países con permiso de pagar contra reembolso en “Pado -> Restricciones de países” el modulo de CECA ya no sale entre los métodos de pago para los clientes en el Front Office. He vuelto a instalarlo varios veces pero siempre con el mismo resultado.

    ¿Crees con introducir el código que has puerto arribe se soluciona el el problema?

    Aprecio como todos tu ayuda

    En espera de tu respuesta te mando un cordial saludo

    Sami Orfali
    http://www.decoracionalcazaba.com
  5. Hola Sami,

    La verdad es que es bastante extraño lo que te pasa. Si solamente cambias un número por otro. No entiendo porque te aparece el error. Con las pantallas que me mandas no me resulta fácil saber cual es el origen del error. Podrías hacer lo siguiente:

    En la carpeta config de la tienda hay un archivo que se llama "config.inc.php" y en la tercera línea pone @ini_set('display_errors', 'off');
    podrías cambiarlo a @ini_set('display_errors', 'on'); y luego volver a la lista de módulos para ver que error da realmente el cecatpv. Si haces de nuevo unos pantallazos y me los mandas genial. Despues vuelve a cambiar la línea del config.inc.php a @ini_set('display_errors', 'off');

    Por cierto, que versión estás usando de prestashop?
    Saludos,
    Enrique


    Hola ecomesana,

    Primero Gracias por el modulo, a partir de la problema que te comenté estaba funcionando bien. En su momento no atreví a tocar el código de Prestashop por eso lo dejado tal como estaba.
    Sin embargo, últimamente actualicé a prestashop 1.4.2.5, y volví a instalar el modulo y funcionó (dando el mismo error en el backoffice), pero no apareció como modulo en la sección de "Pago" (sino en la sección de "otros módulos" en el apartado de "Modulos") ni apareció en el apartado de "Pado -> Restricciones de países". Al modificar los países con permiso de pagar contra reembolso en "Pado -> Restricciones de países" el modulo de CECA ya no sale entre los métodos de pago para los clientes en el Front Office. He vuelto a instalarlo varios veces pero siempre con el mismo resultado.

    Creo que necesitamos tu ayuda y una versión nueva 0.7

    Aprecio como todos tu trabajo y voluntad

    En espera de tu respuesta te mando un cordial saludo

    Sami Orfali
    www.decoracionalcazaba.com
  6. Solved,
    Author has released a 1.4 version also free :-)

    Thanks to

    http://prestashop-module.de/payment/82-nachnahme-mit-nachnahmegebuhr-modul-fuer-prestashop.html


    Hi,

    I installed the module in my prestashop 1.4.2.5 and it calculates well. However, when I confirm the last step gives this result: "An order has already been placed using this cart"

    Do I have to do any other configurations?

    Please help
  7. Hola Sami,

    Fijate bien, que solo hayas modificado la clave en el código. Que sigua estando entre comillas y con punto y coma al final.

    Si el error te aparecio despues de modificar la clave y antes de modificarla se te instaló correctamente, es probable que al modificar la clave hayas borrado algo del código del módulo. Puedes probar a borrar el módulo y copiarlo de nuevo.

    Saludos,
    Enrique


    Muchas gracias Enrique,

    Como no se nada de Php ni soy informático, te sugiero que pongas una casilla en el modulo para modificar la clave. Así, la gente como yo no tendrá que pedir ayuda al hosting para modificarlo.

    Agradezco tu esfuerzo y espero que seguimos en contacto

    Saludos cordiales

    Sami
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More