Jump to content

estorde

Members
  • Posts

    16
  • Joined

  • Last visited

Contact Methods

Profile Information

  • Location
    Barcelona
  • Activity
    Freelancer

Recent Profile Visitors

132 profile views

estorde's Achievements

Newbie

Newbie (1/14)

3

Reputation

1

Community Answers

  1. Hi, I have a Prestashop 1.7.5.0 installation, when I do try to edit the User Permissions at the Backend, I´m getting this error: Notice en línea 199 en archivo /home/bnacdn3a/public_html/controllers/admin/AdminAccessController.php [8] Undefined index: name It´s a new installation and I do not modify the "AdminAccessController.php" file. In line 199 is writing: return strnatcmp($a['name'], $b['name']); 197- private function sortModuleByName($a, $b) 198- { 199- return strnatcmp($a['name'], $b['name']); 200- }
  2. Buenas, He encontrado este hilo, tratando de encontrar una solución para Borrar todas las combinaciones de todos los productos. SELECT * FROM satun_product_attribute_combination pac NATURAL JOIN satun_product_attribute pa DELETE pac, pa FROM satun_product_attribute_combination pac NATURAL JOIN satun_product_attribute pa WHERE pa.id_product = * Sin embargo al intentar realizar la siguiente consulta SQL en mi Prestashop 1.7.3 me sale el siguiente error: "DELETE" es una palabra reservada. Seguro que estaré escribiendo algo mal en la orden, porque mis conocimientos de SQL son limitados. Alguien podría ayudarme a crear la orden correcta para poder borrar todas las combinaciones y dejar todos mis productos como productos simples por favor? En realidad los productos son simples, pero de alguna manera al importarlos de manera masiva en la nueva instalación de PS los ha traído con la casilla de Producto con combinaciones activada y es lo que quiero corregir. Muchas gracias
  3. Al intentar ejecutar esta orden desde Parámetros Avanzados > Base de Datos > Gestor SQL SELECT al.name FROM satun_attribute_lang al INNER JOIN satun_product_attribute_combination pac ON pac.id_attribute=al.id_attribute INNER JOIN satun_product_attribute pa ON pac.id_product_attribute = pa.id_product_attribute WHERE pa.id_product=* el prefijo de mis tablas es "satun_" en lugar de "ps_" por eso lo modifiqué en la consulta. Pero me sale el siguiente error: Error indefinido "checkedWhere"
  4. Llevo días buscando algo como esto.... Cómo haría entonces para eliminar TODAS las combinaciones de TODOS los productos?? Siguiendo la orden SQL que has utilizado, podría simplemente eliminar la última fila para que no afecte a un sólo producto, sino a todos? o poner un * en lugar del id de un producto?? DELETE ppa.*,ppac.*,ppas.* FROM ps_product_attribute ppa INNER JOIN ps_product_attribute_combination ppac ON ppa.id_product_attribute=ppac.id_product_attribute INNER JOIN ps_product_attribute_shop ppas ON ppas.id_product_attribute=ppa.id_product_attribute WHERE ppa.id_product=6021 Por cierto, utilizo la versión 1.7.3 de Prestashop por si esto de alguna manera afecta al nombre de las tablas, etc. Muchas gracias
  5. Thank you so much for your effort and time invested on solving this issue Nemo. All the best
  6. @metal1616 Ese era el fallo efectivamente. Muchísimas gracias por tu tiempo, explicación y ayuda
  7. Buenas, Me gustaría poder mostrar en los listados de productos de nuestra web la unidades disponibles, al igual que aparecen en los detalles del producto. Si os fijáis en este detalle de producto por ejemplo, podéis ver que si muestra la cantidad de unidades disponibles para ese producto concreto: https://www.satun.pro/galaxy-s7-g930f/970-pantalla-completa-samsung-galaxy-s7-negro.html en uno de los listados de productos he conseguido modificar el template, de manera que me muestra esta info, pero de alguna manera, no muestra las cantidades disponibles, sino que siempre me muestra el stock a 0 (por defecto muestra un "display:none" para que el usuario final no vea esta info de momento ya que existe este error. https://www.satun.pro/506-galaxy-s7-g930f Me imagino que habrá algún problema en el código que he añadido al archivo product-list.tpl que os pego a continuación {if (!$PS_CATALOG_MODE && $PS_STOCK_MANAGEMENT && ((isset($product.show_price) && $product.show_price) || (isset($product.available_for_order) && $product.available_for_order)))} {if isset($product.available_for_order) && $product.available_for_order && !isset($restricted_country_mode)} <span itemprop="offers" itemscope itemtype="http://schema.org/Offer" class="availability"> {if ($product.allow_oosp || $product.quantity > 0)} <span class="available-now"> <link itemprop="availability" href="http://schema.org/InStock" />{l s='In Stock'} </span> {elseif (isset($product.quantity_all_versions) && $product.quantity_all_versions > 0)} <span class="available-dif"> <link itemprop="availability" href="http://schema.org/LimitedAvailability" />{l s='Product available with different options'} </span> {else} <span class="out-of-stock"> <link itemprop="availability" href="http://schema.org/OutOfStock" />{l s='Out of stock'} </span> {/if} </span> <!-- number of item in stock --> <p id="pQuantityAvailable"{if $product->quantity <= 0} style="display: none;"{/if}> <span id="quantityAvailable">{$product->quantity|intval}</span> <span id="quantityAvailableTxt"{if $product->quantity > 1} style="display: none;"{/if}>{l s='Item'}</span> <span id="quantityAvailableTxtMultiple"{if $product->quantity == 1} style="display: none;"{/if}>{l s='Items'}</span> </p> {/if} De alguna manera <span id="quantityAvailable">{$product->quantity|intval}</span> no está mostrando la cantidad de productos existentes en stock. Además, en teoría, al igual que en los detalles del producto, "<span id="quantityAvailableTxt" no debería ser mostrado si la cantidad es mayor a 1, pero está mostrando ambos textos, ese y "<span id="quantityAvailableTxtMultiple" Alguien podría ayudarme a detectar y corregir el error por favor?? Muchas gracias
  8. Buenas Fredy, siento no tener buenas noticias para ti. Al final, tras semanas sin encontrar respuesta o solución y tras varios emails por privado, facebook y a través de esta plataforma al desarrollador, sólo pude conseguir que me devolvieran el dinero que había pagado por el módulo que nunca me funcionó y me dió bastantes problemas. Una pena porque con un soporte adecuado, creo que podría ser un módulo muy interesante. Pero en mi caso la experiencia es horrorosa
  9. @solnuevo efectivamente es en el fichero "product.tpl" Yo no utilizo la plantilla por defecto, pero aquí puedes ver dónde y con qué tags lo he incluido yo mismo <div class="price"> <p class="our_price_display" itemprop="offers" itemscope itemtype="http://schema.org/Offer"> {if $product->quantity > 0}<link itemprop="availability" href="http://schema.org/InStock"/>{/if} {if $priceDisplay >= 0 && $priceDisplay <= 2} <span id="our_price_display" itemprop="price">{convertPrice price=$productPrice}</span> {if $tax_enabled && ((isset($display_tax_label) && $display_tax_label == 1) || !isset($display_tax_label))} {if $priceDisplay == 1}{l s='tax excl.'}{else}{l s='tax incl.'}{/if} {/if} <div class="price-no-tax">{convertPrice price=$product->getPrice(false, $smarty.const.NULL, 2)} <span class="text-no-tax">{l s='tax excl.'}</span></div> <meta itemprop="priceCurrency" content="{$currency->iso_code}" /> {/if} </p> como puedes ver en los detalles de producto de nuestra tienda https://www.satun.pro/reparaciones-sony-xperia-z5-premium/874-pantalla-completa-sony-xperia-z5-premium-negro.html el hacer más grande, más pequeño, de un color o de otro, lo hacer ya desde la hoja de estilo a tu gusto Saludos
  10. He comprado el módulo Advanced URL hace más de una semana. Desde que lo instalé, la página me ha dejado de funcionar. He tratado de escribir en los foros de Prestashop, escribí al desarrollador a través de Prestashop, luego a través de su email personal e incluso sus cuentas de twitter y facebook, pero no sólo no ha solucionado el problema generado, sino que ni ha contestado siquiera. A través del servicio de atención de Prestashop, me atendió Jasael Pueasn, únicamente me ofrecía comprar su servicio para que pagando me solucionasen el problema, o la compra de otro módulo que parchearía el problema, pero no lo solucionaría. Ya que el módulo lo he pagado a través de ellos, Prestashop debería ser el responsable de exigir una calidad a los módulos que ellos venden y sino, hacerse cargo, exigiendo a los desarrolladores responsabilizarse o de la manera que crean más oportuna. Tras la espera de 6 días sin solución o respuesta alguna, he desabilitado el módulo y ahora me genera otros errores relacionados con las URLs que antes no tenía. De momento, llevo una semana con la tienda inoperativa por culpa de este módulo, y no hay manera de encontrar una solución al problema, así que ahora me gustaría al menos saber cómo recuperar el dinero que me gasté en la compra del módulo en cuestión, por los problemas ocasionados. Tiene que existir algún tipo de garantía sobre los productos que venden. Un servicio de atención PÉSIMO por parte de Prestashop
  11. Para la gestión de mi tienda satun.pro tengo instalada la última versión de Prestashop 1.6.1.4 He comprado hace una semana el módulo Advanced URL para poder eliminar los IDs en las URLs Tras instalar y configurar el módulo en cuestión, tal y como indica la documentación del mismo, me encuentro que el módulo ha funcionado bien en la página de inicio, las páginas CMS, en las categorías o los listados de productos y en los detalles del producto Sin embargo, desde entonces las páginas de contacto, y todas las relacionadas con el usuario: crear cuenta, identifícate, vales descuento, vales, etc resuelven en páginas de error tipo 404 Tras intentar contactar con el desarrollador del plugin a través del formulario habilitado para ello en esta web, conseguí después de 3 días, que Richard (el desarrollador) me facilitara su email, para que el mismo pudiera mirar la configuración del módulo desde el Panel de Control de mi tienda, sin embargo sigo esperando por una respuesta o solución del mismo. Con esto, llevo más de 5 días con la tienda inoperativa, con las consecuencias que para mi negocio esto implica. Quisiera saber si alguien se ha encontrado con este mismo problema y cual sería la solución, ya que necesito solucionar esto
  12. Muchas gracias @ventura, estaba buscando como lograr esto hace un tiempo, y siguiendo tus instrucciones ha resultado muy fácil. Me gustaría añadir esto mismo en los listados de productos "Novedades" y "Top ventas" que aparecen en la home. Que archivo es el que debería modificar? He buscado el archivo homefeatured.tpl dentro de la carpeta de mi theme, pero no lo encuentro.
  13. De momento, he vuelto a dejar el formato de los enlaces, igual que antes, porque no puedo tener la web inoperativa. Por supuesto agradecería mucho ayuda para poder modificar esto
  14. Quería modificar las urls que aparecen durante la navegación de la tienda, para que fueran más lógicas. Para ello en Preferencias > SEO > Formato de los enlaces y he modificado los parámetros tal como aparece a continuación: Ruta a los productos: {category:/}{id}-{rewrite}{-:ean13} Ruta a las categorías: {categories:/}{id}-{rewrite} Ruta a la categoría que tiene el atributo "filtro seleccionado" para el módulo de "Navegación por capas" (blocklayered): {id}-{rewrite}{/:selected_filters} Ruta a los proveedores: {id}__{rewrite} Ruta a los fabricantes: {id}_{rewrite} Ruta a las páginas CMS: {id}-{rewrite} Ruta a las categorías CMS: categoria/{id}-{rewrite} Ruta a los modulos: modulo/{module}{/:controller} y de repente todas las páginas que apuntan a urls que he modificado, navegando desde la web me dan como que "no existen". En rojo aparece, lo que he modificado, que es todo lo que ahora me da error de "página no existe", así por ejemplo, antes estaba como sigue: Ruta a las categorías: {id}-{rewrite} Supongo que a lo mejor tiene que ver algo con la caché, pero he ido a la sección Parámetros avanzados > Rendimiento donde he borrado la caché y la opción de Forzar compilación está activada Podéis intentar navegar por la web https://www.satun.pro/ por las secciones Reparaciones, Accesorios o por Información en el pié de página para ver mejor de lo que hablo. Alguien conoce el motivo o la solución? Muchas gracias
  15. Buenas Tengo el mismo problema. El módulo "Bloque Social" ya me aparece insertado tanto en "displayFooter" como en "displayHeader" y no me permite añadirlo a "displayNav" Así que no logro hacer que aparezca en la cabecera la lista de iconos sociales ¿Alguna otra sugerencia?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More