Jump to content

PayPalIberia

Members
  • Posts

    5
  • Joined

  • Last visited

Everything posted by PayPalIberia

  1. Atención: (202) recomienda actualizar a la versión 3.8.1. cuando se está utilizando la versión Prestashop 1.4 y Smarty. Más detalles en su post en inglés: http://www.prestashop.com/forums/topic/380185-paypal-modification-ssl-v3-to-tls/
  2. Hola, Puedes descargar la versión de Prestashop en la sección de versiones y rescatar el modulo que ya tenías. A partir de ahí, seguir las instrucciones que mostramos en el primer post (han sido editadas). Pero si aun así no se soluciona, puedes tocar el código manualmente… tienes que ir al siguiente fichero: prestashop\modules\paypal\api\paypal_connect.php Y Añadir/Editar estas 2 lineas: @curl_setopt($ch, CURLOPT_SSLVERSION, 4); @curl_setopt($ch, CURLOPT_SSL_CIPHER_LIST, 'SSLv3'); Espero que sea de ayuda.
  3. Hi all, Since the SSL v3 issue (also known as POODLE) was identified on October 14, PayPal has decided to completely disable SSL 3.0 support at 12:01 a.m. Pacific Standard Time on December 3, 2014. POODLE is an internet security vulnerability that impacts the Secure Sockets Layer (SSL) 3.0 protocol, which was designed to ensure secure connections when surfing on the Internet. As a consequence all PayPal merchant customers using PrestaShop need to update their PayPal integration by upgrading their PayPal module on PrestaShop before December 3rd disable SSL 3.0 for their client interactions. If you do not upgrade your PayPal module on PrestaShop by this date, you may face interruptions to your ability to accept payments with PayPal. To make sure your integration is protected against this vulnerability and to keep accepting PayPal payments beyond this date, you need to upgrade your PayPal module to version 3.8.0 by following these steps: Users of version 1.5 and 1.6 of PrestaShop 1- Go to PrestaShop back office in the list of modules installed 2- Click on the « Update it » button next to PayPal module If this button doesn’t appear, please follow the same steps as the ones described below for “users of version 1.4 de PrestaShop” The upgrade to version 3.8.0 will then complete. If it doesn’t, please follow the steps below. Users of version 1.4 of PrestaShop 1. Go to the PrestaShop Addons website and download the latest version of the PayPal module (version 3.8.0) 2. You need to carry out a manual update of the module. Please go to the “Modules” section in the Back Office of your store 3. Click on “Upload the module from your computer” , you should get the screen below: 4. Insert the downloaded file in zip format 5. Click on « Upload this module » The upgrade to version 3.8.0 will then complete. Caution: If the message "Before using the module, you must install the compatibility Retro Module" appears after your being updated, thank you download and install the "Retro compatibility" module at this address: http://addons.presta...patibility.html We make every effort to help you as quickly as possible and we apologize for any inconvenience due to this problem. Regard, PayPal Iberia
  4. Hi, The update of Prestashop module will be available on Tuesday November 18th, 2014 on Addons (Versión 3.8.0 to come). You can find more information in this post: http://www.prestashop.com/forums/topic/380185-paypal-modification-ssl-v3-to-tls/ Hope it helps.
  5. Hola a todos, Con motivo de la vulnerabilidad del protocolo SSL v3 (también conocido como POODLE) que fue detectada el 14 de octubre, PayPal ha estado trabajando para mitigar cualquier posible impacto en nuestros clientes y, por ello, hemos decidido desactivar completamente la compatibilidad con SSL 3.0 el 3 de diciembre de 2014 a las 12:01 AM (Pacific Standard Time). POODLE es una vulnerabilidad de seguridad de Internet que afecta al protocolo Secure Sockets Layer (SSL) 3.0, que se diseñó para garantizar la seguridad de las conexiones al navegar por Internet. Como consecuencia, todas las tiendas que utilizan Prestashop tienen que cambiar su integración con PayPal actualizando el módulo de PayPal en Prestashop antes del 3 de diciembre de 2014 y desactivar de este modo el SSL 3.0 para las interacciones con clientes. Si no actualiza su módulo antes de esta fecha, es posible que sufra problemas a la hora de procesar pagos a través de PayPal. Para asegurarse de que su integración está protegida contra esta vulnerabilidad y de que podrá seguir aceptando pagos tras esta fecha, tiene que actualizar su módulo de PayPal a la versión 3.8.0 siguiendo estos pasos: Usuarios de la versión 1.5 y 1.6 de PrestaShop: 1- Vaya al back office de PrestaShop a la lista de módulos instalados. 2- Haga clic en “Actualícelo” en el módulo de PayPal. La actualización a la versión 3.8.0 se habrá completado. Si no es así, siga los pasos que indicamos a continuación. Usuarios de la versión 1.4 de PrestaShop: 1. Vaya la página web de PrestaShop Addons y descargue la última versión del módulo de PayPal ( versión 3.8.0). 2. Será necesario llevar a cabo una actualización manual del módulo. Para ello, vaya a la sección "Módulos" en el Back Office de su tienda. 3. Haga clic en "Cargar el módulo desde su ordenador" y verá la siguiente pantalla: 4. Inserte el archivo descargado en formato zip. 5. Haga clic en “Subir este módulo”. La actualización a la versión 3.8.0 habrá finalizado. Si ha instalado el nuevo módulo y tiene problemas, como última alternativa podría recuperar la anterior versión en Prestashop en la sección de versiones y seguir las instrucciones mencionadas arriba. Si no consigue solucionarlo, podría: 1. Editar el código manualmente en el siguiente fichero: prestashop\modules\paypal\api\paypal_connect.php 2. Añadir/Editar estas 2 lineas: @curl_setopt($ch, CURLOPT_SSLVERSION, 4); @curl_setopt($ch, CURLOPT_SSL_CIPHER_LIST, 'SSLv3'); Si es una agencia web o desarrollador y necesita asistencia directa, le recomendamos que se registre en el Programa de partners de PayPal en www.paypal.es/partner-program para recibir respuesta personalizada. Si es un vendedor, puede contactar con nuestro Servicio de Atención al Cliente en www.paypal.es/contact. Realizar esta acción puede parecer un reto, sobre todo en esta época del año, pero confiamos en que entienda que esto le ayudará a hacer frente a las vulnerabilidades que puedan surgir de POODLE y a preservar las normas de seguridad habituales al usar PayPal en PrestaShop. Muchas gracias
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More